Bug 167291 - CAPI subsystem not working with udev
CAPI subsystem not working with udev
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: udev (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
NdRvw
:
Depends On:
Blocks: 181409
  Show dependency treegraph
 
Reported: 2005-09-01 08:10 EDT by Peter Bieringer
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2006-0382
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 17:16:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2005-09-01 08:10:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Description of problem:
Same as happen in FC4:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=139321

Version-Release number of selected component (if applicable):
udev-039-10.8.EL4

How reproducible:
Always

Steps to Reproduce:
1. put AVM B1 ISDN card into system
2. try to load firmware


Actual Results:  # /sbin/avmcapictrl load /etc/firmware/isdn/b1.t4 1
Device file /dev/capi20 and /dev/isdn/capi20 missing, use instdev: No such file or directory


Expected Results:  # /sbin/avmcapictrl load /etc/firmware/isdn/b1.t4 1
Loading Bootcode /etc/firmware/isdn/b1.t4 ... done


Additional info:
Comment 1 Uwe Beck 2005-10-04 16:47:15 EDT
With AVM PCI (Fritz!PCI v2) isdn card /dev/capi20 also missing.
Comment 11 Danilo Godec 2006-03-22 05:31:07 EST
I tried the udev fix as proposed in the FC4 bug report
([url=https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=139321#c5]), but
still have issues:

1. using the 'standard' capiinit (from isdn4k-utils package) doesn't work even
with the fix - no /dev/capi20 and /dev/capi/* device nodes are created.

2. I compiled capi4k-utils-2005.07.18 which provides a newer capiinit (and some
other utilities). With it the first time I run 'capiinit' it fails, but a couple
of seconds later the /dev/capi20 and /dev/capi/* device nodes are created. If I
run 'capiinit' once more, it starts fine.

 D.
Comment 12 Peter Bieringer 2006-03-22 05:36:16 EST
Your second point looks like to me as the usual udev problem after loading a
module (e.g. by a trigger). udev need some time to create the device node
(sometimes up to 20 seconds). So one have to debug which code in capiinit
triggers loading of module. Here it has to wait some time until the device node
is created successfully by udev.
Comment 17 Bob Johnson 2006-04-11 13:01:21 EDT
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 4.4 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 4.4 release.
Comment 18 Harald Hoyer 2006-04-18 07:51:30 EDT
please test:
ftp://people.redhat.com/harald/udev/039-10.14.EL4/
Comment 22 Red Hat Bugzilla 2006-08-10 17:16:58 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0382.html
Comment 24 Jeff Layton 2006-08-16 11:03:44 EDT
It turns out that the rules that were added to fix this are not restrictive
enough. They make no distinction between block and character devices.
Unfortunately, I don't have one of these devices, so it's tough for me to
suggest a new rule to fix it.

Would someone with one of these cards be kind enough to run:

udevinfo -q all -n /dev/capi20
udevinfo -q all -n /dev/capi/0

and post the output here?
Comment 25 Peter Bieringer 2006-08-16 11:09:51 EDT
I have still not updated the selinux policy, but here the output as requested:

# udevinfo -q all -n /dev/capi20
P: /class/capi/capi
N: capi20
T: c
M: 020660
S:
O: root
G: root
F: /etc/udev/rules.d/10-capi.rules
L: 1
U: 38
R: 0

# udevinfo -q all -n /dev/capi/0
P: /class/tty/capi0
N: capi/0
T: c
M: 020660
S:
O: root
G: root
F: /etc/udev/rules.d/10-capi.rules
L: 2
U: 38
R: 0

Note You need to log in before you can comment on or make changes to this bug.