This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 167300 - sendmail: auxpropfunc error invalid parameter supplied
sendmail: auxpropfunc error invalid parameter supplied
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cyrus-sasl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
http://www.openldap.org/lists/openlda...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-01 10:03 EDT by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.1.21-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-01 18:11:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2005-09-01 10:03:08 EDT
Description of problem:
I've the following error message in syslog (/var/log/messages) after updating to 
Rawhide and restarting saslauthd and sendmail:

[...] sendmail[18698]: auxpropfunc error invalid parameter supplied

Version-Release number of selected component (if applicable):
sendmail-8.13.4-2
cyrus-sasl-2.1.21-2
cyrus-sasl-2.1.21-3
openldap-2.2.26-1

Steps to Reproduce & how reproducible:
Everytime, restart sendmail.

Actual results:
I searched a bit in the Internet and only got, that the problem is ldapdb 
related. When I built cyrus-sasl myself with --disable-ldapdb, the problem 
disappeared.

Expected results:
No error message in syslog! ;-)

Additional info:
I filed this bug against cyrus-sasl, because I think this problem caused by 
cyrus-sasl and not by sendmail.
Comment 1 Nalin Dahyabhai 2005-09-01 16:11:54 EDT
The ldapdb plugin gets loaded, and I don't see any way to disable it in your
configuration without also disabling sasldb support.  As a temporary workaround,
try adding "ldapdb_uri: ldapi:///" to /usr/lib/sasl2/Sendmail.conf.
Comment 2 Nalin Dahyabhai 2005-09-01 16:17:32 EDT
I guess moving the ldapdb auxprop module into yet another subpackage is the most
workable solution.

Note You need to log in before you can comment on or make changes to this bug.