Bug 1673214 - Review Request: mandoc - A suite of tools for compiling mdoc and man
Summary: Review Request: mandoc - A suite of tools for compiling mdoc and man
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-06 23:15 UTC by David Shea
Modified: 2019-04-18 19:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-16 02:26:34 UTC
dcantrell: fedora-review+


Attachments (Terms of Use)

Description David Shea 2019-02-06 23:15:43 UTC
Spec URL: https://copr-be.cloud.fedoraproject.org/results/dshea/mandoc/fedora-rawhide-x86_64/00855579-mandoc/mandoc.spec
SRPM URL: https://copr-be.cloud.fedoraproject.org/results/dshea/mandoc/fedora-rawhide-x86_64/00855579-mandoc/mandoc-1.14.4-1.fc30.src.rpm

Description:
mandoc is a suite of tools compiling mdoc, the roff macro language of choice
for BSD manual pages, and man, the predominant historical language for UNIX
manuals. It is small, ISO C, ISC-licensed, and quite fast. The main component
of the toolset is the mandoc utility program, based on the libmandoc validating
compiler, to format output for UTF-8 and ASCII UNIX terminals, HTML 5,
PostScript, and PDF.

Fedora Account System Username: dshea

Comment 1 David Cantrell 2019-02-07 16:40:32 UTC
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated


Issues:
=======
- Header files in -devel subpackage, if present.
  Note: mandoc-debugsource :
  /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/compat_ohash.h mandoc-
  debugsource :
  /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/compat_stringlist.h mandoc-
  debugsource : /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/config.h mandoc-
  debugsource : /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/dba.h mandoc-
  debugsource : /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/dba_array.h
  mandoc-debugsource :
  /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/dba_write.h mandoc-debugsource
  : /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/dbm.h mandoc-debugsource :
  /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/dbm_map.h mandoc-debugsource :
  /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/html.h mandoc-debugsource :
  /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/libman.h mandoc-debugsource :
  /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/libmandoc.h mandoc-debugsource
  : /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/libmdoc.h mandoc-debugsource
  : /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/libroff.h mandoc-debugsource
  : /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/main.h mandoc-debugsource :
  /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/man.h mandoc-debugsource :
  /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/manconf.h mandoc-debugsource :
  /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/mandoc.h mandoc-debugsource :
  /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/mandoc_aux.h mandoc-
  debugsource : /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/mandoc_ohash.h
  mandoc-debugsource :
  /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/mandoc_xr.h mandoc-debugsource
  : /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/mansearch.h mandoc-
  debugsource : /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/mdoc.h mandoc-
  debugsource : /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/out.h mandoc-
  debugsource : /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/roff.h mandoc-
  debugsource : /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/roff_int.h
  mandoc-debugsource : /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/tag.h
  mandoc-debugsource : /usr/src/debug/mandoc-1.14.4-1.fc29.x86_64/term.h
  See: http://fedoraproject.org/wiki/Packaging/Guidelines#DevelPackages
- All build dependencies are listed in BuildRequires, except for any that
  are listed in the exceptions section of Packaging Guidelines.
  Note: These BR are not needed: gcc make
  See: http://fedoraproject.org/wiki/Packaging/Guidelines#Exceptions_2
- ldconfig called in %post and %postun if required.
  Note: /sbin/ldconfig not called in libmandoc
  See: http://fedoraproject.org/wiki/Packaging/Guidelines#Shared_Libraries


===== MUST items =====

C/C++:
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.
[x]: Development (unversioned) .so files in -devel subpackage, if present.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "BSD 3-clause "New" or "Revised" License", "ISC License",
     "Unknown or generated", "BSD 2-clause "Simplified" License". 1676
     files have unknown license. Detailed output of licensecheck in
     /home/dcantrel/mandoc/1673214-mandoc/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[x]: Package does not own files or directories owned by other packages.
     Note: Dirs in package are owned also by: /usr/lib/.build-id(qemu-ui-
     gtk, libvirt-wireshark, libhbalinux, cups-client, efivar-libs,
     rsyslog, xml-security-c, lz4-libs, qemu-block-gluster, rpm-plugin-
     selinux, libmediaart, libimagequant, giflib, libreoffice-
     graphicfilter, trousers, ots-libs, libdb-utils, tracker-miners,
     xorg-x11-font-utils, libvirt-daemon-driver-vbox, OpenEXR-libs,
     libcom_err, libseccomp, p11-kit, libabw, gtkspell, libvirt-daemon-
     driver-storage-iscsi, libid3tag, libmodman, claws-mail-plugins-smime,
     cfitsio, argyllcms, parted, gnome-disk-utility, libdvdread, zstd,
     bluez-libs, libbs2b, libwebp, libxslt, system-config-printer-udev,
     perl-Encode, libverto-libev, python2-cryptography, libevdev, libgpg-
     error, libmaxminddb, lvm2-libs, libpurple, perl-Digest-SHA, perl-
     Params-Classify, libsodium, python3-unbound, libzstd, gtk-murrine-
     engine, qemu-system-ppc-core, lua-lpeg, symlinks, python3-simplejson,
     python3-crypto, libcdr, cdparanoia-libs, e2fsprogs-libs, pulseaudio-
     libs, claws-mail-plugins-attachwarner, libdwarf, ltrace, gcc-plugin-
     devel, lcms2, docker-rhel-push-plugin, qemu-guest-agent, annobin,
     deltarpm, libxcb, libyubikey, python3-pycurl, postgresql-libs, rtkit,
     xcb-util-keysyms, m4, xfce4-systemload-plugin, libgphoto2, cdparanoia,
     xcb-util, libwmf-lite, clutter-gtk, libabiword, xfce4-pulseaudio-
     plugin, python3-coverage, krb5-devel, anaconda-widgets, http-parser,
     java-1.8.0-openjdk, pulseaudio-utils, perl-Sub-Identify, llvm5.0-libs,
     perl-PerlIO-utf8_strict, libeot, systemd-bootchart, perl-Ref-Util-XS,
     libvirt-admin, perl-Time-Piece, xdelta, ncurses-libs, libidn2, virt-
     viewer, ldns, perl-Sys-Syslog, gnome-color-manager, fcoe-utils,
     libyui-mga-ncurses, xorg-x11-xkb-utils, perl-IO-Tty, NetworkManager-
     openvpn, libxkbfile, hplip-libs, libwvstreams, xmlrpc-c-client, sane-
     backends-drivers-cameras, python3-hawkey, libwpd, enchant2, libdc1394,
     libvirt-daemon-driver-qemu, perl-Time-HiRes, qemu-block-ssh, libwps,
     gssdp, libacl, xorg-x11-drv-ati, libSM, policycoreutils, qemu-block-
     iscsi, mcelog, pptp, sane-backends-drivers-scanners, libXxf86misc,
     foomatic, colord-gtk, dbus-x11, libpath_utils, libicu-devel, rpm-
     build, libvirt-daemon-driver-storage-sheepdog, libglvnd-gles,
     python3-audit, redhat-lsb-core, libmicrodns, python2-saslwrapper,
     claws-mail-plugins-archive, freeglut, gstreamer1, bsdtar, gom,
     libvirt-sandbox-libs, gmime30, libtomcrypt, ccache, sshpass,
     libreoffice-gtk3, aiksaurus, boost-wave, cairo-gobject, vim-minimal,
     leafpad, libclastfm, gutenprint, openal-soft, usermode, xarchiver,
     qpdf-libs, linux-atm-libs, libedit, openssh, guvcview, chrpath,
     subversion-libs, libvirt-gconfig, python3-cairo, python2-libdnf,
     accountsservice, isl, python2-qpid-proton, hfsplus-tools, ImageMagick,
     perl-IPC-SysV, gssproxy, mesa-libGLU, libblockdev-btrfs,
     libatomic_ops, x11-ssh-askpass, python3-libs, gupnp-av, clang6.0-libs,
     librepo, gtk-update-icon-cache, bsd-games, geany, python3-iscsi-
     initiator-utils, libyui-ncurses, libvirt-daemon-driver-interface,
     NetworkManager, libkate, liblangtag, libdatrie, glade-libs, setuptool,
     guile, pcre-utf16, tree, isdn4k-utils, pipewire, python2-kiwisolver,
     gnupg, libnsl2, libserf, xfsprogs, libhbaapi, authselect, boost-timer,
     libcroco, xfce4-dict, NetworkManager-iodine, python3-lazy-object-
     proxy, telepathy-glib, NetworkManager-fortisslvpn-gnome, plymouth-
     plugin-label, libisoburn, colord-libs, aalib-libs, gstreamer1-libav,
     libcddb, totem-pl-parser, gpgmepp, libzhuyin, gvnc, hypervfcopyd,
     cronie, libwnck, rpm-libs, libjpeg-turbo-utils, libuv, nettle,
     libcacard, elfutils, colord, libpipeline, pkcs11-helper,
     accountsservice-libs, gstreamer-plugins-ugly, network-scripts,
     findutils, popt, x264, python2-xpyb, qt5-qtx11extras, libsss_idmap,
     imsettings-gsettings, libraw1394, boost-atomic, ocp, lm_sensors,
     gcc-c++, iptables, iproute-tc, libipa_hbac, libupnp, goffice, spice-
     glib, woff2, python2-numpy, libXfont, jigdo, PackageKit-glib, patch,
     sqlite-libs, lttng-ust, enchant, libXxf86dga, python2-smartcols,
     rhash, xdg-user-dirs-gtk, perl-Data-Dumper, libwayland-client,
     pinentry-gnome3, pwgen, libipt, libofx, mdadm, device-mapper,
     python2-librepo, libXtst, xapian-core-libs, irqbalance, GeoIP, perl-
     Class-XSAccessor, clamav, wv, libsigc++20, xmlrpc-c-client++,
     libXrandr, newt, liba52, hplip, python2-libuser, crda, libical,
     sheepdog, qt5-qtdeclarative, vo-amrwbenc, libXfont2, libblockdev-loop,
     libmfx, libssh2, byacc, NetworkManager-adsl, open-vm-tools-desktop,
     xmlsec1-nss, libXcursor, nftables, iio-sensor-proxy, boost-python2,
     procps-ng, plymouth-core-libs, telnet, libXpm, xorg-x11-drv-nouveau,
     bluez-obexd, zlib, libpeas, pam_krb5, gutenprint-cups, PackageKit-
     gstreamer-plugin, avahi, libselinux, ncurses-compat-libs, libassuan,
     expat, cups-filters, iw, boost-fiber, librdmacm, userspace-rcu, qemu-
     system-sh4-core, libblockdev-utils, dumpet, libgudev, python3-yui,
     live555, setroubleshoot-server, make, python3-markupsafe, galculator,
     libnice, libsoup, xfce4-xkb-plugin, libetpan, glusterfs-api, fuse,
     perl-Net-SSLeay, perl-Filter, rrdtool, cups-libs, libsepol, efivar,
     gzip, autogen-libopts, usermode-gtk, keyutils, isomd5sum, libfdisk,
     libdmx, sox-plugins-nonfree, openssl-libs, corosynclib, opencc,
     libreport-plugin-reportuploader, qemu-system-moxie-core, gavl, ipset,
     x265-libs, unique, libyui-gtk, libcaca, keybinder3, ntfs-3g, fuse-
     libs, gwenhywfar, xfce4-weather-plugin, xorg-x11-xauth, libglvnd-glx,
     libcue, libXrender, json-glib, libX11-xcb, libfontenc, libicu, libgsf,
     xorg-x11-drv-vmware, xfce-polkit, sssd-common, NetworkManager-
     openconnect, libgtop2, x3270-x11, ristretto, tracker, sssd-common-pac,
     python2-pandas, goffice08, perl-Devel-PPPort, openconnect, protobuf-c,
     xerces-c, openssh-askpass, mesa-libglapi, bolt, glx-utils, libtommath,
     postgresql, ykpers, libquadmath, daxctl-libs, numad, python2-evdev,
     boost-container, fswebcam, boost-math, SDL_image, texlive-lib, ppp,
     sox, libtiger, git, perl-Compress-Raw-Bzip2, jack-audio-connection-
     kit, mpg123-libs, opus, ctags, tcpdump, zisofs-tools, libxklavier,
     traceroute, cyrus-sasl-plain, dyninst, libblockdev-crypto, pcsc-lite-
     ccid, libreoffice-pdfimport, xfce4-mount-plugin, rp-pppoe, libtheora,
     attr, mtr, gtksourceview3, iniparser, pugixml, libcanberra-gtk2,
     libcanberra-gtk3, boost-program-options, mtdev, mailx, systemd-udev,
     fftw-libs-single, libXvMC, cheese-libs, tix, python2-pillow, quota,
     libXmu, python2-crypto, capstone, libreoffice-impress, smartmontools,
     jasper-libs, librbd1, device-mapper-libs, xorg-x11-xinit, libogg,
     libffi, libGLEW, pcre-utf32, python2-hawkey, diffutils,
     libgnomecanvas, time, checkpolicy, mpfr, tinyxml, cyrus-sasl-md5,
     iputils, SDL_ttf, qt5-qtxmlpatterns, numactl-libs, libvirt-daemon-
     driver-nwfilter, btrfs-progs, gvfs-fuse, tigervnc-server-minimal,
     gpgme, ninja-build, hypervvssd, xorg-x11-drv-openchrome, gcc-gfortran,
     libmcpp, libibverbs, rpm-devel, dleyna-core, qemu-audio-pa, libgovirt,
     libqmi-utils, libmbim-utils, psacct, lame-libs, gnome-bluetooth-libs,
     VirtualBox, usbredir, ghostscript, iproute, iptables-libs, gnucash,
     fftw, cryptsetup-libs, syslinux-extlinux, SDL2_image, bind-libs,
     pygobject2, boost-type_erasure, ghostscript-x11, lua-posix, libinput,
     libreport-cli, libpkgconf, libyui-mga, libosinfo, wireshark-cli,
     corosync, im-chooser, qt5-qtsvg, libreoffice-calc, libqmi, gawk,
     dmraid-events, pcsc-lite-libs, adwaita-gtk2-theme, libbasicobjects,
     qemu-system-mips-core, hdf5, rdma-core, vte291, libgweather, sssd-
     krb5, nmap, NetworkManager-strongswan-gnome, perl-Devel-Peek, brotli,
     libgrss, libdvbpsi, httpd, libsmbclient, transmission-gtk, libkcapi,
     libvdpau, compat-openssl10, opencore-amr, libnftnl, sstp-client,
     oddjob-mkhomedir, python3-libvirt, network-manager-applet,
     openCOLLADA, xcb-util-renderutil, sssd-ad, python2-Bottleneck, rclone,
     lightdm, libpinyin, freetype, logrotate, patchelf, libkadm5, libdnet,
     ntfsprogs, protobuf, efibootmgr, libgdither, boost-signals, libgusb,
     samba-common-libs, libreswan, libpsl, qemu-system-or1k-core, libass,
     python3-rpm, sl, jimtcl, libuser, NetworkManager-libreswan, opensp,
     libnotify, graphviz, kexec-tools, opensc, boost-date-time,
     python3-libdnf, vte, wvdial, python2-subprocess32, libglade2, satyr,
     gts, pixman, wpa_supplicant, xorg-x11-drv-vesa, libbluray,
     python2-coverage, cifs-utils, libstdc++, libbabeltrace, apr-util-bdb,
     systemd, vpnc, psmisc, net-snmp-libs, xorg-x11-drv-libinput, cscope,
     libsss_certmap, libblockdev-mpath, ed, libgcc, gdisk, ilmbase, perl-
     Compress-Bzip2, xfce4-settings, poppler, pocl, djvulibre-libs, gnome-
     online-accounts, claws-mail, fftw-libs-double, libconfig,
     ModemManager, gnumeric, midori, qemu-img, qt5-qtbase-gui,
     xfce4-screenshooter, sgpio, orc, polkit, libuuid, faad2-libs,
     libarchive, libfreehand, xfdesktop, qemu-system-aarch64-core,
     python2-libselinux, cheese, udisks2, xfce4-dict-plugin, clucene-
     contribs-lib, paps-libs, tcp_wrappers, xz, libXcomposite, rpcbind,
     mtools, pygtk2, xfce4-sensors-plugin, criu, python3-matplotlib-tk,
     harfbuzz-icu, libplist, nghttp2, gstreamer-tools, xdg-user-dirs,
     hwloc-libs, spice-server, thunar-volman, gdk-pixbuf2, xscreensaver-
     base, gst-transcoder, gupnp, libreport, libevent, redland, libknet1
     -crypto-nss-plugin, python2-cccolutils, git-core, link-grammar,
     python3-tkinter, zsh, xfce4-notifyd, NetworkManager-ssh, clucene-core,
     dash, libblockdev, ypbind, lua-socket, dconf, xz-libs, dbus-glib,
     minisat2-libs, bash, python3-kiwisolver, libmpc, libdvdnav,
     strongswan, libcap, libprojectM, libvirt-daemon-driver-storage-zfs,
     libwbclient, compiler-rt, libvirt-daemon-driver-storage-gluster,
     python3-bcrypt, NetworkManager-fortisslvpn, xfdashboard, libXp,
     mod_http2, libthai, fakeroot, nss-tools, adcli, libtirpc, python2-gpg,
     libsmartcols, boost-test, fakeroot-libs, cargo, oci-systemd-hook,
     xfce4-verve-plugin, orc-compiler, libyui-qt-graph, xfburn, os-prober,
     ethtool, vorbis-tools, qemu-system-alpha-core, libfprint, systemd-
     libs, cpio, libknet1, libfdt, util-linux, libburn, imsettings,
     krb5-libs, bison, net-tools, claws-mail-plugins-spam-report, htop,
     enca, llvm6.0-libs, libblockdev-part, libpciaccess, gpart,
     libsss_autofs, kmod, NetworkManager-ssh-gnome, libxml++,
     NetworkManager-pptp, libetonyek, plymouth, libgs, python2-pwquality,
     sssd-client, libgxps, screen, jq, webkit2gtk3-jsc, libpagemaker,
     libxkbcommon, device-mapper-multipath-libs, yajl, lockdev, cups-
     filters-libs, geocode-glib, lpsolve, xorg-x11-server-utils,
     NetworkManager-bluetooth, vid.stab, libvirt-daemon-driver-storage-
     iscsi-direct, cracklib, evince-libs, python2-tkinter, libepubgen,
     libdnf, qemu-system-m68k-core, ruby, gnuplot-common, gmp-c++,
     libdbusmenu-gtk3, libdbusmenu-gtk2, pulseaudio-libs-glib2, libnice-
     gstreamer1, netpbm, nm-connection-editor, python3-pyparted,
     libudisks2, gstreamer1-plugins-bad-free, NetworkManager-libreswan-
     gnome, python3-setools, clutter, zenity, chkconfig, libgnome-keyring,
     hostname, xfce4-battery-plugin, gparted, pangox-compat, librados2,
     libvirt-daemon-driver-storage-mpath, pam, python2-cffi, openldap,
     oniguruma, python3-ldap, ipcalc, SDL, speex, libvirt-daemon-driver-
     storage-logical, audacious-libs, neon, rest, libsamplerate,
     python2-lxml, xfce4-cpugraph-plugin, boost-iostreams, poppler-utils,
     pakchois, subversion, zfs-fuse, systemtap-runtime, libusbmuxd, perl-
     Unicode-Normalize, gperftools-libs, libimobiledevice, lzop, nss_nis,
     NetworkManager-wwan, claws-mail-plugins-newmail, xen-runtime, polkit-
     pkla-compat, jbig2dec-libs, libmtp, compface, librevenge, xterm-
     resize, python3-gobject-base, gnome-settings-daemon, xfce4-appfinder,
     dnsmasq, geoclue2-libs, libXfixes, libblkid, libcdio, libsss_sudo,
     rsync, lua-libs, pavucontrol, perl-Params-Util, ddd, authselect-libs,
     soundtouch, xorg-x11-drv-evdev, kmod-
     VirtualBox-4.20.4-200.fc29.x86_64, xfce4-netload-plugin, libXinerama,
     lirc-libs, libteam, vim-enhanced, libcmis, libesmtp, acl, cyrus-sasl-
     scram, boost-numpy2, qemu-system-lm32-core, xfce4-session,
     xorg-x11-apps, libphodav, irssi, gstreamer-plugins-base, libgee,
     libXxf86vm, mesa-libEGL, python2-pyxattr, rpm-plugin-systemd-inhibit,
     systemd-pam, python2-libvirt, libyui-mga-qt, ftgl, libwpg, perl-
     Storable, perl-Digest-MD5, lua-term, libreoffice-ogltrans, libshout,
     SDL_gfx, perl-Sort-Key, glib2-devel, libvirt-daemon-driver-storage-
     rbd, libnfsidmap, nss-util, libsemanage, marisa, rust, mozjs52,
     systemd-container, libcomps, libaec, gtk3-devel, at, file, aisleriot,
     libdca, libblockdev-fs, chrony, libblockdev-nvdimm, libnma, gettext,
     gource, pcre2-utf32, soxr, oci-umount, libvirt-gobject, libutempter,
     gnome-remote-desktop, libmetalink, slang, openblas-serial, usbutils,
     e2fsprogs, libcdio-paranoia, grub2-tools-minimal, cpp, oprofile,
     libksba, libwayland-server, virglrenderer, dracut, gdbm,
     libchromaprint, osinfo-db-tools, libsndfile, libblockdev-vdo,
     libvisio, tk, ruby-libs, bzip2-libs, NetworkManager-iodine-gnome,
     dbus-libs, gnome-keyring, boost-log, openssl-pkcs11, libreoffice-gtk2,
     gnutls, ncftp, jack-audio-connection-kit-example-clients, libyui-mga-
     gtk, xmlrpc-c-apps, device-mapper-persistent-data, python2-krbv,
     webkit2gtk3-plugin-process-gtk2, libselinux-utils, perl-Scalar-List-
     Utils, dosfstools, rng-tools, libspectre, compat-
     openssl10-pkcs11-helper, nano, keyutils-libs, libproxy, libreoffice-
     math, libtimezonemap, libyui, ghc-base, glusterfs-fuse, game-music-
     emu, pidgin, anaconda-core, vim-X11, libkkc, xfce4-clipman-plugin,
     libatasmart, perl-XML-Parser, mlocate, tmux, file-libs, grub2-tools,
     tnftp, avahi-glib, mokutil, libblockdev-swap, libnetfilter_conntrack,
     python3-gobject, libev, xfce4-datetime-plugin, gdb-headless, frei0r-
     plugins, fprintd-pam, libXpresent, libusbx, NetworkManager-openvpn-
     gnome, qrencode-libs, libICE, xfce4-places-plugin, libgexiv2, flac,
     drpm, qemu-block-nfs, createrepo_c-libs, grilo, perl-Compress-Raw-
     Zlib, libindicator-gtk3, speexdsp, libntlm, upower, java-1.8.0
     -openjdk-devel, libreoffice-x11, perl-File-RsyncP, xcb-util-wm,
     diffstat, clamav-lib, Thunar, atk, python3-psycopg2, dbxtool, libvirt-
     daemon-driver-lxc, pragha, alsa-lib, gstreamer1-plugins-good-gtk,
     libwnck3, x264-libs, python2-gobject, gtkmm24, libvirt-daemon-driver-
     storage-disk, xfce4-about, mesa-dri-drivers, pyliblzma, libffado,
     suitesparse, gdbm-libs, fribidi, libgnomekbd, libblockdev-kbd,
     pciutils, libini_config, openssh-clients, blosc, libX11, celt051,
     beignet, iscsi-initiator-utils, kyotocabinet-libs, python3-pwquality,
     python3-cryptography, gnome-bluetooth, u2f-hidraw-policy, libnl3,
     gimp-libs, libmikmod, libnatpmp, NetworkManager-sstp, libidn,
     BackupPC, grubby, openjpeg-libs, amrwb, python3-libreport,
     libdbusmenu, libdbi, libbytesize, libmpeg2, qemu-block-rbd,
     python3-systemd, libnl3-cli, python2-libcomps, python2-pyyaml, audit-
     libs, bluez, motif-devel, gettext-libs, liborcus, cups, qt5-qtwayland,
     libref_array, switcheroo-control, raptor2, qemu-system-sparc-core,
     rubygem-io-console, xfce4-mailwatch-plugin, sharutils, plymouth-
     plugin-two-step, sbc, libhangul, SDL_mixer, python2-tables,
     python3-sqlalchemy, ocl-icd, poppler-glib, seahorse, libblockdev-lvm,
     utf8proc, orage, libopenraw, lvm2, openfortivpn, par2cmdline,
     harfbuzz, ghc-syb, lash-libs, python3-wrapt, dmraid, tokyocabinet,
     libva, gvfs-client, NetworkManager-libnm, urlview, python2-libs,
     audit, python2-scipy, lrzsz, libglvnd-egl, opusfile, python3-newt,
     dhcp-libs, transmission-cli, libtalloc, grep, hypervkvpd, libepoxy,
     perl-Variable-Magic, man-db, python2-dbus, gedit, fluidsynth, libvirt-
     daemon-driver-storage-core, libibumad, libgadu, python2-deltarpm,
     boost-locale, liblogging-stdlog, timedatex, fltk, glusterfs-libs,
     python2-pynacl, rasqal, wireless-tools, libdb, xfce4-fsguard-plugin,
     passwd, cups-pk-helper, mosh, kmod-libs, NetworkManager-team, libdv,
     gutenprint-libs, lm_sensors-libs, libreoffice-writer, desktop-file-
     utils, libXdamage, xorg-x11-utils, vnstat, libmwaw, exo, gst-editing-
     services, libunwind, dleyna-connector-dbus, gtkmm30, unbound-libs,
     clang5.0-libs, kmod-VirtualBox-4.20.6-200.fc29.x86_64,
     qt5-qtmultimedia, libxfce4ui, libopusenc, gobject-introspection,
     libpwquality, imake, fontconfig, compat-ffmpeg28, patchutils, libnsl,
     libblockdev-dm, compat-lua-libs, perl-Math-BigInt-FastCalc, evince-
     djvu, libkcapi-hmaccalc, libtar, libdaemon, ffmpeg, qemu-system-s390x-
     core, libytnef, rpm-build-libs, python3-librepo, pkgconf, vino,
     json-c, sed, sssd-ipa, pygtk2-libglade, arj, matio, perl-threads-
     shared, libaio, saslwrapper, NetworkManager-vpnc-gnome, openslide,
     libpng, sane-backends-libs, python3-pillow, msmtp, ostree-libs,
     ktoblzcheck, libvirt-daemon-driver-uml, hardlink, libcollection,
     libgcrypt, xfce4-taskmanager, cairomm, perl-Unicode-UTF8, lash, lasi,
     geoclue2, lsof, bonnie++, at-spi2-atk, openjfx, loudmouth, cronie-
     anacron, twolame-libs, cups-ipptool, lxdm, xorg-x11-server-Xorg,
     rpcgen, pv, libmbim, perl-IO, libomp, libverto, glibmm24, gtk-xfce-
     engine, libXScrnSaver, realmd, libmspub, ncurses, xfce4-genmon-plugin,
     graphite2, python3-kerberos, perl-List-MoreUtils-XS, passwdqc-lib,
     libmad, ndctl-libs, gmp, sssd-krb5-common, volume_key-libs, qemu-
     system-cris-core, b43-fwcutter, libmodulemd1, farstream02, ffmpeg-
     libs, alsa-plugins-pulseaudio, perl-interpreter, oci-register-machine,
     bluez-cups, gimp, texlive-metafont, libcurl, x3270, coreutils, gnutls-
     utils, libcap-ng, xfce4-screenshooter-plugin, gvfs, mesa-libgbm,
     pinentry, libvirt-daemon-driver-storage-scsi, libmpcdec, lua-
     filesystem, fbida, gwenhywfar-gui-gtk3, qemu-common, docker, gsm, gsl,
     boost-filesystem, libtevent, libvmaf, firefox, openblas-threads,
     libglvnd, boost-system, libpcap, nspr, im-chooser-common, snappy,
     python3-test, libindicator, clutter-gst3, xterm, cyrus-sasl-lib,
     libdrm, genisoimage, libgcrypt-devel, rubygem-bigdecimal, pcre2, bip,
     xmlrpc-c, jsoncpp, perl-TermReadKey, cogl, rygel, libpng-devel, perl-
     MIME-Base64, libvirt-glib, bitlbee, libqhull, sssd-nfs-idmap,
     SDL_Pango, libmspack, perl-Unicode-Collate, libssh, GConf2, glibc,
     ttmkfdir, fipscheck, bc, gtk-vnc2, gdk-pixbuf2-devel, wget, libijs,
     openssl, boost-regex, python2-unbound, libreport-web, libgomp,
     libexif, libvirt-daemon-driver-secret, tigervnc, gdk-pixbuf2-xlib,
     glib2, spirv-tools-libs, python2-libxml2, libbinio, qemu-
     system-x86-core, ImageMagick-libs, libwmf, pcre2-utf16, libmnl,
     audacious-plugins, gettext-devel, libzmf, libmng, nss, pcre,
     python3-pynacl, tcp_wrappers-libs, sane-backends, gstreamer1-plugins-
     base, spax, pciutils-libs, libiptcdata, perl-SDL, libXi, audacious,
     openjpeg2, libmatroska, flac-libs, libXt, libXv, rubygem-openssl,
     libexttextcat, info, libnfnetlink, libiec61883, gstreamer,
     NetworkManager-sstp-gnome, rpm-sign-libs, boost-context, device-
     mapper-event, libusal, libreport-plugin-bugzilla, fftw-libs-quad,
     thunar-media-tags-plugin, lightdm-gtk, qt5-qtbase, libpskc, linux-atm,
     python3-lxml, jwhois, qemu-block-dmg, curl, qemu-system-nios2-core,
     yelp-libs, cmake, gnutls-dane, gnuplot, libdmapsharing, rubygem-json,
     claws-mail-plugins-rssyl, gcc-gdb-plugin, fipscheck-lib, pilot-link-
     libs, python2-pycurl, ncompress, dos2unix, paps, libqxp, lzo-minilzo,
     ustr, pinfo, tpm2-tss, geany-libgeany, libdhash, frozen-bubble, sssd-
     proxy, imsettings-libs, zchunk-libs, python2-numexpr, totem,
     python3-matplotlib, gd, gc, adplug, python3-cups, libxshmfence,
     ncurses-c++-libs, ampache_browser, gstreamer1-plugins-ugly-free,
     atlas, lftp, unzip, apr-util-openssl, vlc, gtk2, gtk3, libwayland-egl,
     libv4l, hfsutils, xfce4-session-engines, atkmm, npth, systemtap-
     client, libyaml, claws-mail-plugins-notification, gspell, xcb-util-
     image, libblockdev-mdraid, glusterfs, exiv2-libs, libebml, xfce4-time-
     out-plugin, libunistring, rxvt-unicode, dleyna-server, wireshark,
     gstreamer1-plugins-good, python2-rpm, libasyncns, qemu-block-curl,
     device-mapper-multipath, c-ares, xmlsec1-openssl, pulseaudio-
     module-x11, python2-cairo, NetworkManager-pptp-gnome, jansson, bind-
     utils, garcon, libpeas-gtk, librsvg2, vips, alsa-utils, apr,
     libsss_nss_idmap, blueman, pitivi, gupnp-dlna, trousers-lib, apg,
     libnumbertext, libaom, zip, webrtc-audio-processing, bcache-tools,
     startup-notification, jhead, babl, libstaroffice, harfbuzz-devel,
     xfce4-panel, bubblewrap, elfutils-libs, cairo, libtasn1, jbigkit-libs,
     libe-book, python3-dbus, sqlite, tar, xmlsec1-gnutls, sudo, dhcp-
     client, fprintd, gcc, lame, dwz, meanwhile, libgsf-devel, iodine-
     client, gnupg2, oddjob, ebtables, libyui-qt, avahi-libs, amrnb, pigz,
     python3-pyyaml, libappindicator-gtk3, xfce4-eyes-plugin, libquvi,
     qemu-system-tricore-core, gvfs-archive, python2-matplotlib-tk, qemu-
     system-arm-core, thunar-archive-plugin, libao, udis86, perl-libs,
     systemtap-devel, lz4, kbd, tcl, xorg-x11-drv-qxl, mutt, dbus-daemon,
     libreoffice-core, wayland-devel, gnupg2-smime, opus-tools, gupnp-igd,
     gcr, libwayland-cursor, openvpn, flex, squashfs-tools, xvidcore,
     libwacom, lzo, pango, libss, libshaderc, BackupPC-XS, esmtp,
     VirtualBox-server, polkit-libs, perl-threads, perl-Params-Validate,
     python2-newt, pangomm, cryptsetup, mesa-libxatracker, nss-sysinit,
     LibRaw, nss-mdns, claws-mail-plugins-vcalendar, tcsh, qemu-system-
     unicore32-core, geeqie, runc, python3-cffi, perl-Socket6, fftw-libs-
     long, at-spi2-core, libvirt-daemon-driver-network, gegl04, yum-
     metadata-parser, glibc-common, liblockfile, indent, clang-libs, bind-
     export-libs, xmlsec1-gcrypt, ndctl, xalan-c, claws-mail-plugins-
     mailmbox, python3-libxml2, libicns-utils, libnfs, libgfortran, stoken-
     libs, libiscsi, texlive-kpathsea, libvirt-daemon-driver-libxl, groff-
     base, libusb, hdparm, hddtemp, mesa-libGL, perl-Devel-LexAlias, perl-
     HTML-Parser, libldb, bind-libs-lite, NetworkManager-vpnc, libmodplug,
     libvirt-daemon-driver-nodedev, libXres, libcanberra, pcsc-lite,
     xisdnload, grub2-tools-efi, libdav1d, libart_lgpl, wavpack, xorg-x11
     -drv-wacom, libsrtp, perl-Package-Stash-XS, samba-client-libs, ghc-
     singleton-bool, which, boost-chrono, samba-client, glib-networking,
     lua-expat, python3-cccolutils, aqbanking, libxfce4util, qemu-ui-
     curses, t1lib, brlapi, strace, thunderbird, createrepo_c,
     python2-markupsafe, nethack, libreport-gtk, liboauth, lmdb-libs,
     libgpg-error-devel, xmlsec1, xfce4-power-manager, isns-utils-libs,
     libmypaint, libwsman1, openldap-clients, krb5-workstation, ksh, nmap-
     ncat, kpartx, libglvnd-opengl, vlc-core, qemu-system-xtensa-core,
     lksctp-tools, libgltf, usb_modeswitch, tbb, mythes, rubygem-psych,
     NetworkManager-wifi, libfastjson, teamd, libvorbis, claws-mail-
     plugins-tnef, lightdm-gobject, NetworkManager-openconnect-gnome,
     vconfig, pcre-cpp, python3-libselinux, libodfgen, setserial, exiv2,
     libestr, yasm, lua, xorriso, perl-PadWalker, cyrus-sasl, qemu-user,
     libpeas-loader-python3, llvm-libs, doxygen, asunder, pulseaudio-
     module-bluetooth, libvirt-libs, valgrind, qpid-proton-c, xfce4
     -diskperf-plugin, portaudio, passwdqc, libXft, schroedinger, libattr,
     libicns, hyphen, python2-matplotlib, zvbi, rpm, libgsasl, qemu-audio-
     oss, syslinux, yp-tools, abiword, libxcrypt, sssd-ldap, iptstate,
     claws-mail-plugins-fetchinfo, radvd, libplacebo, gtk-unico-engine,
     libvirt-nss, libappindicator, glusterfs-cli, perl-PathTools, ipset-
     libs, boost-graph, cvs, perl-Devel-Size, plymouth-graphics-libs,
     boost-serialization, lasem, glusterfs-client-xlators, libreoffice-
     pyuno, motif, libpaper, libxml2, gmime, libreoffice-ure, iscsi-
     initiator-utils-iscsiuio, cyrus-sasl-gssapi, xfwm4, mpage, libargon2,
     mesa-vulkan-drivers, libvirt-daemon, protobuf-lite, libsecret,
     tumbler, gtk2-engines, strongswan-charon-nm, libnet, qemu-system-
     riscv-core, p11-kit-trust, dcraw, nss-softokn, augeas-libs, libsysfs,
     python3-numpy, texlive-dvipng, xfce4-terminal, buildah, java-1.8.0
     -openjdk-headless, gnome-desktop3, gdk-pixbuf2-modules, binutils,
     xfconf, xen-libs, libisofs, perl-DateTime, nss-pem, vim-common,
     python2-kerberos, less, xen, brltty, libvpx, evince, boost-coroutine,
     libnghttp2, util-linux-user, libsolv, exempi, libxkbcommon-x11,
     libtdb, python3-gpg, libXdmcp, libvirt-sandbox, origin-clients, perl-
     Socket, qemu-system-microblaze-core, apr-util, python2-bcrypt, aspell,
     libatomic, libvisual, python3, python2, gpm-libs, minicom, perl-
     DB_File, dbus-tools, shared-mime-info, httpd-tools, SDL2, webkit2gtk3,
     libsigsegv, boost-thread, perl-Devel-Caller, grilo-plugins, shadow-
     utils, boost-random, libcgroup, libXaw, libXau, netcf-libs, libgdata,
     libvirt-client, libspiro, dmidecode, qemu-audio-alsa,
     python3-libcomps, perl-Devel-CallChecker, libXpm-devel, libjpeg-turbo,
     spice-gtk3, libmount, spice-vdagent, xorg-x11-drv-wacom-serial-
     support, xorg-x11-drv-fbdev, libqb, libavc1394, lldpad, libtiff,
     python3-libsemanage, libvncserver, kmod-
     VirtualBox-4.19.9-300.fc29.x86_64, claws-mail-plugins-pgp, ima-evm-
     utils, boost-stacktrace, python3-gstreamer1, python2-gobject-base,
     mesa-libOpenCL, grub2-tools-extra, transmission-common, qemu-audio-
     sdl, openssh-server, fluidsynth-libs, taglib, libXext, mcpp,
     ModemManager-glib, bridge-utils, ostree, device-mapper-event-libs,
     initscripts, hunspell, xfce4-whiskermenu-plugin, libieee1284, libndp,
     xmlrpc-c-c++, claws-mail-plugins-att-remover, pulseaudio, qemu-ui-sdl,
     bitlbee-facebook, bzip2, elfutils-libelf, nss-softokn-freebl, rsync-
     bpc, open-vm-tools, libsmi, python3-smartcols, libavdevice, nfs-utils,
     libtool-ltdl, readline, yelp, xorg-x11-drv-intel, vulkan-loader, perl-
     version, parole), /usr/lib/.build-id/12(ncurses-compat-libs,
     gstreamer1-plugins-bad-free, ImageMagick-libs, libcdio, perl-
     interpreter, clang6.0-libs, cups, libreoffice-core, gimp, compiler-rt,
     bsd-games, glibc, gperftools-libs, httpd, gettext, shadow-utils,
     strongswan, ocp, vlc-core, ruby-libs, bind-libs-lite, sssd-client,
     libmbim-utils, authselect-libs, ModemManager, orage, gstreamer1
     -plugins-good, plymouth-plugin-two-step, sane-backends-drivers-
     scanners, libqxp, python2-libs, util-linux, java-1.8.0-openjdk-devel,
     pipewire, binutils, gutenprint-cups, libnl3-cli, at-spi2-atk),
     /usr/lib/.build-id/a1(libuser, linux-atm, ffmpeg-libs, audacious-
     plugins, libxcb, dbxtool, libyubikey, libreoffice-core, gimp,
     compiler-rt, util-linux, java-1.8.0-openjdk-headless, glibc, gettext,
     frei0r-plugins, ruby-libs, pam, gawk, libdrm, xen-runtime, flac,
     brltty, SDL_mixer, tbb, pulseaudio, python3-systemd, clang-libs),
     /usr/lib/.build-id/cf(libudisks2, libao, firefox, qt5-qtdeclarative,
     gstreamer1-plugins-bad-free, graphviz, xmlsec1, iscsi-initiator-utils,
     lpsolve, libreoffice-core, xorg-x11-server-Xorg, glibc, gnupg2,
     tokyocabinet, zfs-fuse, tumbler, gtk2, vlc-core, python3-bcrypt,
     suitesparse, python3-libreport, gnucash, e2fsprogs, krb5-libs, psmisc,
     gdk-pixbuf2-modules, zsh, gsl, rust), /usr/lib/.build-id/3e
     (NetworkManager-libreswan, lvm2, webkit2gtk3, clamav-lib, gstreamer-
     plugins-base, iproute, rpm-build-libs, perl-interpreter, libreoffice-
     core, httpd-tools, sssd-common, perl-Encode, glibc, compat-ffmpeg28,
     frei0r-plugins, ksh, iptables, lftp, gtk2, vlc-core, gnumeric, gegl04,
     lksctp-tools, jack-audio-connection-kit-example-clients, network-
     manager-applet, net-tools, protobuf-c, elfutils)
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[x]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 0 bytes in 0 files.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[!]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in
     libmandoc , mandoc-debuginfo , mandoc-debugsource
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Patches link to upstream bugs/comments/lists or are otherwise
     justified.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[!]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Uses parallel make %{?_smp_mflags} macro.
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on debuginfo package(s).
     Note: No rpmlint messages.
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: mandoc-1.14.4-1.fc29.x86_64.rpm
          libmandoc-1.14.4-1.fc29.x86_64.rpm
          libmandoc-devel-1.14.4-1.fc29.x86_64.rpm
          mandoc-debuginfo-1.14.4-1.fc29.x86_64.rpm
          mandoc-debugsource-1.14.4-1.fc29.x86_64.rpm
          mandoc-1.14.4-1.fc29.src.rpm
mandoc.x86_64: W: spelling-error Summary(en_US) mdoc -> doc, m doc
mandoc.x86_64: W: spelling-error %description -l en_US mdoc -> doc, m doc
mandoc.x86_64: W: spelling-error %description -l en_US roff -> toff, riff, off
mandoc.x86_64: W: spelling-error %description -l en_US toolset -> tool set, tool-set, Togolese
mandoc.x86_64: W: manual-page-warning /usr/share/man/man7/mandoc_char.7.gz 726: warning: macro `R' not defined
mandoc.x86_64: W: manual-page-warning /usr/share/man/man7/mandoc_char.7.gz 727: warning: macro `Tm' not defined
mandoc.x86_64: W: manual-page-warning /usr/share/man/man7/mandoc_char.7.gz 733: warning: macro `lq' not defined
mandoc.x86_64: W: manual-page-warning /usr/share/man/man7/mandoc_char.7.gz 734: warning: macro `rq' not defined
mandoc.x86_64: W: manual-page-warning /usr/share/man/man7/mandoc_char.7.gz 736: warning: macro `va' not defined
libmandoc.x86_64: W: spelling-error Summary(en_US) mdoc -> doc, m doc
libmandoc.x86_64: W: spelling-error %description -l en_US mandoc -> manioc, man doc, man-doc
libmandoc.x86_64: W: spelling-error %description -l en_US mdoc -> doc, m doc
libmandoc.x86_64: W: spelling-error %description -l en_US roff -> toff, riff, off
libmandoc.x86_64: W: spelling-error %description -l en_US tbl -> bl, tel, tbs
libmandoc.x86_64: W: spelling-error %description -l en_US eqn -> en, eon, equine
libmandoc.x86_64: W: no-documentation
libmandoc-devel.x86_64: W: spelling-error %description -l en_US mandoc -> manioc, man doc, man-doc
libmandoc-devel.x86_64: W: spelling-error %description -l en_US mdoc -> doc, m doc
libmandoc-devel.x86_64: W: spelling-error %description -l en_US roff -> toff, riff, off
libmandoc-devel.x86_64: W: spelling-error %description -l en_US tbl -> bl, tel, tbs
libmandoc-devel.x86_64: W: spelling-error %description -l en_US eqn -> en, eon, equine
mandoc.src: W: spelling-error Summary(en_US) mdoc -> doc, m doc
mandoc.src: W: spelling-error %description -l en_US mdoc -> doc, m doc
mandoc.src: W: spelling-error %description -l en_US roff -> toff, riff, off
mandoc.src: W: spelling-error %description -l en_US toolset -> tool set, tool-set, Togolese
mandoc.src:76: W: configure-without-libdir-spec
6 packages and 0 specfiles checked; 0 errors, 26 warnings.




Rpmlint (debuginfo)
-------------------
Checking: mandoc-debuginfo-1.14.4-1.fc29.x86_64.rpm
1 packages and 0 specfiles checked; 0 errors, 0 warnings.





Rpmlint (installed packages)
----------------------------
sh: /usr/bin/python: No such file or directory
mandoc.x86_64: W: spelling-error Summary(en_US) mdoc -> doc, m doc
mandoc.x86_64: W: spelling-error %description -l en_US mdoc -> doc, m doc
mandoc.x86_64: W: spelling-error %description -l en_US roff -> toff, riff, off
mandoc.x86_64: W: spelling-error %description -l en_US toolset -> tool set, tool-set, Togolese
mandoc.x86_64: W: invalid-url URL: https://mandoc.bsd.lv/ <urlopen error [Errno -2] Name or service not known>
mandoc.x86_64: W: manual-page-warning /usr/share/man/man7/mandoc_char.7.gz 726: warning: macro `R' not defined
mandoc.x86_64: W: manual-page-warning /usr/share/man/man7/mandoc_char.7.gz 727: warning: macro `Tm' not defined
mandoc.x86_64: W: manual-page-warning /usr/share/man/man7/mandoc_char.7.gz 733: warning: macro `lq' not defined
mandoc.x86_64: W: manual-page-warning /usr/share/man/man7/mandoc_char.7.gz 734: warning: macro `rq' not defined
mandoc.x86_64: W: manual-page-warning /usr/share/man/man7/mandoc_char.7.gz 736: warning: macro `va' not defined
libmandoc-devel.x86_64: W: spelling-error %description -l en_US mandoc -> manioc, man doc, man-doc
libmandoc-devel.x86_64: W: spelling-error %description -l en_US mdoc -> doc, m doc
libmandoc-devel.x86_64: W: spelling-error %description -l en_US roff -> toff, riff, off
libmandoc-devel.x86_64: W: spelling-error %description -l en_US tbl -> bl, tel, tbs
libmandoc-devel.x86_64: W: spelling-error %description -l en_US eqn -> en, eon, equine
libmandoc-devel.x86_64: W: invalid-url URL: https://mandoc.bsd.lv/ <urlopen error [Errno -2] Name or service not known>
libmandoc.x86_64: W: spelling-error Summary(en_US) mdoc -> doc, m doc
libmandoc.x86_64: W: spelling-error %description -l en_US mandoc -> manioc, man doc, man-doc
libmandoc.x86_64: W: spelling-error %description -l en_US mdoc -> doc, m doc
libmandoc.x86_64: W: spelling-error %description -l en_US roff -> toff, riff, off
libmandoc.x86_64: W: spelling-error %description -l en_US tbl -> bl, tel, tbs
libmandoc.x86_64: W: spelling-error %description -l en_US eqn -> en, eon, equine
libmandoc.x86_64: W: invalid-url URL: https://mandoc.bsd.lv/ <urlopen error [Errno -2] Name or service not known>
libmandoc.x86_64: W: undefined-non-weak-symbol /usr/lib64/libmandoc.so.1 gzclose
libmandoc.x86_64: W: undefined-non-weak-symbol /usr/lib64/libmandoc.so.1 gzdopen
libmandoc.x86_64: W: undefined-non-weak-symbol /usr/lib64/libmandoc.so.1 zError
libmandoc.x86_64: W: undefined-non-weak-symbol /usr/lib64/libmandoc.so.1 gzread
libmandoc.x86_64: W: undefined-non-weak-symbol /usr/lib64/libmandoc.so.1 gzerror
libmandoc.x86_64: W: no-documentation
mandoc-debuginfo.x86_64: W: invalid-url URL: https://mandoc.bsd.lv/ <urlopen error [Errno -2] Name or service not known>
mandoc-debugsource.x86_64: W: invalid-url URL: https://mandoc.bsd.lv/ <urlopen error [Errno -2] Name or service not known>
5 packages and 0 specfiles checked; 0 errors, 31 warnings.



Requires
--------
mandoc (rpmlib, GLIBC filtered):
    libc.so.6()(64bit)
    libmandoc.so.1()(64bit)
    libz.so.1()(64bit)
    rtld(GNU_HASH)

libmandoc-devel (rpmlib, GLIBC filtered):
    libmandoc(x86-64)
    libmandoc.so.1()(64bit)

libmandoc (rpmlib, GLIBC filtered):
    libc.so.6()(64bit)
    rtld(GNU_HASH)

mandoc-debuginfo (rpmlib, GLIBC filtered):

mandoc-debugsource (rpmlib, GLIBC filtered):



Provides
--------
mandoc:
    mandoc
    mandoc(x86-64)

libmandoc-devel:
    libmandoc-devel
    libmandoc-devel(x86-64)

libmandoc:
    libmandoc
    libmandoc(x86-64)
    libmandoc.so.1()(64bit)

mandoc-debuginfo:
    debuginfo(build-id)
    mandoc-debuginfo
    mandoc-debuginfo(x86-64)

mandoc-debugsource:
    mandoc-debugsource
    mandoc-debugsource(x86-64)



Source checksums
----------------
https://mandoc.bsd.lv/snapshots/mandoc-1.14.4.tar.gz :
  CHECKSUM(SHA256) this package     : 24eb72103768987dcc63b53d27fdc085796330782f44b3b40c4660b1e1ee9b9c
  CHECKSUM(SHA256) upstream package : 24eb72103768987dcc63b53d27fdc085796330782f44b3b40c4660b1e1ee9b9c


Generated by fedora-review 0.6.1 (f03e4e7) last change: 2016-05-02
Command line :/usr/bin/fedora-review -b 1673214
Buildroot used: fedora-29-x86_64
Active plugins: Generic, Shell-api, C/C++
Disabled plugins: Java, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6

Comment 2 David Cantrell 2019-02-07 16:44:26 UTC
Additional comments:

1) I do not know what the debug stuff is under the Issues in the previous comment.  I think this is bogus because the debuginfo and debugsource packages look fine.

2) The gcc and make BuildRequires can be dropped.

3) I also think the ldconfig thing is bogus since RPM triggers are now used for that stuff (right?).

4) Under SHOULD, the fully versioned dependency of subpackages is not complete?  Maybe?  Should the main mandoc package have a fully versioned dependency on the libmandoc subpackage?  RPM already picks up the shared library dependency, but that potentially leaves the door open for having a different version of mandoc and libmandoc installed and is that something worth caring about?  My thought is that the main package should have the fully versioned dependency to close the door on that potential situation.

5) %check is missing, but it could run "make regress".  This is listed under the SHOULD items and is not required, so I will leave it up to you.

Other than these items, the package looks fine.  Awaiting feedback.

Comment 3 David Shea 2019-02-07 17:29:51 UTC
(In reply to David Cantrell from comment #2)
> Additional comments:
> 
> 1) I do not know what the debug stuff is under the Issues in the previous
> comment.  I think this is bogus because the debuginfo and debugsource
> packages look fine.

That, plus the message about /usr/lib/.build-id/ being owned by every single package, I think just means no one has updated fedora-review in a while to handle the new debug package stuff.

> 2) The gcc and make BuildRequires can be dropped.

gcc needs to be in BuildRequires because Fedora decided not to include those by default anymore.

https://fedoraproject.org/wiki/Changes/Remove_GCC_from_BuildRoot

make could probably be dropped but I figured just leave it in to stay ahead of the next round of buildroot changes.

> 3) I also think the ldconfig thing is bogus since RPM triggers are now used
> for that stuff (right?).

It is bogus, but I should probably use the %ldconfig_scriptlets macro so /sbin/ldconfig runs on EPEL. Added to the next revision.
 
> 4) Under SHOULD, the fully versioned dependency of subpackages is not
> complete?  Maybe?  Should the main mandoc package have a fully versioned
> dependency on the libmandoc subpackage?  RPM already picks up the shared
> library dependency, but that potentially leaves the door open for having a
> different version of mandoc and libmandoc installed and is that something
> worth caring about?  My thought is that the main package should have the
> fully versioned dependency to close the door on that potential situation.

I guess it'd be best to avoid the versions of mandoc and libmandoc differing. Added a fully versioned Requires.

> 5) %check is missing, but it could run "make regress".  This is listed under
> the SHOULD items and is not required, so I will leave it up to you.

Added.

Spec URL: https://copr-be.cloud.fedoraproject.org/results/dshea/mandoc/fedora-rawhide-x86_64/00856080-mandoc/mandoc.spec
SRPM URL: https://copr-be.cloud.fedoraproject.org/results/dshea/mandoc/fedora-rawhide-x86_64/00856080-mandoc/mandoc-1.14.4-2.fc30.src.rpm

Comment 4 David Cantrell 2019-02-07 18:03:41 UTC
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated


Issues:
=======
- Header files in -devel subpackage, if present.
[IGNORED - this has not been updated to match current build policies]
- All build dependencies are listed in BuildRequires, except for any that
  are listed in the exceptions section of Packaging Guidelines.
  Note: These BR are not needed: gcc make
  See: http://fedoraproject.org/wiki/Packaging/Guidelines#Exceptions_2
[IGNORED - Fedora does not explicitly add gcc anymore, leaving the BR in.]
- ldconfig called in %post and %postun if required.
  Note: /sbin/ldconfig not called in libmandoc
  See: http://fedoraproject.org/wiki/Packaging/Guidelines#Shared_Libraries
[IGNORED - This is wrong per current policy, the package is using
 %ldconfig_scriptlets correctly.]


===== MUST items =====

C/C++:
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.
[x]: Development (unversioned) .so files in -devel subpackage, if present.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "BSD 3-clause "New" or "Revised" License", "ISC License",
     "Unknown or generated", "BSD 2-clause "Simplified" License". 1676
     files have unknown license. Detailed output of licensecheck in
     /home/dcantrel/mandoc/mandoc/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[x]: Package does not own files or directories owned by other packages.
     [IGNORED - this test needs to be updated for current .build-id policies.]
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[x]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 0 bytes in 0 files.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in
     libmandoc , mandoc-debuginfo , mandoc-debugsource
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Patches link to upstream bugs/comments/lists or are otherwise
     justified.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Uses parallel make %{?_smp_mflags} macro.
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on debuginfo package(s).
     Note: No rpmlint messages.
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.


Rpmlint
-------
Checking: mandoc-1.14.4-2.fc29.x86_64.rpm
          libmandoc-1.14.4-2.fc29.x86_64.rpm
          libmandoc-devel-1.14.4-2.fc29.x86_64.rpm
          mandoc-debuginfo-1.14.4-2.fc29.x86_64.rpm
          mandoc-debugsource-1.14.4-2.fc29.x86_64.rpm
          mandoc-1.14.4-2.fc29.src.rpm
mandoc.x86_64: W: spelling-error Summary(en_US) mdoc -> doc, m doc
mandoc.x86_64: W: spelling-error %description -l en_US mdoc -> doc, m doc
mandoc.x86_64: W: spelling-error %description -l en_US roff -> toff, riff, off
mandoc.x86_64: W: spelling-error %description -l en_US toolset -> tool set, tool-set, Togolese
mandoc.x86_64: W: manual-page-warning /usr/share/man/man7/mandoc_char.7.gz 726: warning: macro `R' not defined
mandoc.x86_64: W: manual-page-warning /usr/share/man/man7/mandoc_char.7.gz 727: warning: macro `Tm' not defined
mandoc.x86_64: W: manual-page-warning /usr/share/man/man7/mandoc_char.7.gz 733: warning: macro `lq' not defined
mandoc.x86_64: W: manual-page-warning /usr/share/man/man7/mandoc_char.7.gz 734: warning: macro `rq' not defined
mandoc.x86_64: W: manual-page-warning /usr/share/man/man7/mandoc_char.7.gz 736: warning: macro `va' not defined
libmandoc.x86_64: W: spelling-error Summary(en_US) mdoc -> doc, m doc
libmandoc.x86_64: W: spelling-error %description -l en_US mandoc -> manioc, man doc, man-doc
libmandoc.x86_64: W: spelling-error %description -l en_US mdoc -> doc, m doc
libmandoc.x86_64: W: spelling-error %description -l en_US roff -> toff, riff, off
libmandoc.x86_64: W: spelling-error %description -l en_US tbl -> bl, tel, tbs
libmandoc.x86_64: W: spelling-error %description -l en_US eqn -> en, eon, equine
libmandoc.x86_64: W: no-documentation
libmandoc-devel.x86_64: W: spelling-error %description -l en_US mandoc -> manioc, man doc, man-doc
libmandoc-devel.x86_64: W: spelling-error %description -l en_US mdoc -> doc, m doc
libmandoc-devel.x86_64: W: spelling-error %description -l en_US roff -> toff, riff, off
libmandoc-devel.x86_64: W: spelling-error %description -l en_US tbl -> bl, tel, tbs
libmandoc-devel.x86_64: W: spelling-error %description -l en_US eqn -> en, eon, equine
mandoc.src: W: spelling-error Summary(en_US) mdoc -> doc, m doc
mandoc.src: W: spelling-error %description -l en_US mdoc -> doc, m doc
mandoc.src: W: spelling-error %description -l en_US roff -> toff, riff, off
mandoc.src: W: spelling-error %description -l en_US toolset -> tool set, tool-set, Togolese
mandoc.src:85: W: configure-without-libdir-spec
6 packages and 0 specfiles checked; 0 errors, 26 warnings.




Rpmlint (debuginfo)
-------------------
Checking: mandoc-debuginfo-1.14.4-2.fc29.x86_64.rpm
1 packages and 0 specfiles checked; 0 errors, 0 warnings.





Rpmlint (installed packages)
----------------------------
sh: /usr/bin/python: No such file or directory
mandoc.x86_64: W: spelling-error Summary(en_US) mdoc -> doc, m doc
mandoc.x86_64: W: spelling-error %description -l en_US mdoc -> doc, m doc
mandoc.x86_64: W: spelling-error %description -l en_US roff -> toff, riff, off
mandoc.x86_64: W: spelling-error %description -l en_US toolset -> tool set, tool-set, Togolese
mandoc.x86_64: W: invalid-url URL: https://mandoc.bsd.lv/ <urlopen error [Errno -2] Name or service not known>
mandoc.x86_64: W: manual-page-warning /usr/share/man/man7/mandoc_char.7.gz 726: warning: macro `R' not defined
mandoc.x86_64: W: manual-page-warning /usr/share/man/man7/mandoc_char.7.gz 727: warning: macro `Tm' not defined
mandoc.x86_64: W: manual-page-warning /usr/share/man/man7/mandoc_char.7.gz 733: warning: macro `lq' not defined
mandoc.x86_64: W: manual-page-warning /usr/share/man/man7/mandoc_char.7.gz 734: warning: macro `rq' not defined
mandoc.x86_64: W: manual-page-warning /usr/share/man/man7/mandoc_char.7.gz 736: warning: macro `va' not defined
libmandoc-devel.x86_64: W: spelling-error %description -l en_US mandoc -> manioc, man doc, man-doc
libmandoc-devel.x86_64: W: spelling-error %description -l en_US mdoc -> doc, m doc
libmandoc-devel.x86_64: W: spelling-error %description -l en_US roff -> toff, riff, off
libmandoc-devel.x86_64: W: spelling-error %description -l en_US tbl -> bl, tel, tbs
libmandoc-devel.x86_64: W: spelling-error %description -l en_US eqn -> en, eon, equine
libmandoc-devel.x86_64: W: invalid-url URL: https://mandoc.bsd.lv/ <urlopen error [Errno -2] Name or service not known>
libmandoc.x86_64: W: spelling-error Summary(en_US) mdoc -> doc, m doc
libmandoc.x86_64: W: spelling-error %description -l en_US mandoc -> manioc, man doc, man-doc
libmandoc.x86_64: W: spelling-error %description -l en_US mdoc -> doc, m doc
libmandoc.x86_64: W: spelling-error %description -l en_US roff -> toff, riff, off
libmandoc.x86_64: W: spelling-error %description -l en_US tbl -> bl, tel, tbs
libmandoc.x86_64: W: spelling-error %description -l en_US eqn -> en, eon, equine
libmandoc.x86_64: W: invalid-url URL: https://mandoc.bsd.lv/ <urlopen error [Errno -2] Name or service not known>
libmandoc.x86_64: W: undefined-non-weak-symbol /usr/lib64/libmandoc.so.1.0 gzclose
libmandoc.x86_64: W: undefined-non-weak-symbol /usr/lib64/libmandoc.so.1.0 gzdopen
libmandoc.x86_64: W: undefined-non-weak-symbol /usr/lib64/libmandoc.so.1.0 zError
libmandoc.x86_64: W: undefined-non-weak-symbol /usr/lib64/libmandoc.so.1.0 gzread
libmandoc.x86_64: W: undefined-non-weak-symbol /usr/lib64/libmandoc.so.1.0 gzerror
libmandoc.x86_64: W: no-documentation
mandoc-debuginfo.x86_64: W: invalid-url URL: https://mandoc.bsd.lv/ <urlopen error [Errno -2] Name or service not known>
mandoc-debugsource.x86_64: W: invalid-url URL: https://mandoc.bsd.lv/ <urlopen error [Errno -2] Name or service not known>
5 packages and 0 specfiles checked; 0 errors, 31 warnings.



Requires
--------
mandoc (rpmlib, GLIBC filtered):
    libc.so.6()(64bit)
    libmandoc(x86-64)
    libmandoc.so.1()(64bit)
    libz.so.1()(64bit)
    rtld(GNU_HASH)

libmandoc-devel (rpmlib, GLIBC filtered):
    libmandoc(x86-64)
    libmandoc.so.1()(64bit)

libmandoc (rpmlib, GLIBC filtered):
    libc.so.6()(64bit)
    rtld(GNU_HASH)

mandoc-debuginfo (rpmlib, GLIBC filtered):

mandoc-debugsource (rpmlib, GLIBC filtered):



Provides
--------
mandoc:
    mandoc
    mandoc(x86-64)

libmandoc-devel:
    libmandoc-devel
    libmandoc-devel(x86-64)

libmandoc:
    libmandoc
    libmandoc(x86-64)
    libmandoc.so.1()(64bit)

mandoc-debuginfo:
    debuginfo(build-id)
    mandoc-debuginfo
    mandoc-debuginfo(x86-64)

mandoc-debugsource:
    mandoc-debugsource
    mandoc-debugsource(x86-64)



Source checksums
----------------
https://mandoc.bsd.lv/snapshots/mandoc-1.14.4.tar.gz :
  CHECKSUM(SHA256) this package     : 24eb72103768987dcc63b53d27fdc085796330782f44b3b40c4660b1e1ee9b9c
  CHECKSUM(SHA256) upstream package : 24eb72103768987dcc63b53d27fdc085796330782f44b3b40c4660b1e1ee9b9c


Generated by fedora-review 0.6.1 (f03e4e7) last change: 2016-05-02
Command line :/usr/bin/fedora-review --rpm-spec -n mandoc-1.14.4-2.fc30.src.rpm
Buildroot used: fedora-29-x86_64
Active plugins: Generic, Shell-api, C/C++
Disabled plugins: Java, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6

Comment 5 David Cantrell 2019-02-07 18:04:21 UTC
And with that, I hereby grant fedora-review a '+'.  Go forth and request branches in git.

Comment 6 Gwyn Ciesla 2019-02-07 19:14:05 UTC
(fedscm-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/mandoc

Comment 7 Fedora Update System 2019-02-07 19:55:48 UTC
mandoc-1.14.4-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-a0a4d8fc28

Comment 8 Fedora Update System 2019-02-07 19:56:12 UTC
mandoc-1.14.4-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a1fe63637e

Comment 9 Fedora Update System 2019-02-10 02:12:50 UTC
mandoc-1.14.4-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-a0a4d8fc28

Comment 10 Fedora Update System 2019-02-10 04:28:07 UTC
mandoc-1.14.4-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a1fe63637e

Comment 11 Fedora Update System 2019-02-16 02:26:34 UTC
mandoc-1.14.4-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2019-02-19 14:02:19 UTC
mandoc-1.14.4-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2019-04-09 14:20:03 UTC
mandoc-1.14.4-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-477410c3f9

Comment 14 Fedora Update System 2019-04-10 04:34:16 UTC
mandoc-1.14.4-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-477410c3f9

Comment 15 Fedora Update System 2019-04-18 19:50:11 UTC
mandoc-1.14.4-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.