Bug 1673241 - die_pretty_print_type at: abg-dwarf-reader.cc:11088: execution should not have reached this point!
Summary: die_pretty_print_type at: abg-dwarf-reader.cc:11088: execution should not hav...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libabigail
Version: rawhide
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Sinny Kumari
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-07 04:24 UTC by Orion Poplawski
Modified: 2019-04-13 15:31 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-04-13 00:03:06 UTC


Attachments (Terms of Use)

Description Orion Poplawski 2019-02-07 04:24:50 UTC
Description of problem:

In taskotron check:

Following error encountered while running command abipkgdiff --dso-only --d1 /var/tmp/task-dist.abicheck_uECzQ8/stable/netcdf-fortran-mpich-debuginfo-4.4.4-10.fc29.x86_64.rpm --d1 /var/tmp/task-dist.abicheck_uECzQ8/stable/netcdf-fortran-debuginfo-4.4.4-10.fc29.x86_64.rpm --d1 /var/tmp/task-dist.abicheck_uECzQ8/stable/netcdf-fortran-openmpi-debuginfo-4.4.4-10.fc29.x86_64.rpm --d1 /var/tmp/task-dist.abicheck_uECzQ8/stable/netcdf-fortran-debugsource-4.4.4-10.fc29.x86_64.rpm --d2 /var/tmp/task-dist.abicheck_uECzQ8/update/netcdf-fortran-debuginfo-4.4.4-11.fc30.x86_64.rpm --d2 /var/tmp/task-dist.abicheck_uECzQ8/update/netcdf-fortran-debugsource-4.4.4-11.fc30.x86_64.rpm --d2 /var/tmp/task-dist.abicheck_uECzQ8/update/netcdf-fortran-openmpi-debuginfo-4.4.4-11.fc30.x86_64.rpm --d2 /var/tmp/task-dist.abicheck_uECzQ8/update/netcdf-fortran-mpich-debuginfo-4.4.4-11.fc30.x86_64.rpm --devel1 /var/tmp/task-dist.abicheck_uECzQ8/stable/netcdf-fortran-mpich-devel-4.4.4-10.fc29.x86_64.rpm --devel2 /var/tmp/task-dist.abicheck_uECzQ8/update/netcdf-fortran-mpich-devel-4.4.4-11.fc30.x86_64.rpm /var/tmp/task-dist.abicheck_uECzQ8/stable/netcdf-fortran-mpich-4.4.4-10.fc29.x86_64.rpm /var/tmp/task-dist.abicheck_uECzQ8/update/netcdf-fortran-mpich-4.4.4-11.fc30.x86_64.rpm :
 b'in die_pretty_print_type at: abg-dwarf-reader.cc:11088: execution should not have reached this point!\n'

https://taskotron.fedoraproject.org/artifacts/all/53ec4ce2-2710-11e9-9c24-525400fc9f92/tests.yml/netcdf-fortran-4.4.4-11.fc30.log

Comment 1 Dodji Seketeli 2019-02-07 14:28:13 UTC
Thank you for taking the time to report this issue.

I could reproduce it and am I looking at it. It looks like a "hole" in
the recent Fortran support that was done in Libabigail.

In the mean time I filed an upstream bug to track the issue there too,
at https://sourceware.org/bugzilla/show_bug.cgi?id=24188.

Comment 2 Dodji Seketeli 2019-02-08 09:56:26 UTC
So this bug was fixed upstream.  You can see the details at
https://sourceware.org/bugzilla/show_bug.cgi?id=24188.
The fix will be available in the next 1.6 release of Libabigail.

Comment 3 Fedora Update System 2019-03-29 15:46:06 UTC
libabigail-1.6-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e618b6616c

Comment 4 Fedora Update System 2019-03-29 15:52:38 UTC
libabigail-1.6-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3c238b5efa

Comment 5 Fedora Update System 2019-03-29 15:53:09 UTC
libabigail-1.6-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-022547dd8c

Comment 6 Fedora Update System 2019-03-29 15:53:27 UTC
libabigail-1.6-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-2f9e202bcf

Comment 7 Fedora Update System 2019-03-29 15:53:45 UTC
libabigail-1.6-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-9871f61010

Comment 8 Fedora Update System 2019-03-29 19:09:07 UTC
libabigail-1.6-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-2f9e202bcf

Comment 9 Fedora Update System 2019-03-29 20:11:09 UTC
libabigail-1.6-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-022547dd8c

Comment 10 Fedora Update System 2019-03-29 20:32:28 UTC
libabigail-1.6-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-e618b6616c

Comment 11 Fedora Update System 2019-03-29 21:56:36 UTC
libabigail-1.6-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-9871f61010

Comment 12 Fedora Update System 2019-03-29 22:41:27 UTC
libabigail-1.6-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-3c238b5efa

Comment 13 Fedora Update System 2019-04-13 00:03:06 UTC
libabigail-1.6-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2019-04-13 01:30:09 UTC
libabigail-1.6-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2019-04-13 06:33:25 UTC
libabigail-1.6-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2019-04-13 15:31:59 UTC
libabigail-1.6-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.