Bug 1673419 - compat-openssl10-devel is AWOL
Summary: compat-openssl10-devel is AWOL
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: compat-openssl10
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-07 13:40 UTC by Miro Hrončok
Modified: 2019-09-21 00:01 UTC (History)
4 users (show)

Fixed In Version: compat-openssl10-1.0.2o-8.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 00:01:41 UTC


Attachments (Terms of Use)

Description Miro Hrončok 2019-02-07 13:40:54 UTC
Since compat-openssl10-1.0.2o-4.fc30, compat-openssl10-devel is no longer there.

There was no Fedora 30 change proposal for this and there was no communication with the package owners about this, please put it back and do a proper Fedora 31 change for this with the path to a newer OpenSSL described.

The following packages BR compat-openssl10-devel and FTBFS for that:

bacula2-0:2.4.4-32.fc29.src
botan-0:1.10.17-11.fc30.src
bro-0:2.5.4-4.fc30.src
compat-openssl10-pkcs11-helper-0:1.22-6.fc29.src
ettercap-0:0.8.2-13.20170306git60aca9.fc29.src
freerdp1.2-0:1.2.0-11.fc29.src
gnome-vfs2-0:2.24.4-27.fc29.src
gq-0:1.3.4-33.fc29.src
httperf-0:0.9.0-22.fc29.src
ipsec-tools-0:0.8.2-14.fc30.src
kqoauth-qt5-0:0.98-0.3.20140122git7c31a12.fc29.src
libwvstreams-0:4.6.1-28.fc30.src
medusa-0:2.2-7.fc29.src
mongo-cxx-driver-legacy-0:1.1.3-2.fc30.src
ncrack-0:0.6-1.fc30.src
netty-tcnative-0:1.1.30-12.fc29.src
opensmtpd-0:6.0.3p1-6.fc30.src
pam_ssh-0:1.98-12.fc29.src
pgadmin3-0:1.22.2-12.fc30.src
ptlib-0:2.10.11-1.fc29.src
pypy3-0:6.0.0-4.fc30.src
python2-0:2.7.15-12.fc30.src
python26-0:2.6.9-18.fc30.src
python34-0:3.4.9-6.fc30.src
python35-0:3.5.6-4.fc30.src
samdump2-0:3.0.0-13.fc28.src
sems-0:1.6.0-13.fc29.src
skipfish-0:2.10-0.18.b.fc29.src
slowhttptest-0:1.7-6.fc29.src
sscep-0:0.6.1-8.20160525git2052ee1.fc29.src
sslscan-0:1.11.11-2.fc29.src
stud-0:0.3-15.20120814git.fc29.src
telepathy-salut-0:0.8.1-15.fc29.src
ucommon-0:7.0.0-10.fc29.src
uwsgi-0:2.0.17.1-7.fc30.src
validns-0:0.8-11.fc29.src
vtun-0:3.0.4-7.fc29.src
w3m-0:0.5.3-40.git20180125.fc29.src

Comment 1 Miro Hrončok 2019-02-07 15:45:41 UTC
Note that python2, python34, python35 and pypy3 would probably build fine with a compat-openssl-1.1.0 package.

Also, pypy3 7.0.0 was just released and might build fine with openssl 1.1.1.

Comment 2 Tomas Mraz 2019-02-08 07:57:31 UTC
I've moved the conditionals to Fedora 31. But I'll probably orphan the package by the time.

Comment 3 Miro Hrončok 2019-02-08 09:00:29 UTC
Thank you.

Comment 4 Miro Hrončok 2019-07-29 15:04:48 UTC
This now happened for compat-openssl10-1:1.0.2o-6.fc31 as well.
There was no Fedora 31 change proposal for this and there was no communication with the package owners about this.
The package is not orphaned.

The following packages BR compat-openssl10-devel and will FTBFS for that:

bacula2-0:2.4.4-33.fc30.src
botan-0:1.10.17-12.fc30.src
bro-0:2.5.4-4.fc30.src
ettercap-0:0.8.2-14.20170306git60aca9.fc30.src
freerdp1.2-0:1.2.0-12.fc30.src
gnome-vfs2-0:2.24.4-28.fc30.src
gq-0:1.3.4-34.fc30.src
httperf-0:0.9.0-23.fc30.src
ipsec-tools-0:0.8.2-15.fc30.src
kqoauth-qt5-0:0.98-0.4.20140122git7c31a12.fc30.src
libwvstreams-0:4.6.1-29.fc30.src
medusa-0:2.2-8.fc30.src
mongo-cxx-driver-legacy-0:1.1.3-2.fc30.src
ncrack-0:0.6-2.fc30.src
netty-tcnative-0:1.1.30-13.fc30.src
opensmtpd-0:6.0.3p1-7.fc30.src
pgadmin3-0:1.22.2-14.fc31.src
python26-0:2.6.9-20.fc30.src
python34-0:3.4.10-1.fc31.src
python35-0:3.5.7-1.fc31.src
samdump2-0:3.0.0-13.fc28.src
skipfish-0:2.10-0.19.b.fc30.src
slowhttptest-0:1.7-7.fc30.src
snownews-0:1.5.12-21.fc31.src
sscep-0:0.6.1-9.20160525git2052ee1.fc30.src
sslscan-0:1.11.11-3.fc30.src
stud-0:0.3-16.20120814git.fc30.src
telepathy-salut-0:0.8.1-15.fc29.src
ucommon-0:7.0.0-11.fc30.src
validns-0:0.8-12.fc30.src
vtun-0:3.0.4-8.fc30.src
w3m-0:0.5.3-42.git20180125.fc31.src

We have preparations in python34 and python35 packages for this. However the rest is still a lot.

Comment 5 Victor Stinner 2019-07-31 15:18:55 UTC
I understand that my https://src.fedoraproject.org/rpms/python34/pull-request/32 PR cannot be merged right now, since compat-openssl10-devel is gone from Rawhide. I propose to modify my PR to switch Python 3.4 to OpenSSL 1.1.1 in Rawhide.

Comment 6 Tomas Mraz 2019-08-05 14:10:09 UTC
OK, the compat-openssl10 is now orphaned.

Comment 7 Miro Hrončok 2019-08-05 14:11:46 UTC
It seems that it is still owned by you (tmraz). Would you like me to orphan it?

Comment 8 Tomas Mraz 2019-08-05 14:31:51 UTC
For some reason the "give to orphan" procedure failed first time. Now it should be really orphaned.

Comment 9 Miro Hrončok 2019-08-05 15:02:36 UTC
Indeed.

Comment 10 Ben Cotton 2019-08-13 16:53:09 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 11 Ben Cotton 2019-08-13 18:33:13 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 13 Fedora Update System 2019-09-10 22:50:44 UTC
FEDORA-2019-db06efdea1 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-db06efdea1

Comment 14 Fedora Update System 2019-09-11 15:37:15 UTC
compat-openssl10-1.0.2o-8.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-db06efdea1

Comment 15 Fedora Update System 2019-09-21 00:01:41 UTC
compat-openssl10-1.0.2o-8.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.