Bug 167347 - Canon IXUS 700 support
Summary: Canon IXUS 700 support
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gphoto2   
(Show other bugs)
Version: 4
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Radek Vokal
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-01 20:10 UTC by Clément MATHIEU
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 2.1.99-13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-29 11:34:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against libgphoto (740 bytes, patch)
2005-09-01 20:14 UTC, Clément MATHIEU
no flags Details | Diff
debug output with canon ixus 700 and gphoto2-2.1.99-10 (24.40 KB, text/plain)
2006-04-15 09:25 UTC, Daniel Qarras
no flags Details

Description Clément MATHIEU 2005-09-01 20:10:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Canon ixus cameras have two transfert protocols, PTP and "another one than USB mass storage". gphoto2 implements them both but only PTP works. The second one is know to be broken [1]

Gphoto2 tries to autodetect camera by alphabetic order. And as you can see from the output of "gphoto2 --list-camera" 

     "Canon Digital IXUS 700 (normal mode)" (EXPERIMENTAL)
     "Canon Digital IXUS 700 (PTP mode)"

the broken protocol comes before the working one, so the autodetect feature can't be used (read gthumb does not work).

[1] http://sourceforge.net/mailarchive/forum.php?thread_id=7953860&forum_id=32960 for the most recent message.


Version-Release number of selected component (if applicable):
gphoto2-2.1.6-1

How reproducible:
Always

Steps to Reproduce:
1. Plug the camera
2. gphoto2 --list-file
3. read the error message about lock key
  

Actual Results:  In short photos cannot be retrieved. You get an error message like this one:

*** Erreur (-114: 'OS error in camera communication') ***


Additional info:

A trivial patch is to remove the broken protocol from libgphoto2, the camera will be detected as a normal PTP camera and will be supported.

Canon IXUS 700 is also known as PowerShot SD500 or IXY Digital 60

Comment 1 Clément MATHIEU 2005-09-01 20:14:12 UTC
Created attachment 118367 [details]
Patch against libgphoto

I have rebuild the RPM with this patch applied and all is working fine !

Comment 2 Radek Vokal 2006-01-08 16:09:13 UTC
Can you please retest your issue with gphoto2-2.1.99 from rawhide? 

Comment 3 Radek Vokal 2006-02-08 09:32:30 UTC
I believe this is fixed in rawhide. 

Comment 4 Clément MATHIEU 2006-02-08 10:31:11 UTC
Sorry for the delay but I missed your previous comment.

I just tested gphoto2 on a FC2t5 and it seems the bug hasn't been fixed

# rpm -qa | grep gphoto2
gphoto2-2.1.99-5

# env LANG=C gphoto2 --auto-detect
Model                          Port
----------------------------------------------------------
Canon Digital IXUS 700 (normal mode) usb:

# env LANG=C gphoto2 -P
Detected a 'Canon:PowerShot SD500 (normal mode)'.

*** Error ***
lock keys failed.
*** Error (-114: 'OS error in camera communication') ***

# env LANG=C gphoto2 --camera "USB PTP Class Camera" --port "usb:" -P
Downloading 'IMG_3941.JPG' from folder '/store_00010001/DCIM/639CANON'...
Saving file as IMG_3941.JPG

Normal mode is still the default mode and still does not work, so you will be
unable to import photos using gthumb.

I can attach a full debug log if needed.

Thanks

Comment 5 Daniel Qarras 2006-04-15 09:24:09 UTC
I am having the problem with my Canon IXUS 700. I tried both gphoto2-2.1.99-8
and gphoto2-2.1.99-10 to no avail. I'll attached debug output generated with:

env LANG=C gphoto2 --debug --summary

I'll gladly test new gphoto2 RPMs if needed.

Thanks.

Comment 6 Daniel Qarras 2006-04-15 09:25:23 UTC
Created attachment 127774 [details]
debug output with canon ixus 700 and gphoto2-2.1.99-10

Comment 7 Daniel Qarras 2006-04-17 21:10:19 UTC
More information! Ixus 700 must use PTP mode. I got this info from gphoto2 list.
See
http://sourceforge.net/mailarchive/forum.php?thread_id=10181609&forum_id=32960
for more.

But, as said, even the latest RPM does not work yet at the moment.

Comment 8 Marcus Meissner 2006-04-19 06:42:51 UTC
you need to remove all 3 occurences of the USB id pair, not just 1. (the line 
above and below) 

Comment 9 Marcus Meissner 2006-04-19 06:43:17 UTC
you need to remove all 3 occurences of the USB id pair, not just 1. (the line 
above and below) 

Comment 10 Daniel Qarras 2006-05-29 08:54:07 UTC
So what's the status with this? All information needed should be available to
roll out a package containing needed fixes. Thanks.

Comment 11 Clément MATHIEU 2006-05-29 09:25:07 UTC
Still does not work out of box.

For IXUS 700 patch #1 is needed. I'm running this patch since one year...

Others IXUS probably need the same kind of patch but I only own an IXUS 700 so I
can't tell if it is needed or working...

I can test new package if needed.

Comment 12 Radek Vokal 2006-05-29 11:34:12 UTC
Ok, I've remmoved Ixus 700 in gphoto2-2.1.99-13. Can you please retest this
package? Thanks

Comment 13 Clément MATHIEU 2006-05-29 15:05:54 UTC
Probably stupid question but Where can I find gphoto2-2.1.99-13 ?

In /pub/fedora/linux/core/development/i386/os/Fedora/RPMS on
download.fedora.redhat.com only -12 is available not -13.

Thanks

Comment 14 Radek Vokal 2006-05-29 15:17:55 UTC
Just give it some time to synchronise. It went through build system and will
appear there really soon. 

Comment 15 Daniel Qarras 2006-05-31 16:36:53 UTC
I am happy to confirm that with gphoto2-2.1.99-13 my Canon IXUS 700 works now
all ok!

Thanks!


Note You need to log in before you can comment on or make changes to this bug.