Bug 167356 - tora is now fully GPL and being maintaned again
tora is now fully GPL and being maintaned again
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: tora (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
http://sourceforge.net/project/showfi...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-01 16:58 EDT by Don Himelrick
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-24 14:47:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Himelrick 2005-09-01 16:58:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Tora is now being maintained (not sure if it ever really wasn't, there seems to have been some confusion about it on the development forums) AND is (still?) fully  GPL.   Not sure if this falls under extras or not, but I wonder if it could be included in either core or extras again?  I thought it was dropped because of problems with the initial deal with quest software.  Anyway, I think it is a very good package and it seems that the mainatiners now have the project back on its feet.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
See the URL above.

Additional info:
Comment 1 Mihai Ibanescu 2005-09-14 10:28:04 EDT
tora didn't make a lot of sense in core, since it's quite specialized. Its place
is indeed in extras, the latest will get there hopefully this week.
Comment 2 Mihai Ibanescu 2005-09-30 11:34:52 EDT
I tried to compile tora, they seem to have changed a lot and it doesn't install
properly, at least not on my machine. I'll wait for the next build (I tried 1.3.19).
Comment 3 Don Himelrick 2005-09-30 12:04:46 EDT
I compiled 1.3.19 on my FC4 machine, but I had to change one or two config
options.  They changed their configure from some kind of perl script to a
regular bash style configure process.  The old perl script generated some stuff
needed to make an rpm, like the file list use in the files section of the spec
file.  I tried to make an rpm, but I couldn't figure out how to generate a list
of all of the files that the spec file needs :(  I'm an rpm newbie and I never
can figure out what files rpm needs in the files section for any regualr sized
builds.

I can send you my source tree if that would help?
Comment 4 Mihai Ibanescu 2005-09-30 12:24:44 EDT
Well, make install really doesn't do what it used to. I was able to compile it
too, but the plugins and the libraries are all installed in the same dir and I
didn't try to see if they work like that.

Correction, I checked with 1.3.18, there's no 1.3.19 yet. I'll see if tora is
usable in 1.3.18.
Comment 5 Don Himelrick 2005-10-13 12:38:43 EDT
There is a bug in tora (or maybe KDE?) that goofs up the text display in the sql
editor.  It is mentioned in the tora mailing list with a workaround of compiling
with the without-kde or with-kde=no option.  I did this (tora-1.3.18) and it is
working very well for me, but I still can't the %files thing right to make an rpm.
Comment 6 Rahul Sundaram 2005-11-24 14:47:20 EST
If anyone is interested in packaging and maintaining tora in Fedora Extras, look
at http://fedoraproject.org/wiki/Extras. If you need any help with it, post to
the fedora-extras list.

Closing this.

Note You need to log in before you can comment on or make changes to this bug.