Bug 1673625 - All firewalld operations failing since Fedora-Rawhide-20190203.n.0
Summary: All firewalld operations failing since Fedora-Rawhide-20190203.n.0
Keywords:
Status: CLOSED DUPLICATE of bug 1672683
Alias: None
Product: Fedora
Classification: Fedora
Component: firewalld
Version: rawhide
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Eric Garver
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa
Depends On:
Blocks: F30BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2019-02-07 16:11 UTC by Adam Williamson
Modified: 2019-02-07 17:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-07 17:22:04 UTC
Type: Bug


Attachments (Terms of Use)

Description Adam Williamson 2019-02-07 16:11:11 UTC
Since Fedora-Rawhide-20190203.n.0 , all firewalld operations seem to be broken. All openQA tests that do something with firewalld are reliably failing.

`firewall-cmd --state` shows "failed" and returns 251. `systemctl status firewalld.service` shows "active (running)", but the logs show multiple errors:

Feb 07 07:29:48 adam.happyassassin.net firewalld[1181]: ERROR: '/usr/sbin/ebtables-restore --noflush' failed: Bad table name 'nat'.
Feb 07 07:29:48 adam.happyassassin.net firewalld[1181]: ERROR: '/usr/sbin/ebtables-restore --noflush' failed: Bad table name 'nat'.
Feb 07 07:29:50 adam.happyassassin.net firewalld[1181]: ERROR: COMMAND_FAILED: '/usr/sbin/ebtables-restore --noflush' failed: Bad table name 'nat'.
Feb 07 07:29:50 adam.happyassassin.net firewalld[1181]: ERROR: '/usr/sbin/iptables-restore -w -n' failed: iptables-restore: line 4 failed
Feb 07 07:29:50 adam.happyassassin.net firewalld[1181]: ERROR: '/usr/sbin/ip6tables-restore -w -n' failed: ip6tables-restore: line 11 failed
Feb 07 07:29:50 adam.happyassassin.net firewalld[1181]: ERROR: COMMAND_FAILED: '/usr/sbin/ip6tables-restore -w -n' failed: ip6tables-restore: line 11 failed
Feb 07 07:29:50 adam.happyassassin.net firewalld[1181]: ERROR: '/usr/sbin/iptables-restore -w -n' failed: iptables-restore: line 4 failed
Feb 07 07:29:50 adam.happyassassin.net firewalld[1181]: ERROR: '/usr/sbin/ip6tables-restore -w -n' failed: ip6tables-restore: line 4 failed
Feb 07 07:29:50 adam.happyassassin.net firewalld[1181]: ERROR: COMMAND_FAILED: '/usr/sbin/ip6tables-restore -w -n' failed: ip6tables-restore: line 4 failed

Commands like `firewall-cmd --permanent --add-service postgresql` show "Error: INVALID_ZONE".

Proposing as a Beta blocker as a violation of "After system installation without explicit firewall configuration, the system firewall must be active on all non-loopback interfaces. The only ports which may be open to incoming traffic are port 22 (ssh) and port 9090 (Cockpit web interface). Supported install-time firewall configuration options must work correctly" - https://fedoraproject.org/wiki/Basic_Release_Criteria#Firewall_configuration

Comment 1 Eric Garver 2019-02-07 17:22:04 UTC

*** This bug has been marked as a duplicate of bug 1672683 ***


Note You need to log in before you can comment on or make changes to this bug.