Bug 1673714 - sudden loss of input in gnome-shell
Summary: sudden loss of input in gnome-shell
Keywords:
Status: CLOSED DUPLICATE of bug 1671286
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-07 20:33 UTC by Porygon
Modified: 2019-02-08 03:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-08 03:43:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Porygon 2019-02-07 20:33:27 UTC
Description of problem:

gnome-terminal and activities overlay stop receiving any input from the keyboard, except for some strange exceptions. the super key still opens/closes activities, and I was able to input text into nautilus search and firefox, but any newly opened gnome-terminal, gedit or vte instance also stopped receiving input. xterm still accepts input, however.

Version-Release number of selected component (if applicable):


How reproducible:

Sometimes

Steps to Reproduce:

Uncertain of exact steps, but halfline and I determined that it is an ibus issue and probably has to do with stalls in a compositor.

Actual results:

various gnome-shell applications no longer receive keyboard input

Expected results:

able to use keyboard to input into terminal/gnome-shell search

Additional info:

Lenovo ThinkPad T480s
Fedora 29
kernel version 4.20.4-200.fc29.x86_64
ibus-1.5.19-13.fc29.x86_64

Comment 1 fujiwara 2019-02-08 03:43:16 UTC
Sorry for the trouble. It was hard to reproduce the issue but I think it's now fixed.

*** This bug has been marked as a duplicate of bug 1671286 ***


Note You need to log in before you can comment on or make changes to this bug.