Bug 167388 - iiimf-le-xcin causes "status has not been enabled yet" in system log
iiimf-le-xcin causes "status has not been enabled yet" in system log
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: iiimf-le-xcin (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Leon Ho
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-02 05:39 EDT by Tommas Ip
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 01:49:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix conversion_on() and status_draw() in src/le_proc.c (743 bytes, patch)
2005-09-06 06:26 EDT, Tommas Ip
no flags Details | Diff

  None (edit)
Description Tommas Ip 2005-09-02 05:39:38 EDT
Description of problem:
After activated the input method, it may produce repeating messages in system
log /var/log/messages. It has been reported under bug RH#135284 (htt/iiimd).

There are two form of messages:
The first generated when switching between applications:

Sep  2 16:22:08 descent iiimd[15089]: status has not been enabled yet. (1, 1)
Sep  2 16:22:41 descent last message repeated 8 times

The second generated when in preedit:

Sep  2 14:14:58 descent iiimd[2497]: preedit has not been enabled yet. (1, 1)
Sep  2 14:15:28 descent last message repeated 57 times


Version-Release number of selected component (if applicable):
0.1.10-2 (development)

How reproducible:
Always

Steps to Reproduce:
1. Activate iiimf-le-xcin
2. Randomly type some character (preedit) for Changjie input method
3. Notes the system log, it should popup lots of 'preedit has not been enabled
yet. (1, 1)' messages
4. Try switch between apps when input method is open
5. Notes the system log, it should popup lots of 'status has not been enabled
yet. (1, 1)' messages
  
Actual results:
The system log was flooded with useless messages.

Expected results:
No noise in syslog

Additional info:
Comment 1 Tommas Ip 2005-09-06 06:26:59 EDT
Created attachment 118489 [details]
fix conversion_on() and status_draw() in src/le_proc.c

It's seems that it should be iml_make_preedit_start_inst() instead of
iml_make_preedit_done_inst() in conversion_on().
Also it should call iml_make_status_done_inst() after status_draw in
status_draw().

So far it isn't has any problem after applying my own patch.
Comment 3 Lawrence Lim 2005-09-30 01:49:23 EDT
We strive to work with the upstream community of open source projects. This
allows us to reduce the likelihood of regressions between releases as well as to
benefit from features and fixes as development moves forward. Since this change
would require a divergence from the upstream project, please report this issue
to IIIMF developers by filing a bug report in the OpenI18N bugzilla located at
http://openi18n.org/bugzilla/ in the "IIIMF" component.

We urge you to bring the information upstream, so that it can be incorporated in
the next release. Once you've filed your bug report to OpenI18N, if you paste
the new bug URL here, we will continue to track the issue in the centralized
OpenI18N bug tracker, and will review any bug fixes that become available for
consideration in future updates.

Thanks. 

Note You need to log in before you can comment on or make changes to this bug.