Bug 16739 - (NET EPIC100) epic100 broken for smc9432btx
(NET EPIC100) epic100 broken for smc9432btx
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-22 15:20 EDT by Michael Redinger
Modified: 2013-07-02 22:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:38:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2000-08-22 15:20:33 EDT
The epic100 driver is completely broken for the SMC 9432BTX card (BTX is
the combo card- both BNC and TP). I did attach it to a 100mbit LAN. The
installer did find, but it doesn't work ... I know there are some module
options to make it work.

Hard to say who is to blame - the module or the installer. Yes, the
installer could add some more options to modules.conf. However, attaching
the card to a twisted pair network is the most simple test. I didn't even
dare to use the BNC interface (I know it is broken anyways ...). I don't
even dare to dream of correct autosensing, this simply didn't ever work for
this card ... pitty ... after all, forget Linux with this card as of now
...
Comment 1 Pekka Savola 2000-08-22 16:55:42 EDT
You can specify module options using expert mode, if that'd be of any help..
Comment 2 Michael Redinger 2000-08-23 05:57:42 EDT
No it doesn't ... :( 
The card simply does not work, period. Tried all types of network (100 FD, 100
HD, 10baseT, 10base2) and did configure the module options correctly. No chance.
Comment 3 Michael K. Johnson 2000-08-23 11:58:18 EDT
I don't understand.  You say first that it works if you give
it options, then when pp pointed out the options, you say that
it doesn't work with the options.  Has it ever worked?  If so,
what options do you expect to make it work?

I'm deferring this because we won't have time to fix and test
it even if we figure out what the bug is soon.
Comment 4 Michael Redinger 2000-08-23 12:22:23 EDT
Just FYI: did some extensive testing today. Only BNC works now (parameter
options=1), UTP is completely broken.
Our test cases seem to indicate that the driver doesn't really use fixed
settings, even when the EEPROM of the card is properly configured (using ezstart
from SMC). The options seem to have some affect, but they aren't relyble either.
The card and the switch (we tried Cisco and Xylan - now Alcatel - switches)
don't seem to be able to finish negotiation, and the link goes up and down. On
the SMC europe homepage I did find a proper driver (note that it is different
from that on the smc.com homepage). It works fine, does find the proper
interface (BNC, all UTP variants) with autodection (that is, switching to BNC if
no UTP link beat is detected, otherwise doing autonegotiation). It's available
as source code (didn't compile on 7.0 RC2 but on 6.2), but I fear it's a
commercial license ... but I think if there would be a chance to make this
driver GPL (as it can be distributed anyway), somebody would just have to talk
to them ....
And, again: this holds only true for SMC9432BTx ("combo" card), the 9432BT (UTP
only) works perfect.
Comment 5 Michael Redinger 2000-12-28 13:11:17 EST
Update for Florence Beta 1:

- SMC9432BTX doesn't work at all without specifying any parameters (no matter
whether you use
   BNC or TP)
- BNC works if the parameter options=1 is set
- twisted pair never works (tried all combinations of HD, FD 100/10 MBbit)

Again, SMC9432BT (the TP-only card) works fine.

The testing is quite difficult, you don't always know which part fails, but I
tried two different
switches and one hub, so I this is a Linux problem - also, this works fine using
any version
of Windows.
Using hardware tests it seems as if the link is going up and down all the time -
negotiation seems
broken (could be something very different though)

Comment 6 Glen Foster 2001-01-11 16:03:55 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 7 Glen Foster 2001-01-12 11:22:33 EST
After review, this defect is being re-classified; it is no longer considered
MUST-FIX for the Florence release.  The decision is that the TP-only cards are
much more popular and hence, we are not going to worry about this one.
Comment 8 Bugzilla owner 2004-09-30 11:38:49 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.