Bug 1673921 - not found error on Reboot action for a VM in Importing/Pending status
Summary: not found error on Reboot action for a VM in Importing/Pending status
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Container Native Virtualization (CNV)
Classification: Red Hat
Component: User Experience
Version: 1.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 2.0
Assignee: Phillip Bailey
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks: 1712736
TreeView+ depends on / blocked
 
Reported: 2019-02-08 13:03 UTC by Irina Gulina
Modified: 2019-07-24 20:15 UTC (History)
7 users (show)

Fixed In Version: v2.0.0-14.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1712736 (view as bug list)
Environment:
Last Closed: 2019-07-24 20:15:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:1850 None None None 2019-07-24 20:15:59 UTC

Description Irina Gulina 2019-02-08 13:03:52 UTC
Description of problem:
There is an 'Importing' state of a VM. I have not seen that one documented anywhere. Nevertheless, in Actions there are options to stop/restart and delete that machine (Which is also not documented in [1], e.g.). Stop and Delete works fine, but Restart returns an error: "<name> not found."

Version-Release number of selected component (if applicable):
oc v3.11.69
kubernetes v1.11.0+d4cacc0


How reproducible:
always

Steps to Reproduce:
1. Create a virtual machine, and choose Container as a provision source
2. Start that machine, observe Importing... 
3. Choose Restart in Actions

Actual results:
An error machine is not found. 

Expected results:
There should be smth about Importing in docs, and no error on Reboot. Or maybe even no Stop/Restart actions, if those are not applicable (are they?), before image import.


Additional info:
[1] https://github.com/openshift/openshift-docs/blob/61a051b762659b05377301e9aca5df764ab3418a/modules/cnv_vm_actions_web.adoc#cnv-vm-actions-web

Comment 1 Tomas Jelinek 2019-02-11 12:18:27 UTC
@Andrew: FYI, not sure if you need a separate BZ to handle it.

Comment 2 Irina Gulina 2019-02-12 15:18:36 UTC
Tomas, I have opened a separate doc BZ 1676572

Comment 3 Tomas Jelinek 2019-02-14 08:36:08 UTC
as per agreement moving this to 2.0

Comment 4 Tomas Jelinek 2019-03-27 00:02:55 UTC
https://github.com/kubevirt/web-ui/pull/237

Comment 5 Guohua Ouyang 2019-05-08 05:57:07 UTC
How to get a VM into importing status? I see it once and the restart option is not available when vm is importing.

But for status "pending", "Importer Error", the problem "VM not found" is still there, I think "restart" should be disabled for these status as well.
And "migration" should be disabled since the VM is not existed yet.

Comment 6 Rastislav Wagner 2019-05-16 11:36:53 UTC
How to get a VM into importing status? I see it once and the restart option is not available when vm is importing.
-> Vm is in importing status when you use URL source and import didn't complete yet


https://github.com/kubevirt/web-ui/pull/375

Comment 7 Guohua Ouyang 2019-05-22 07:17:02 UTC
Restart and Migration are not available in vm actions when vm in importing.

Comment 9 errata-xmlrpc 2019-07-24 20:15:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1850


Note You need to log in before you can comment on or make changes to this bug.