Bug 1674034 - openshift-install fails with 'Error launching source instance: Unsupported: The requested configuration is currently not supported.'
Summary: openshift-install fails with 'Error launching source instance: Unsupported: T...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: W. Trevor King
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks: 1664187 1686361
TreeView+ depends on / blocked
 
Reported: 2019-02-08 19:48 UTC by emahoney
Modified: 2019-06-04 10:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1686361 (view as bug list)
Environment:
Last Closed: 2019-06-04 10:42:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:43:51 UTC
Github openshift installer pull 1163 None None None 2019-02-15 07:16:01 UTC

Description emahoney 2019-02-08 19:48:18 UTC
Description of problem: When installing the 4.0 beta in the AZ eu-west-3 I am seeing the error below. Not sure whether it is specific to the AZ or my install config. 

~~~
# ./openshift-install create cluster
INFO Consuming "Install Config" from target directory 
INFO Creating cluster...                          
ERROR                                              
ERROR Error: Error applying plan:                  
ERROR                                              
ERROR 4 errors occurred:                           
ERROR 	* module.masters.aws_instance.master[1]: 1 error occurred: 
ERROR 	* aws_instance.master.1: Error launching source instance: Unsupported: The requested configuration is currently not supported. Please check the documentation for supported configurations. 
ERROR 	status code: 400, request id: c41bbcd7-f2dd-400c-bdd1-da85c6f183db 
ERROR                                              
ERROR                                              
ERROR 	* module.masters.aws_instance.master[0]: 1 error occurred: 
ERROR 	* aws_instance.master.0: Error launching source instance: Unsupported: The requested configuration is currently not supported. Please check the documentation for supported configurations. 
ERROR 	status code: 400, request id: f3a19b07-6d29-443c-9be7-09534ff83f0c 
ERROR                                              
ERROR                                              
ERROR 	* module.masters.aws_instance.master[2]: 1 error occurred: 
ERROR 	* aws_instance.master.2: Error launching source instance: Unsupported: The requested configuration is currently not supported. Please check the documentation for supported configurations. 
ERROR 	status code: 400, request id: 4a2c5725-e075-46dc-9ed0-8a50e02763c7 
ERROR                                              
ERROR                                              
ERROR 	* module.bootstrap.aws_instance.bootstrap: 1 error occurred: 
ERROR 	* aws_instance.bootstrap: Error launching source instance: Unsupported: The requested configuration is currently not supported. Please check the documentation for supported configurations. 
ERROR 	status code: 400, request id: 4ad6f74f-ae75-4ea8-9352-bdebe6b59f41 
ERROR                                              
ERROR                                              
ERROR                                              
ERROR                                              
ERROR                                              
ERROR Terraform does not automatically rollback in the face of errors. 
ERROR Instead, your Terraform state file has been partially updated with 
ERROR any resources that successfully completed. Please address the error 
ERROR above and apply again to incrementally change your infrastructure. 
ERROR                                              
ERROR                                              
FATAL failed to fetch Cluster: failed to generate asset "Cluster": failed to create cluster: failed to apply using Terraform 
~~~~

# vi install-config.yaml

apiVersion: v1beta1
baseDomain: rhcee.support
machines:
- name: master
  platform: {}
  replicas: 3
- name: worker
  platform: {}
  replicas: 3
metadata:
  creationTimestamp: null
  name: mahoney4test4
networking:
  clusterNetworks:
  - cidr: 10.128.0.0/14
    hostSubnetLength: 9
  machineCIDR: 10.0.0.0/16
  serviceCIDR: 172.30.0.0/16
  type: OpenshiftSDN
platform:
  aws:
    region: eu-west-3
pullSecret: '{"auths":{"cloud.openshift.com":{"auth":"blah","email":"emahoney@redhat.com"},"quay.io":{"auth":"blah","email":"emahoney@redhat.com"}}}'
sshKey: |
  ssh-rsa blah root@mahoneyrocks


Version-Release number of the following components:
# ./openshift-install version
./openshift-install v0.10.0


How reproducible:
Can repeat at will. 

Steps to Reproduce:
- ./openshift-install create install-config
- ./openshift-install create cluster


Actual results:
openshift-install fails with:

~~~
Error launching source instance: Unsupported: The requested configuration is currently not supported. Please check the documentation for supported configurations. 
ERROR 	status code: 400, request id: 4ad6f74f-ae75-4ea8-9352-bdebe6b59f41
~~~

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 3 W. Trevor King 2019-02-15 07:16:02 UTC
installer#1163 addresses this, and is currently waiting on review.

Comment 5 Johnny Liu 2019-02-21 10:56:26 UTC
QE can reproduce this bug with v0.12.0 installer in eu-west-3.

Re-test it with v4.0.0-0.177.0.1-dirty installer (extracted from 4.0.0-0.nightly-2019-02-21-034936 payload), still reproduced.

# ./openshift-install create cluster --dir demo2
<--snip-->
INFO Creating cluster...                          
ERROR                                              
ERROR Error: Error applying plan:                  
ERROR                                              
ERROR 5 errors occurred:                           
ERROR 	* module.bootstrap.aws_instance.bootstrap: 1 error occurred: 
ERROR 	* aws_instance.bootstrap: Error launching source instance: Unsupported: The requested configuration is currently not supported. Please check the documentation for supported configurations. 
ERROR 	status code: 400, request id: 6e49051d-7808-4d2c-acfb-889c2a5c1026 
ERROR                                              
ERROR                                              
ERROR 	* module.masters.aws_instance.master[2]: 1 error occurred: 
ERROR 	* aws_instance.master.2: Error launching source instance: Unsupported: The requested configuration is currently not supported. Please check the documentation for supported configurations. 
ERROR 	status code: 400, request id: a9e31cd5-dcaa-4cce-bb43-52628c84432b 
ERROR                                              
ERROR                                              
ERROR 	* module.masters.aws_instance.master[0]: 1 error occurred: 
ERROR 	* aws_instance.master.0: Error launching source instance: Unsupported: The requested configuration is currently not supported. Please check the documentation for supported configurations. 
ERROR 	status code: 400, request id: ddd7fe64-103c-4650-b650-280d8aa725e9 
ERROR                                              
ERROR                                              
ERROR 	* module.masters.aws_instance.master[1]: 1 error occurred: 
ERROR 	* aws_instance.master.1: Error launching source instance: Unsupported: The requested configuration is currently not supported. Please check the documentation for supported configurations. 
ERROR 	status code: 400, request id: 362cd64d-247c-42f2-8bf7-d34acf0acf17

Comment 6 Johnny Liu 2019-02-21 10:57:57 UTC
Ooops, did not notice the PR is not merged yet.

Comment 7 W. Trevor King 2019-02-27 06:02:03 UTC
[1] went out with [2], so this should be fixed now.

[1]: https://github.com/openshift/installer/pull/1163
[2]: https://github.com/openshift/installer/releases/tag/v0.13.0

Comment 9 Johnny Liu 2019-03-07 10:26:35 UTC
Verified this bug with v4.0.16-1-dirty (extracted from 4.0.0-0.nightly-2019-03-06-074438), and PASS.

[root@preserve-jialiu-ansible 20190307]# ./openshift-install create cluster --dir ./bz1674034/
WARNING Found override for OS Image. Please be warned, this is not advised 
WARNING Found override for ReleaseImage. Please be warned, this is not advised 
INFO Consuming "Install Config" from target directory 
INFO Creating cluster...                          
INFO Waiting up to 30m0s for the Kubernetes API... 
INFO API v1.12.4+b3e6ad4 up                       
INFO Waiting up to 30m0s for the bootstrap-complete event... 
WARNING RetryWatcher - getting event failed! Re-creating the watcher. Last RV: 4108 
WARNING RetryWatcher - getting event failed! Re-creating the watcher. Last RV: 4533 
WARNING RetryWatcher - getting event failed! Re-creating the watcher. Last RV: 4847 
INFO Destroying the bootstrap resources...        
INFO Waiting up to 30m0s for the cluster to initialize... 
FATAL failed to initialize the cluster: Cluster operator image-registry has not yet reported success 


The last failure about Cluster operator image-registry is another issue, will clone this bug to image-registry component later.

Comment 12 errata-xmlrpc 2019-06-04 10:42:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.