This site requires JavaScript to be enabled to function correctly, please enable it.
Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
Summary:
[OSP10] VNX driver sends a remove_hba() to storops instead of delete_hba()
Product:
Red Hat OpenStack
Reporter:
David Vallee Delisle <dvd>
Component:
openstack-cinder Assignee:
Eric Harney <eharney>
Status:
CLOSED
CURRENTRELEASE
QA Contact:
Tzach Shefi <tshefi>
Severity:
high
Docs Contact:
Tana <tberry>
Priority:
high
Version:
10.0 (Newton) CC:
abishop, eharney, gfidente, igallagh, jjoyce, pgrist, pkovacs, shdunne, slinaber, tvignaud
Target Milestone:
z11 Keywords:
OtherQA, TestOnly, Triaged, ZStream
Target Release:
10.0 (Newton) Flags:
tshefi:
automate_bug-
Hardware:
Unspecified
OS:
Unspecified
Whiteboard:
Fixed In Version:
openstack-cinder-9.1.4-50.el7ost
Doc Type:
Bug Fix
Doc Text:
Previously, volume detach operations were not working. This was because a function was renamed that the cinder VNX driver calls when detaching a volume. The VNX driver would crash when it tried to invoke the old function name. This issue has been resolved by updating the VNX driver to use the new function name.
Story Points:
---
Clone Of:
Environment:
Last Closed:
2019-10-16 10:49:13 UTC
Type:
Bug
Regression:
---
Mount Type:
---
Documentation:
---
CRM:
Verified Versions:
Category:
---
oVirt Team:
---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team:
---
Target Upstream Version:
Embargoed:
Bug Depends On:
Bug Blocks:
1684207
Description of problem: When we enable "initiator_auto_deregister" and all the volumes are detached from a compute node, the last volume fails to fully detached because the VNX driver is failing to deregister the initiator Version-Release number of selected component (if applicable): master branch How reproducible: All the time Steps to Reproduce: 1. Enable initiator_auto_deregister on vnx driver 2. Detach all volumes from instances on a compute node Actual results: Last volume will remain in detaching [1] and we have this traceback [2] in volume.log Expected results: It sould detach and deregister the initiator. Additional info: [1] ~~~ +--------------------------------+------------------------------------------------------------------------------------------------------------------------------------------------+ | Field | Value | +--------------------------------+------------------------------------------------------------------------------------------------------------------------------------------------+ | attachments | [{u'server_id': u'f0acbadf-8452-49b4-83f3-d7f23d9a5e5d', u'attachment_id': u'4dd4d3a9-7a41-433d-82d2-7c99450fcaa7', u'attached_at': | | | u'2019-02-07T21:36:27.000000', u'host_name': None, u'volume_id': u'8fd10445-cf58-4b2c-a4d5-4619c368ff03', u'device': u'/dev/vdb', u'id': | | | u'8fd10445-cf58-4b2c-a4d5-4619c368ff03'}] | | availability_zone | nova | | bootable | false | | consistencygroup_id | None | | created_at | 2019-02-07T21:32:34.000000 | | description | None | | encrypted | False | | id | 8fd10445-cf58-4b2c-a4d5-4619c368ff03 | | migration_status | None | | multiattach | False | | name | admin_test1 | | os-vol-host-attr:host | hostgroup@vnx_iscsi#somepool | | os-vol-mig-status-attr:migstat | None | | os-vol-mig-status-attr:name_id | None | | os-vol-tenant-attr:tenant_id | 08ad00ba2dd34ae6ad30c788eea2aacc | | properties | attached_mode='rw', readonly='False', snapcopy='False' | | replication_status | disabled | | size | 1 | | snapshot_id | None | | source_volid | None | | status | detaching | | type | allflash | | updated_at | 2019-02-08T16:28:47.000000 | | user_id | 480a0bd09dee4b54935d2573eaf93d88 | +--------------------------------+------------------------------------------------------------------------------------------------------------------------------------------------+ ~~~ [2] ~~~ 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager [req-a496c8a6-1e2f-4360-98bf-bd5aac2fec89 480a0bd09dee4b54935d2573eaf93d88 08ad00ba2dd34ae6ad30c788eea2aacc - default default] Terminate volume connection failed: 'VNXSystem' does not contain attribute 'remove_hba' 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager Traceback (most recent call last): 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager File "/usr/lib/python2.7/site-packages/cinder/volume/manager.py", line 1572, in terminate_connection 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager force=force) 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager File "/usr/lib/python2.7/site-packages/cinder/zonemanager/utils.py", line 105, in decorator 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager conn_info = terminate_connection(self, *args, **kwargs) 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/emc/vnx/driver.py", line 209, in terminate_connection 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager conn_info = self.adapter.terminate_connection(volume, connector) 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/emc/vnx/adapter.py", line 921, in terminate_connection 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager return self._terminate_connection(volume, connector) 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/emc/vnx/adapter.py", line 941, in _terminate_connection 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager self.terminate_connection_cleanup(host, sg) 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/emc/vnx/adapter.py", line 979, in terminate_connection_cleanup 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager self._destroy_empty_sg(host, sg) 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/emc/vnx/adapter.py", line 987, in _destroy_empty_sg 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager self._deregister_initiator(host) 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/emc/vnx/adapter.py", line 1001, in _deregister_initiator 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager self.client.deregister_initiators(initiators) 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/emc/vnx/client.py", line 500, in deregister_initiators 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager self.vnx.remove_hba(initiator_uid) 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager File "/usr/lib/python2.7/site-packages/storops/lib/resource.py", line 172, in __getattr__ 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager ret = self._get_property_from_raw(item) 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager File "/usr/lib/python2.7/site-packages/storops/vnx/resource/__init__.py", line 113, in _get_property_from_raw 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager value = super(VNXCliResource, self)._get_property_from_raw(item) 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager File "/usr/lib/python2.7/site-packages/storops/lib/resource.py", line 193, in _get_property_from_raw 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager self.__class__.__name__, item)) 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager AttributeError: 'VNXSystem' does not contain attribute 'remove_hba' 2019-02-08 16:29:03.927 502744 ERROR cinder.volume.manager ~~~