Bug 167436 - Adding partitions kills W2k when setting up dual boot on same drive
Adding partitions kills W2k when setting up dual boot on same drive
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-02 12:27 EDT by Michael Wiktowy
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-06 11:20:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Wiktowy 2005-09-02 12:27:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
Just to be clear, this is not a duplicate of the changing drive CHS values problem on installation killing W2k.

When anaconda (or anything else for that matter) sets up a new partition to install Fedora on on the same drive as an existing installation of W2k, it will disable W2k on a drive that is bigger than 137 GB unless W2k is set up to support large drives while W2k can still boot (i.e. *before* you attempt to install Fedora).

Now this isn't strictly Fedora's problem but if a new-comer to Linux wants to try it out by setting up a dual boot system, they are going to blame Linux since the problem will show up once Linux is installed and disappear once Linux (and the partitions and grub) are completely removed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install W2k from old media (W2k+SP2 has this problem  ... don't know if more recent install media enables large disks by default) onto a partition on a large (137GB+) disk
2. Update it via MS update to the lastest SP (to demonstrate that simple updating does not enable large disks)
3. Add a partition via anaconda or fdisk on a LiveCD
4. See W2k die
  

Actual Results:  W2k will start to boot, it will hit midway in its graphical boot progress meter and halt with a blue screen and a INACCESSIBLE_BOOT_DEVICE error.
Fedora will boot just fine.

Expected Results:  On drives that are over 137GB, have a W2K installation and the Fedora installation will be on the same disk as the w2k installation, anaconda should give a warning to people to make sure their w2k has large disk support otherwise w2k will not work unless there are no other partitions on the disk.

Additional info:

The way that I discovered that my w2k didn't have large disk support (eventhough it installed on a premade partition fine but wouldn't make a partition larger than 99 GB in install) was simple. I installed the setup utility specific to my harddrive (Western Digital 250 GB SATA) and it gave me a warning and offered to fix things in the registry. Before the utility+fixes were there, managing the harddrives showed no free space after the partition. After the fixes were made, managing the drives showed free space. Maybe that is a simple enough check for a novice user to do ... see if Windows shows any free space after its partition.
If these checks and fixes are performed beforehand, installation of grub and Fedora in a dual-boot configureation work fine.

This is not a note that can go *only* into the release notes since those are often read after the damage is already done and undoing it made much harder.
Comment 1 Jeremy Katz 2005-09-06 11:20:10 EDT
There's not really much of anything we can do to workaround this, AFAICT.  
Comment 2 Michael Wiktowy 2005-09-09 23:14:27 EDT
Well ... like I said, this isn't really Fedora's fault and there isn't anything
that anaconda can do to fix this situation. However, Fedora will get unfairly
and silently blamed and Fedora will lose potential new users and lose reputation
... after all, Windows worked before and it doesn't after Fedora installation.
Most people will not look further into it other than blowing away the whole disk
and reinstalling Windows and never touching Linux again.

So the least that could be done is to detect this potentially harmful situation
(single ntfs partition + >137GB drive + dual boot installation on the same
drive) and have anaconda pop up a simple warning to direct the user to make sure
that Windows displays free space after the Windows partition and, if not,
install and run the drive manufacturers diagnostic utility from within Windows
before proceding. A mention in the release notes or some sort of
pre-installation checklist would be worthwhile.

It is a corner case now but it is one that will become more prevalent as the
average size drives grow bigger.

You may not care about their Windows partition, but obviously they do. Otherwise
they would have blown it away an not bothered to try to dual-boot.

The only post installation fixes that I can think of are:
1) remove all other partitions other than the Windows one
2) possibly the DOS versions of the Drive utilities will fix this (most of them
are found on UBCD)
3) It is likely just a simple registry key that is added. I have no doubt that
there are offline Windows registry editors out there that can add these keys if
they are known. Unfortunately, I didn't analyze the registry before and after to
see what Western Digital Lifeguard added. So I couldn't tell you.

Note You need to log in before you can comment on or make changes to this bug.