Bug 1674407 - Result button in VM and VM Template Wizards
Summary: Result button in VM and VM Template Wizards
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.3.0
Assignee: Tomas Jelinek
QA Contact: Radim Hrazdil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-11 09:47 UTC by Irina Gulina
Modified: 2020-01-23 11:04 UTC (History)
6 users (show)

Fixed In Version: 4.3.0-0.nightly-2019-11-12-043446
Doc Type: If docs needed, set a value
Doc Text:
Cause: missing confirmation for creating VMs when clicking on the step circles Consequence: unexpected VM creation Fix: fixed by having the result step disabled until the user goes to the review page and clicks "Create Virtual Machine"
Clone Of:
Environment:
Last Closed: 2020-01-23 11:03:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:03:59 UTC

Description Irina Gulina 2019-02-11 09:47:09 UTC
Description of problem:
The wizards prevents you from moving to the next screen until the required fields have been completed. One can move between screens using Back/Next buttons or Basic Settings/Networking/Storage and Result numbered circles at the top. 

After I move to the Storage screen I see "Create VM (template)". So I'm asked if I want to create one. 

If I use navigation on the top, and after Storage I hit Result, the VM (template) will be created. I didn't expect that.. like no one asked for my confirmation. 

Version-Release number of selected component (if applicable):
oc v3.11.69
kubernetes v1.11.0+d4cacc0

How reproducible:
always

Comment 1 Tomas Jelinek 2019-02-11 09:51:01 UTC
@Liz: WDYT? How should it behave? Should the last "circle" be disabled?

Comment 2 Liz 2019-02-11 19:30:09 UTC
Yes, the last circle should be disabled IMO and the user should have to confirm via the wizard button that they want to proceed with creating the VM.

Comment 3 Tomas Jelinek 2019-03-27 00:11:31 UTC
Unfortunately this is not supported now by pf-react and would require quite some work to fix it. Moving to next release since it is not possible to fix it in 2.0.

Comment 4 Filip Krepinsky 2019-07-23 14:37:49 UTC
This is implemented in pf-react 4. Moving again to the next release where pf-react 4 will be utilized.

Comment 5 Tomas Jelinek 2019-11-12 10:09:38 UTC
the PF4 VM / VMTemplate dialog got in, moving this to on_qa

Comment 6 Radim Hrazdil 2019-11-27 15:21:47 UTC
PF4 used with the new in-page wizard improves UX by a lot.
The issues mentioned in this bug description are no longer present. Moving to verified.
4.3.0-0.nightly-2019-11-21-122827

Comment 8 errata-xmlrpc 2020-01-23 11:03:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.