Bug 1674477 - ansible 2.8 generates multiple returning errors and warnings during deployment.
Summary: ansible 2.8 generates multiple returning errors and warnings during deployment.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 4.3.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ovirt-4.3.3
: 4.3.0
Assignee: Simone Tiraboschi
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks: 1667511
TreeView+ depends on / blocked
 
Reported: 2019-02-11 12:59 UTC by Nikolai Sednev
Modified: 2019-05-08 12:32 UTC (History)
4 users (show)

Fixed In Version: ovirt-ansible-hosted-engine-setup-1.0.15-1
Doc Type: Bug Fix
Doc Text:
Previously, testing of Ansible 2.8 returned deprecation errors and warnings during deployment. The current release fixes this issue.
Clone Of:
Environment:
Last Closed: 2019-05-08 12:32:03 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)
sosreport from puma18 (10.53 MB, application/x-xz)
2019-04-02 15:58 UTC, Nikolai Sednev
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github oVirt ovirt-ansible-hosted-engine-setup pull 165 0 None None None 2019-04-02 16:21:25 UTC

Description Nikolai Sednev 2019-02-11 12:59:27 UTC
Description of problem:
ansible 2.8 generates multiple returning errors and warnings during deployment.
[ ERROR ] [DEPRECATION WARNING]: evaluating he_setup_iscsi_getdevices as a bare variable,     
[ ERROR ]  this behaviour will go away and you might need to add |bool to the expression        
[ ERROR ] in the future. Also see CONDITIONAL_BARE_VARS configuration toggle.. This      
[ ERROR ] feature will be removed in version 2.12. Deprecation warnings can be disabled        
[ ERROR ] by setting deprecation_warnings=False in ansible.cfg.
[ ERROR ] [DEPRECATION WARNING]: evaluating he_create_storage_domain as a bare variable,        
[ ERROR ] this behaviour will go away and you might need to add |bool to the expression        
[ ERROR ] in the future. Also see CONDITIONAL_BARE_VARS configuration toggle.. This       
[ ERROR ] feature will be removed in version 2.12. Deprecation warnings can be disabled       
[ ERROR ] by setting deprecation_warnings=False in ansible.cfg.

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-ha-2.3.1-1.el7ev.noarch
ovirt-hosted-engine-setup-2.3.3-1.el7ev.noarch
ansible-2.8.0-1.201902102330git.7b84c0ee80.el7.ans.noarch
ovirt-ansible-repositories-1.1.4-2.el7ev.noarch
ovirt-ansible-engine-setup-1.1.7-1.el7ev.noarch
ovirt-ansible-hosted-engine-setup-1.0.8-1.el7ev.noarch
Red Hat Enterprise Linux Server release 7.6 (Maipo)
Linux 3.10.0-957.5.1.el7.x86_64 #1 SMP Wed Dec 19 10:46:58 EST 2018 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
100%

Steps to Reproduce:
1.Deploy HE over NFS or other storage using ansible-2.8.0-1.201902102330git.7b84c0ee80.el7.ans.noarch

Actual results:
Errors and warnings during deployment as described above.

Expected results:
No warnings or errors should appear.

Additional info:

Comment 4 Sandro Bonazzola 2019-03-06 08:51:27 UTC
Can you please re-test with latest ansible-2.8? Looks like this should not happen anymore

Comment 5 Nikolai Sednev 2019-03-11 16:04:37 UTC
Tested on:
ansible-2.8.0-1.201903101943git.830a11dd38.el7.ans.noarch
ovirt-hosted-engine-setup-2.3.6-1.el7ev.noarch
ovirt-hosted-engine-ha-2.3.1-1.el7ev.noarch
rhvm-appliance-4.3-20190305.1.el7.x86_64
ansible-2.8.0-1.201903101943git.830a11dd38.el7.ans.noarch.rpm
ovirt-ansible-hosted-engine-setup-1.0.12-1.el7ev.noarch
Linux 3.10.0-957.10.1.el7.x86_64 #1 SMP Thu Feb 7 07:12:53 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.6 (Maipo)

[ INFO  ] changed: [localhost]
[ ERROR ] [DEPRECATION WARNING]: evaluating ipv6_deployment as a bare variable, this 
         
[ ERROR ] behaviour will go away and you might need to add |bool to the expression in the
         
[ ERROR ]  future. Also see CONDITIONAL_BARE_VARS configuration toggle.. This feature 
         
[ ERROR ] will be removed in version 2.12. Deprecation warnings can be disabled by 
         
[ ERROR ] setting deprecation_warnings=False in ansible.cfg.
         
[ ERROR ] [DEPRECATION WARNING]: evaluating ipv6_deployment as a bare variable, this 
         
[ ERROR ] behaviour will go away and you might need to add |bool to the expression in the
         
[ ERROR ]  future. Also see CONDITIONAL_BARE_VARS configuration toggle.. This feature 
         
[ ERROR ] will be removed in version 2.12. Deprecation warnings can be disabled by 
         
[ ERROR ] setting deprecation_warnings=False in ansible.cfg.
         
[ ERROR ] [DEPRECATION WARNING]: evaluating ipv6_deployment as a bare variable, this 
         
[ ERROR ] behaviour will go away and you might need to add |bool to the expression in the
         
[ ERROR ]  future. Also see CONDITIONAL_BARE_VARS configuration toggle.. This feature 
         
[ ERROR ] will be removed in version 2.12. Deprecation warnings can be disabled by 
         
[ ERROR ] setting deprecation_warnings=False in ansible.cfg.
         
[ ERROR ] [DEPRECATION WARNING]: evaluating ovirt_engine_setup_use_remote_answer_file as 
         
[ ERROR ] a bare variable, this behaviour will go away and you might need to add |bool to
         
[ ERROR ]  the expression in the future. Also see CONDITIONAL_BARE_VARS configuration 
         
[ ERROR ] toggle.. This feature will be removed in version 2.12. Deprecation warnings can
         
[ ERROR ]  be disabled by setting deprecation_warnings=False in ansible.cfg.
         
[ ERROR ] [DEPRECATION WARNING]: evaluating ovirt_engine_setup_update_all_packages as a 
         
[ ERROR ] bare variable, this behaviour will go away and you might need to add |bool to 
         
[ ERROR ] the expression in the future. Also see CONDITIONAL_BARE_VARS configuration 
         
[ ERROR ] toggle.. This feature will be removed in version 2.12. Deprecation warnings can
         
[ ERROR ]  be disabled by setting deprecation_warnings=False in ansible.cfg.
         
[ ERROR ] [DEPRECATION WARNING]: evaluating he_enable_libgfapi as a bare variable, this 
         
[ ERROR ] behaviour will go away and you might need to add |bool to the expression in the
         
[ ERROR ]  future. Also see CONDITIONAL_BARE_VARS configuration toggle.. This feature 
         
[ ERROR ] will be removed in version 2.12. Deprecation warnings can be disabled by 
         
[ ERROR ] setting deprecation_warnings=False in ansible.cfg.
         
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs)[nfs]:

Comment 7 Sandro Bonazzola 2019-03-18 14:16:36 UTC
Moving back to MODIFIED and pushing this to 4.3.3 since this can't be tested by QE until ansible-2.8 fix is available for https://github.com/ansible/ansible/issues/53459 will be available

Comment 9 Nikolai Sednev 2019-03-27 08:11:24 UTC
QA did not received downstream 4.3.3 yet, we have only rhv-release-latest-nightly-4.3.noarch.rpm 2019-03-14 11:51 at the moment.
Errata moved to ON-QA prematurely.

Comment 10 Nikolai Sednev 2019-04-02 15:57:28 UTC
[ INFO  ] changed: [localhost]
[ ERROR ] [DEPRECATION WARNING]: evaluating he_apply_openscap_profile as a bare variable,
         
[ ERROR ]  this behaviour will go away and you might need to add |bool to the expression 
         
[ ERROR ] in the future. Also see CONDITIONAL_BARE_VARS configuration toggle.. This 
         
[ ERROR ] feature will be removed in version 2.12. Deprecation warnings can be disabled 
         
[ ERROR ] by setting deprecation_warnings=False in ansible.cfg.
         
[ ERROR ] [DEPRECATION WARNING]: evaluating he_apply_openscap_profile as a bare variable,
         
[ ERROR ]  this behaviour will go away and you might need to add |bool to the expression 
         
[ ERROR ] in the future. Also see CONDITIONAL_BARE_VARS configuration toggle.. This 
         
[ ERROR ] feature will be removed in version 2.12. Deprecation warnings can be disabled 
         
[ ERROR ] by setting deprecation_warnings=False in ansible.cfg.
         
[ ERROR ] [DEPRECATION WARNING]: evaluating he_apply_openscap_profile as a bare variable,
         
[ ERROR ]  this behaviour will go away and you might need to add |bool to the expression 
         
[ ERROR ] in the future. Also see CONDITIONAL_BARE_VARS configuration toggle.. This 
         
[ ERROR ] feature will be removed in version 2.12. Deprecation warnings can be disabled 
         
[ ERROR ] by setting deprecation_warnings=False in ansible.cfg.
         
[ ERROR ] [DEPRECATION WARNING]: evaluating he_apply_openscap_profile as a bare variable,
         
[ ERROR ]  this behaviour will go away and you might need to add |bool to the expression 
         
[ ERROR ] in the future. Also see CONDITIONAL_BARE_VARS configuration toggle.. This 
         
[ ERROR ] feature will be removed in version 2.12. Deprecation warnings can be disabled 
         
[ ERROR ] by setting deprecation_warnings=False in ansible.cfg.
         
[ ERROR ] [DEPRECATION WARNING]: evaluating he_apply_openscap_profile as a bare variable,
         
[ ERROR ]  this behaviour will go away and you might need to add |bool to the expression 
         
[ ERROR ] in the future. Also see CONDITIONAL_BARE_VARS configuration toggle.. This 
         
[ ERROR ] feature will be removed in version 2.12. Deprecation warnings can be disabled 
         
[ ERROR ] by setting deprecation_warnings=False in ansible.cfg.
         
[ ERROR ] [DEPRECATION WARNING]: evaluating he_apply_openscap_profile as a bare variable,
         
[ ERROR ]  this behaviour will go away and you might need to add |bool to the expression 
         
[ ERROR ] in the future. Also see CONDITIONAL_BARE_VARS configuration toggle.. This 
         
[ ERROR ] feature will be removed in version 2.12. Deprecation warnings can be disabled 
         
[ ERROR ] by setting deprecation_warnings=False in ansible.cfg.
         
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs)[nfs]: 


Deployment over NFS on clean environment had succeeded using these components on hosts:
Works for me on these components:
ovirt-hosted-engine-setup-2.3.7-1.el7ev.noarch
ovirt-hosted-engine-ha-2.3.1-1.el7ev.noarch
rhvm-appliance-4.3-20190328.1.el7.x86_64
ansible-2.8.0-1.201904012329git.c40f41d519.el7.ans.noarch
ovirt-ansible-hosted-engine-setup-1.0.14-1.el7ev.noarch
ovirt-ansible-engine-setup-1.1.9-1.el7ev.noarch
ovirt-ansible-repositories-1.1.5-1.el7ev.noarch
Linux 3.10.0-957.10.1.el7.x86_64 #1 SMP Thu Feb 7 07:12:53 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.6 (Maipo)

Tested on RHEL hosts.

Moving back to assigned.

Comment 11 Nikolai Sednev 2019-04-02 15:58:34 UTC
Created attachment 1551074 [details]
sosreport from puma18

Comment 12 Nikolai Sednev 2019-04-04 07:26:48 UTC
ansible-2.8.0-1.201904040040git.9776037abe.el7.ans.noarch.rpm contains no ovirt-ansible-hosted-engine-setup-1.0.15-1, currently QA have ovirt-ansible-hosted-engine-setup-1.0.14-1.el7ev.noarch available.

Comment 13 Nikolai Sednev 2019-04-04 09:10:56 UTC
Deployed successfully over NFS using these components:
ansible-2.8.0-1.201904040040git.9776037abe.el7.ans.noarch
ovirt-ansible-engine-setup-1.1.9-1.el7ev.noarch
ovirt-ansible-hosted-engine-setup-1.0.15-1.el7ev.noarch
ovirt-ansible-repositories-1.1.5-1.el7ev.noarch
ovirt-hosted-engine-setup-2.3.7-1.el7ev.noarch
ovirt-hosted-engine-ha-2.3.1-1.el7ev.noarch
engine 4.3.3.1-0.1.el7
Red Hat Enterprise Linux Server release 7.6 (Maipo)
Linux 3.10.0-957.10.1.el7.x86_64 #1 SMP Thu Feb 7 07:12:53 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Moving to verified.

Comment 15 errata-xmlrpc 2019-05-08 12:32:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1050


Note You need to log in before you can comment on or make changes to this bug.