Bug 1674512 - grub2-2.02-68.fc30 shows an error when saved_entry contains text (rather then a number)
Summary: grub2-2.02-68.fc30 shows an error when saved_entry contains text (rather then...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-11 14:05 UTC by Hans de Goede
Modified: 2019-02-18 09:57 UTC (History)
3 users (show)

Fixed In Version: grub2-2.02-69.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-18 09:57:52 UTC
Type: Bug


Attachments (Terms of Use)

Description Hans de Goede 2019-02-11 14:05:41 UTC
Hi,

I'm using a F29 x86_64 UEFI install, but atm my grub is a bit of a mix-and-match between F29 and F30 as I installed all the grub2 bits from the 2.02-68.fc30 build while trying to debug bug 1672850.

So currently I have the following grub related pkgs installed:

grub2-common-2.02-68.fc30.noarch
grub2-efi-ia32-2.02-68.fc30.x86_64
grub2-efi-ia32-cdboot-2.02-68.fc30.x86_64
grub2-efi-ia32-modules-2.02-68.fc30.noarch
grub2-efi-x64-2.02-68.fc30.x86_64
grub2-efi-x64-cdboot-2.02-68.fc30.x86_64
grub2-efi-x64-modules-2.02-68.fc30.noarch
grub2-pc-2.02-68.fc30.x86_64
grub2-pc-modules-2.02-68.fc30.noarch
grub2-tools-2.02-68.fc30.x86_64
grub2-tools-efi-2.02-68.fc30.x86_64
grub2-tools-extra-2.02-68.fc30.x86_64
grub2-tools-minimal-2.02-68.fc30.x86_64
grubby-8.40-18.fc29.x86_64

Note I'm using the F29 grubby with F30 grub2 packages.

This worked fine for a while until a "dnf update" installed a new package, after that instead of a flicker-free boot I got grub switching the EFI framebuffer to text-mode to show me an error like this (more or less):

error: grub-core/kern/misc.c: 476: unrecognized number

After some poking I realized this was probably caused by the kernel install changing saved_entry in the grubenv:

[hans@shalem ~]$ sudo grub2-editenv list
menu_auto_hide=1
boot_success=1
boot_indeterminate=0
saved_entry=d065aaf19da60f6fae055d00473369ee-4.20.6-200.fc29.x86_64
kernelopts=root=UUID=cec677c9-c890-4103-b94a-bcc191642935 ro rd.md=0 rd.dm=0 rd.lvm=0 quiet rhgb

After doing a "sudo grub2-set-default 0" the error at boot went away.

Regards,

Hans

Comment 1 Javier Martinez Canillas 2019-02-18 09:57:52 UTC
Already fixed in grub2-2.02-69.fc30 but I forgot to close the bug.


Note You need to log in before you can comment on or make changes to this bug.