Bug 1674548 - Recommended repositories page on Satellite 6.5 page listing some non-relevant repositories
Summary: Recommended repositories page on Satellite 6.5 page listing some non-relevant...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories
Version: 6.5.0
Hardware: x86_64
OS: Linux
high
medium vote
Target Milestone: Released
Assignee: Brad Buckingham
QA Contact: vijsingh
URL:
Whiteboard:
Depends On: 1692009
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-11 15:39 UTC by Ashish Humbe
Modified: 2019-10-07 17:17 UTC (History)
3 users (show)

Fixed In Version: tfm-rubygem-katello-3.10.0.30-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-14 12:40:09 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:1222 None None None 2019-05-14 12:40:16 UTC
Foreman Issue Tracker 26303 None None None 2019-03-11 16:41:04 UTC

Description Ashish Humbe 2019-02-11 15:39:45 UTC
Description of problem:

"Recommended repositories" page on Satellite 6.5 page listing some non-relevant repositories like: 

Red Hat Enterprise Linux 5 Server - Extended Life Cycle Support (RPMs)
rhel-5-server-els-rpms

Red Hat Enterprise Linux 7 Server - Extended Update Support (RPMs)
rhel-7-server-eus-rpms


>> Ideally, ELS and EUS repos are not very commonly used. 



Red Hat Satellite Tools 6.4 (for RHEL 5 Server - ELS) (RPMs)
rhel-5-server-els-satellite-tools-6.4-rpms

Red Hat Satellite Capsule 6.4 (for RHEL 7 Server) (RPMs)
rhel-7-server-satellite-capsule-6.4-rpms


Red Hat Satellite Tools 6.4 (for RHEL 7 Server) (RPMs)
rhel-7-server-satellite-tools-6.4-rpms

Red Hat Satellite Tools 6.4 (for RHEL 6 Server) (RPMs)
rhel-6-server-satellite-tools-6.4-rpms

These all repositories are related to Satellite 6.4, on Satellite 6.5 the recommended repositories should list Satellite tools 6.5 and Capsule 6.5 repos. 


Version-Release number of selected component (if applicable):
Satellite 6.5 SNAP 15

How reproducible:
Always

Steps to Reproduce:
1. Navigate to Content -> Red Hat Repositories page
2. Click on Recommended Repositories on/off button. 
3.

Actual results:
Some ELS and EUS repos are listed as recommended and also lists Sat6.4 repos instead of Satellite 6.5 tools and Capsule 6.5 repos. 

Expected results:
On Satellite 6.5 the recommended repositories should list Satellite tools 6.5 and Capsule 6.5 repos and there should not be ELS/EUS repos.

Comment 4 Rich Jerrido 2019-02-12 19:30:02 UTC
The intent of the 'recommended repositories' page was to prevent users from using the 'dot-release' version-locked (7.5, 7.6, etc) repositories for RHEL, preferring them to use 7Server. In the case of EUS & ELS, we cannot be _too_ prescriptive here because if a customer has access to them, what criteria do we have to tell them that they are no recommended?


For RHEL Server RPMs, (5Server/6Server/7Server is recommended). All others (5.9, 6.5, 7.1, etc) are not. 
For kickstart repos, there are only version-locked repos as that is the nature of kickstarts. 
EUS/AUS/TUS/E4S are only available in version-locked formats and should be ignored. 


As far as I see, this is not a bug. I can see a use case where we can (such as mentioned in comment #0) not highlight repos for a version of Satellite that is isn't the one installed. (ie dont show or recommend repos for 6.4 if the satellite is 6.5). But that would be an RFE that should be discussed in conjunction with UXD.

Comment 5 Brad Buckingham 2019-03-11 16:41:04 UTC
Created redmine issue https://projects.theforeman.org/issues/26303 from this bug

Comment 6 Brad Buckingham 2019-03-11 19:48:02 UTC
Based upon comment 4, currently updating the recommended Satellite versions from 6.4 to 6.5; however, leaving the EUS/ELS in place.

Comment 13 vijsingh 2019-04-02 13:48:06 UTC
ON_QA Verified

@Satellite 6.5 snap 22

Comment 15 errata-xmlrpc 2019-05-14 12:40:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2019:1222


Note You need to log in before you can comment on or make changes to this bug.