Bug 1674578 - InsightToolkit: FTBFS in Fedora rawhide/f30
Summary: InsightToolkit: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: InsightToolkit
Version: 30
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Ankur Sinha (FranciscoD)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1637255 1688972
Blocks: F30FTBFS 1674576 1674779 1675655
TreeView+ depends on / blocked
 
Reported: 2019-02-11 16:25 UTC by Fedora Release Engineering
Modified: 2019-08-21 01:04 UTC (History)
9 users (show)

Fixed In Version: InsightToolkit-4.13.1-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-21 01:04:21 UTC


Attachments (Terms of Use)
build.log (42 bytes, text/plain)
2019-02-11 16:25 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 16:25 UTC, Fedora Release Engineering
no flags Details
state.log (487 bytes, text/plain)
2019-02-11 16:25 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 16:25:26 UTC
InsightToolkit failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32360191


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix InsightToolkit at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
InsightToolkit will be orphaned. Before branching of Fedora 31,
InsightToolkit will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 16:25:28 UTC
Created attachment 1529122 [details]
build.log

Comment 2 Fedora Release Engineering 2019-02-11 16:25:30 UTC
Created attachment 1529123 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 16:25:31 UTC
Created attachment 1529124 [details]
state.log

Comment 4 Fedora Release Engineering 2019-04-26 23:24:31 UTC
Dear Maintainer,

your package has not been built successfully in f30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 5 Ankur Sinha (FranciscoD) 2019-04-27 10:12:56 UTC
Being worked on. Requires other packages down the chain to be fixed first.

Comment 6 Zbigniew Jędrzejewski-Szmek 2019-07-20 23:04:07 UTC
Built in rawhide and F30.

Comment 7 Zbigniew Jędrzejewski-Szmek 2019-07-21 09:06:58 UTC
Built in rawhide and F30.

Comment 8 Mohan Boddu 2019-08-08 13:26:35 UTC
The following builds were made: InsightToolkit-4.13.1-1.fc30 InsightToolkit-4.13.1-1.fc31

Comment 9 Andre Robatino 2019-08-08 14:20:33 UTC
"and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]."

Is there a reason updating in F30 is not appropriate?

Comment 10 Zbigniew Jędrzejewski-Szmek 2019-08-12 17:47:54 UTC
Yeah, we should make an F30 update because the package is slowly becoming uninstallable
(it conflicts with latest vxl at least).

$ sudo dnf install InsightToolkit.x86_64 vxl-2.0.2-4.fc30.x86_64
Error: 
 Problem: conflicting requests
  - cannot install both vxl-1.17.0-30.fc30.x86_64 and vxl-2.0.2-4.fc30.x86_64
  - package InsightToolkit-4.9.1-9.fc29.x86_64 requires libnetlib.so.1.14()(64bit), but none of the providers can be installed
  - package InsightToolkit-4.9.1-9.fc29.x86_64 requires libv3p_netlib.so.1.14()(64bit), but none of the providers can be installed
  - package InsightToolkit-4.9.1-9.fc29.x86_64 requires libvcl.so.1.14()(64bit), but none of the providers can be installed
  - package InsightToolkit-4.9.1-9.fc29.x86_64 requires libvnl.so.1.14()(64bit), but none of the providers can be installed
  - package InsightToolkit-4.9.1-9.fc29.x86_64 requires libvnl_algo.so.1.14()(64bit), but none of the providers can be installed

Comment 11 Fedora Update System 2019-08-12 17:49:08 UTC
FEDORA-2019-c47d75bf7e has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-c47d75bf7e

Comment 12 Fedora Update System 2019-08-13 01:51:23 UTC
InsightToolkit-4.13.1-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-c47d75bf7e

Comment 13 Fedora Update System 2019-08-21 01:04:21 UTC
InsightToolkit-4.13.1-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.