Bug 167471 - RFE: Update perl-Compress-Zlib to 1.37
RFE: Update perl-Compress-Zlib to 1.37
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-Compress-Zlib (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
http://search.cpan.org/dist/Compress-...
:
Depends On:
Blocks: 167354
  Show dependency treegraph
 
Reported: 2005-09-02 17:47 EDT by Steven Pritchard
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.37-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-06 13:46:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec file update to 1.37 (914 bytes, patch)
2005-09-02 17:47 EDT, Steven Pritchard
no flags Details | Diff

  None (edit)
Description Steven Pritchard 2005-09-02 17:47:38 EDT
I'm attaching a patch that applies perfectly to rawhide and FC-4 that updates
perl-Compress-Zlib to the latest version, 1.37.  (The latest source is at
http://search.cpan.org/CPAN/authors/id/P/PM/PMQS/Compress-Zlib-1.37.tar.gz and
builds perfectly.)

The latest amavisd-new is failing to start, complaining about wanting
Compress::Zlib >= 1.35.  Presumably this is because of some of the fixes in
1.35.  Ideally I'd like to see an update to FC-3 and above so I can build
amavisd-new for all of them once it is accepted into Extras, but an update for
at least FC-4 (where I do most of my testing, and what most of my clients are
running) and rawhide would be greatly appreciated.

The following is the changelog for the last 3 versions of Compress::Zlib:

  1.37 - 12 August 2005

      * Change to t/03examples.t for VMS from Abe Timmerman

  1.36 - 3 August 2005

      * Renamed zlib-src-1.2.3 to zlib-src to help VMS

      * Fixed Makefile.PL for VMS

      * Fixed t/03examples.t for VMS

      * Added a couple of notes about incompatibility with Unix compress.

  1.35 - 16 July 2005

      * Updated zlib source to 1.2.3

      * Fixed problem with where two calls to gzclose would hang the debugger.
        See https://rt.cpan.org/Ticket/Display.html?id=13789

      * Added code from Alexey Tourbin to use XSLoader when available,
        and DynaLoader otherwise.

      * Documented that the compress & uncompress functions were not
        the same as the Unix utilities of the same name.

      * Fixed 05gzsetp -- it left a temp file hanging around. 

      * Integrate core change 24787 - SvUPGRADE returns void in blead

      * Integrate core change 24788 - Makefile.PL adjustments for the core
Comment 1 Steven Pritchard 2005-09-02 17:47:39 EDT
Created attachment 118409 [details]
spec file update to 1.37
Comment 2 Warren Togami 2005-09-03 07:27:48 EDT
FC5 built, FC4 pushed to test updates where your test verification is needed.

Are you sure this is safe to push to FC3 too, it wont break other software that
used the older version?
Comment 3 Steven Pritchard 2005-09-03 11:50:48 EDT
As soon as it hits updates-testing, I'll give it a try on a couple of my servers.

I'm doing a test build for FC-3 now.  I'll let you know how that goes.
Comment 4 Steven Pritchard 2005-09-03 12:14:42 EDT
WORKSFORME on FC-3.
Comment 5 Fedora Update System 2005-09-06 01:35:37 EDT
From User-Agent: XML-RPC

perl-Compress-Zlib-1.37-1.fc3 has been pushed for FC3, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 6 Steven Pritchard 2005-09-06 13:46:33 EDT
The update works great.  Thanks, Warren.

Note You need to log in before you can comment on or make changes to this bug.