Bug 1674763 - containerd: FTBFS in Fedora rawhide/f30
Summary: containerd: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: containerd
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Carl George
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1680040
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 16:59 UTC by Fedora Release Engineering
Modified: 2019-02-28 20:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-28 20:13:40 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 16:59 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 16:59 UTC, Fedora Release Engineering
no flags Details
state.log (633 bytes, text/plain)
2019-02-11 16:59 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 16:59:42 UTC
containerd failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32373467


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix containerd at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
containerd will be orphaned. Before branching of Fedora 31,
containerd will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 16:59:45 UTC
Created attachment 1529579 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 16:59:46 UTC
Created attachment 1529580 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 16:59:47 UTC
Created attachment 1529581 [details]
state.log

Comment 4 Carl George 2019-02-12 02:11:29 UTC
The rebuild failed on ppc64le and aarch64.  I can't reproduce the aarch64 failure, but ppc64le fails consistently in scratch builds.  The result is the same if I update to the latest 1.2.3 upstream source.  I've reported it upstream.

https://github.com/containerd/containerd/issues/3005

If upstream is unresponsive I can disable the tests on ppc64le to get it to pass for now.

Comment 5 Carl George 2019-02-18 19:59:14 UTC
Looks like it's an golang issue.  Rawhide is using golang 1.12 beta2, which introduced the bug.

https://github.com/golang/go/issues/30283


Note You need to log in before you can comment on or make changes to this bug.