Bug 1674789 - dblatex: FTBFS in Fedora rawhide/f30
Summary: dblatex: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dblatex
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael J Gruber
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 17:02 UTC by Fedora Release Engineering
Modified: 2019-02-12 09:31 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-12 09:31:40 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 17:02 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 17:02 UTC, Fedora Release Engineering
no flags Details
state.log (625 bytes, text/plain)
2019-02-11 17:02 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 17:02:38 UTC
dblatex failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32375379


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix dblatex at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
dblatex will be orphaned. Before branching of Fedora 31,
dblatex will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 17:02:40 UTC
Created attachment 1529654 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 17:02:42 UTC
Created attachment 1529655 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 17:02:43 UTC
Created attachment 1529656 [details]
state.log

Comment 4 Neal Becker 2019-02-11 19:20:36 UTC
Someone who has commit rights, I suggest trying:

diff --git a/dblatex.spec b/dblatex.spec
index af69bcf..45bf957 100644
--- a/dblatex.spec
+++ b/dblatex.spec
@@ -1,6 +1,6 @@
 Name:       dblatex
 Version:    0.3.10
-Release:    9%{?dist}
+Release:    10%{?dist}
 Summary:    DocBook to LaTeX/ConTeXt Publishing
 BuildArch:  noarch
 # Most of package is GPLv2+, except:
@@ -83,6 +83,7 @@ Authors:
 %patch1 -p1 -b .disable-debian
 rm -rf lib/contrib
 pathfix.py -pni "%{__python2} %{py2_shbang_opts}" .
+pathfix.py -pni "%{__python2} %{py2_shbang_opts}" scripts/dblatex
 
 %build
 %{__python2} setup.py build
@@ -132,6 +133,9 @@ cp -p %{SOURCE1} COPYING-docbook-xsl
 %postun -p /usr/bin/texhash
 
 %changelog
+* Mon Feb 11 2019 Neal Becker <ndbecker2@gmail.com> - 0.3.10-10
+- Fix scripts/dblatex hashbang
+
 * Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.10-9
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

Comment 5 Neal Becker 2019-02-11 19:56:00 UTC
created PR
https://src.fedoraproject.org/rpms/dblatex/pull-request/3

Comment 6 Michael J Gruber 2019-02-12 09:26:46 UTC
(In reply to Neal Becker from comment #5)
> created PR
> https://src.fedoraproject.org/rpms/dblatex/pull-request/3

No, this still FTBFS with this patch.

The problem is in the way setup.py builds the shebang. Still, thanks for the hint to pathfix. Update is building.


Note You need to log in before you can comment on or make changes to this bug.