Bug 167484 - Errata kernel breaks ibm_acpi module
Errata kernel breaks ibm_acpi module
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2005-09-02 21:31 EDT by Thomas M Steenholdt
Modified: 2015-01-04 17:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-27 20:51:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ibm-acpi-0.11 proposed FC3 build patch (613 bytes, patch)
2005-09-02 21:34 EDT, Thomas M Steenholdt
no flags Details | Diff

  None (edit)
Description Thomas M Steenholdt 2005-09-02 21:31:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
After installing the latest errata kernel for FC3, the ibm_acpi module will no longer load on my system (IBM ThinkPad T30, 2366-JBG).

Upon modprobe ibm_acpi, i see messages like this...

Using generic hotkey driver
Then module insertion just fails saying "no such device" or something to the same end (I can recreate the exact message if it would help in any way).

But the result remains, the module does not get loaded!


Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1376_FC3

How reproducible:
Always

Steps to Reproduce:
1. modprobe ibm_acpi
2. watch kernel messages
3. check lsmod
4. check for /proc/acpi/ibm
  

Actual Results:  The module is not loaded

Expected Results:  The module should load and work (visible under /proc/acpi/ibm)

Additional info:

I downloaded ibm-acpi version 0.11 from http://ibm-acpi.sourceforge.net/ and attempted to build it (failed). So I created a tiny build-fix patch that seems to do the trick. Using the 0.11 driver things now work. It loads perfectly and is as functional as ever :o)
Comment 1 Thomas M Steenholdt 2005-09-02 21:34:20 EDT
Created attachment 118415 [details]
ibm-acpi-0.11 proposed FC3 build patch
Comment 2 Adrian Reber 2005-09-09 17:25:23 EDT
I can confirm this with 2.6.12-1.1447_FC4.
Comment 3 Adrian Reber 2005-09-09 17:51:53 EDT
I just test the newest kernel from updates-testing: 2.6.12-1.1450_FC4
and I still get the same error:

FATAL: Error inserting ibm_acpi
(/lib/modules/2.6.12-1.1450_FC4/kernel/drivers/acpi/ibm_acpi.ko): No such device

and I can see following with dmesg:
ibm_acpi: Using generic hotkey driver

I did just test it and with an older kernel (kernel-2.6.12-1.1398_FC4) it still
works.

The following sounds like it could be the root of the problem:
* Sat Aug 06 2005 Dave Jones <davej@redhat.com> [2.6.12-1.1420_FC4]
- update to final 2.6.12.4 patchset.
- ACPI update to 20050729.
- Disable experimental ACPI HOTKEY driver. (#163355)
Comment 4 Derek Atkins 2005-09-10 12:59:09 EDT
Still running 2.6.12-1.1376_FC3 I see this in my logs, in addition to the failed
ibm_acpi module loading:

Sep 10 12:10:36 cliodev kernel:     ACPI-0105: *** Error: Could not allocate new
owner_id (32 max), AE_OWNER_ID_LIMIT

I suspect this is all related.  I'll also note that 2.6.12-1.1372_FC3 worked fine.
Comment 5 jlbartos 2005-09-10 14:40:28 EDT
I am seeing the same errors on IBM thinkpad R50 (1836-3SU) running
2.6.12-1376_FC3, worked well on previous kernel.
Comment 6 Thomas M Steenholdt 2005-09-12 00:52:41 EDT
Same thing with current latest FC3 updates-testing kernel (2.6.12-1377_FC3).
Some other ACPI issues appear to be resolved in this kernel, but the ibm_acpi
problem remains.
Comment 7 Dave Jones 2005-09-24 01:59:33 EDT
should be fixed in cvs, will be in next update.
Comment 8 Derek Atkins 2005-09-28 08:37:05 EDT
Not to be a pest, but I'm going on the road this weekend and it would be really
nice if I could have ACPI working by then.   Any idea when you're going to be
building a "next update" for FC3?  I'm willing to pull it down from your
personal redhat website and test it.    Thanks!
Comment 9 Rubin Simons 2005-09-28 18:37:25 EDT
I seem to have this problem on a Thinkpad T43 with FC4, kernel 2.6.12-1.1456_FC4.

[root@thinkpad ~]# modprobe ibm_acpi
FATAL: Error inserting ibm_acpi
(/lib/modules/2.6.12-1.1456_FC4/kernel/drivers/acpi/ibm_acpi.ko): No such device

Any idea when the fix will come? 

Thanks,
Comment 10 Dave Jones 2005-09-28 18:49:01 EDT
1379 will be at http://people.redhat.com/davej/kernels/Fedora/FC3/ in a few hours.

I want to get a few more things fixed in this release before I push it to
updates-final, so consider that an 'early preview'.

FC4 has it fixed in the kernel currently in updates-testing
Comment 11 Derek Atkins 2005-10-02 12:13:50 EDT
I've downloaded 2.6.12-1.1379_FC3..  While the ibm_acpi module does load, the
system doesn't properly sleep anymore.  There is no /proc/acpi/sleep like there
was in previous versions, so I cannot suspend-to-ram anymore.  (Granted, I
haven't been able to do that since this ACPI problem started in 1376).

# cat /proc/cmdline
ro root=LABEL=/ acpi_sleep=s3_bios rhgb quiet
# ls /proc/acpi/
ac_adapter  dsdt                 fadt  info            thermal_zone
alarm       embedded_controller  fan   power_resource  video
battery     event                ibm   processor       wakeup

So, this problem is only mostly fixed in my mind.
Comment 12 Thomas M Steenholdt 2005-10-02 15:45:10 EDT
'echo -n "mem" > /sys/power/state' instead

I don't know if removing the "sleep" node from /proc/acpi was intentional, but i
think it might be.

On first test, the .1379 kernel seems to work okay for me in regard to this!
(the driver is still backlevel, but hey, thats the driver that's in the vanilla
kernel, so i'm not gonna bitch too much about it) :o)
Comment 13 Derek Atkins 2005-10-02 16:49:56 EDT
Sweet.  Thanks.  That works!   :)   I'll go change my script to use that.
Comment 14 Dave Jones 2005-10-02 19:26:24 EDT
fwiw, the removal of /proc/acpi/sleep was unintended, and will return in the
next fc3 update.
Comment 15 Derek Atkins 2005-10-07 13:25:16 EDT
Hmm..  I'm still seeing APCI issues on my thinkpad running the 1379 FC3 kernel.
 This morning my machine lost ACPI events for about 5 hours.  Here's the logs
from /var/log/messages:

Oct  7 08:25:01 cliodev ACPI: Entering standby......
Oct  7 08:27:19 cliodev ACPI: Entering standby......
Oct  7 08:27:41 cliodev logger: Switching to Battery-powered state
Oct  7 08:27:42 cliodev kernel: hdc: drive_cmd: status=0x51 { DriveReady
SeekComplete Error }
Oct  7 08:27:42 cliodev kernel: hdc: drive_cmd: error=0x04 { AbortedCommand }
Oct  7 08:27:42 cliodev kernel: ide: failed opcode was: 0xef
Oct  7 08:45:57 cliodev kernel: hdc: drive_cmd: status=0x51 { DriveReady
SeekComplete Error }
Oct  7 08:45:57 cliodev kernel: hdc: drive_cmd: error=0x04 { AbortedCommand }
Oct  7 08:45:57 cliodev kernel: ide: failed opcode was: 0xef
[ removed some DHCP and pam messages ]
Oct  7 13:11:35 cliodev ACPI: Entering standby......
Oct  7 13:11:35 cliodev ACPI: Entering standby......
Oct  7 13:11:35 cliodev logger: Switching to AC-powered state
Oct  7 13:11:36 cliodev logger: Switching to AC-powered state
Oct  7 13:11:37 cliodev ACPI: Entering standby......
Oct  7 13:11:37 cliodev ACPI: Entering standby......
Oct  7 13:11:38 cliodev logger: Switching to AC-powered state
Oct  7 13:11:38 cliodev ACPI: Entering standby......
Oct  7 13:11:38 cliodev last message repeated 2 times
Oct  7 13:11:39 cliodev logger: Switching to AC-powered state

In particular the power events..  Going into battery mode and then coming back
to AC power doesn't seem to be recognized properly.  I just tried it again now
(pulling the power and then putting it back in) and there was still a delay:

Oct  7 13:23:39 cliodev logger: Switching to Battery-powered state
Oct  7 13:23:39 cliodev kernel: hdc: drive_cmd: status=0x51 { DriveReady
SeekComplete Error }
Oct  7 13:23:39 cliodev kernel: hdc: drive_cmd: error=0x04 { AbortedCommand }
Oct  7 13:23:39 cliodev kernel: ide: failed opcode was: 0xef
Oct  7 13:24:26 cliodev logger: Switching to AC-powered state
Oct  7 13:24:27 cliodev kernel: hdc: drive_cmd: status=0x51 { DriveReady
SeekComplete Error }
Oct  7 13:24:27 cliodev kernel: hdc: drive_cmd: error=0x04 { AbortedCommand }
Oct  7 13:24:27 cliodev kernel: ide: failed opcode was: 0xef

Why is it taking 50 seconds to notice the power-on event?  I doubt it's my ACPI
scripts, as those have always worked....   Unless some of the ACPI updates broke
my scripts.

Note You need to log in before you can comment on or make changes to this bug.