Bug 1674849 - overly aggressive -Werror=format-overflow elfutils: FTBFS in Fedora rawhide/f30
Summary: overly aggressive -Werror=format-overflow elfutils: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1675077 (view as bug list)
Depends On:
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 17:08 UTC by Fedora Release Engineering
Modified: 2019-03-06 14:54 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-06 14:54:16 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 17:08 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 17:08 UTC, Fedora Release Engineering
no flags Details
state.log (625 bytes, text/plain)
2019-02-11 17:08 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 17:08:13 UTC
elfutils failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32380121


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix elfutils at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
elfutils will be orphaned. Before branching of Fedora 31,
elfutils will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 17:08:16 UTC
Created attachment 1529825 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 17:08:17 UTC
Created attachment 1529826 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 17:08:18 UTC
Created attachment 1529827 [details]
state.log

Comment 4 Mark Wielaard 2019-02-11 18:46:34 UTC
This is upstream GCC bug https://gcc.gnu.org/bugzilla/show_bug.cgi?id=88835

Comment 5 Mark Wielaard 2019-02-11 19:25:58 UTC
*** Bug 1675077 has been marked as a duplicate of this bug. ***

Comment 6 Zbigniew Jędrzejewski-Szmek 2019-03-03 15:08:41 UTC
A build was successfull: gcc-9.0.1-0.8.fc30 [1].
Closing the bug.

[1] https://koji.fedoraproject.org/koji/buildinfo?buildID=1216868

Comment 7 Mark Wielaard 2019-03-06 14:54:16 UTC
I just did a build of elfutils on f30 with the workaround for this bug removed and it passed.


Note You need to log in before you can comment on or make changes to this bug.