Bug 1674872 - fawkes: FTBFS in Fedora rawhide/f30
Summary: fawkes: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fawkes
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Till Hofmann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1674923 1675611 1680265
Blocks: F30FTBFS 1687591
TreeView+ depends on / blocked
 
Reported: 2019-02-11 17:10 UTC by Fedora Release Engineering
Modified: 2019-05-18 01:01 UTC (History)
4 users (show)

Fixed In Version: fawkes-1.2.0-3.fc31 fawkes-1.2.0-3.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-18 01:01:48 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 17:10 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 17:10 UTC, Fedora Release Engineering
no flags Details
state.log (471 bytes, text/plain)
2019-02-11 17:10 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 17:10:28 UTC
fawkes failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32382545


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix fawkes at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
fawkes will be orphaned. Before branching of Fedora 31,
fawkes will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 17:10:30 UTC
Created attachment 1529894 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 17:10:31 UTC
Created attachment 1529895 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 17:10:33 UTC
Created attachment 1529896 [details]
state.log

Comment 4 Jonathan Wakely 2019-02-11 21:45:44 UTC
This package's dependencies need to be rebuilt:

DEBUG util.py:490:  BUILDSTDERR: Error: 
DEBUG util.py:490:  BUILDSTDERR:  Problem 1: package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_common.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_io.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_features.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_filters.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_octree.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_search.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_segmentation.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_kdtree.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_sample_consensus.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_surface.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_ml.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_registration.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_visualization.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_io_ply.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_keypoints.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_outofcore.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_people.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_recognition.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_stereo.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_tracking.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires libpcl_apps.so.1.8()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package pcl-devel-1.8.1-4.fc30.x86_64 requires pcl = 1.8.1-4.fc30, but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - conflicting requests
DEBUG util.py:490:  BUILDSTDERR:   - nothing provides libboost_system.so.1.66.0()(64bit) needed by pcl-1.8.1-4.fc30.x86_64
DEBUG util.py:490:  BUILDSTDERR:   - nothing provides libboost_filesystem.so.1.66.0()(64bit) needed by pcl-1.8.1-4.fc30.x86_64
DEBUG util.py:490:  BUILDSTDERR:   - nothing provides libboost_thread.so.1.66.0()(64bit) needed by pcl-1.8.1-4.fc30.x86_64
DEBUG util.py:490:  BUILDSTDERR:   - nothing provides libboost_iostreams.so.1.66.0()(64bit) needed by pcl-1.8.1-4.fc30.x86_64
DEBUG util.py:490:  BUILDSTDERR:  Problem 2: package gazebo-ode-devel-9.5.0-2.fc30.x86_64 requires libgazebo_ode.so.9()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - package gazebo-ode-devel-9.5.0-2.fc30.x86_64 requires gazebo-ode(x86-64) = 9.5.0-2.fc30, but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - conflicting requests
DEBUG util.py:490:  BUILDSTDERR:   - nothing provides libboost_system.so.1.66.0()(64bit) needed by gazebo-ode-9.5.0-2.fc30.x86_64
DEBUG util.py:490:  BUILDSTDERR:   - nothing provides libboost_thread.so.1.66.0()(64bit) needed by gazebo-ode-9.5.0-2.fc30.x86_64
DEBUG util.py:490:  BUILDSTDERR:  Problem 3: package gazebo-devel-9.5.0-2.fc30.x86_64 requires libgazebo_ode.so.9()(64bit), but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - conflicting requests
DEBUG util.py:490:  BUILDSTDERR:   - nothing provides libboost_system.so.1.66.0()(64bit) needed by gazebo-ode-9.5.0-2.fc30.x86_64
DEBUG util.py:490:  BUILDSTDERR:   - nothing provides libboost_thread.so.1.66.0()(64bit) needed by gazebo-ode-9.5.0-2.fc30.x86_64
DEBUG util.py:490:  BUILDSTDERR:  Problem 4: package gazebo-media-9.5.0-2.fc30.noarch requires gazebo = 9.5.0-2.fc30, but none of the providers can be installed
DEBUG util.py:490:  BUILDSTDERR:   - conflicting requests
DEBUG util.py:490:  BUILDSTDERR:   - nothing provides libboost_system.so.1.66.0()(64bit) needed by gazebo-9.5.0-2.fc30.x86_64
DEBUG util.py:490:  BUILDSTDERR:   - nothing provides libboost_filesystem.so.1.66.0()(64bit) needed by gazebo-9.5.0-2.fc30.x86_64
DEBUG util.py:490:  BUILDSTDERR:   - nothing provides libboost_thread.so.1.66.0()(64bit) needed by gazebo-9.5.0-2.fc30.x86_64
DEBUG util.py:490:  BUILDSTDERR:   - nothing provides libboost_regex.so.1.66.0()(64bit) needed by gazebo-9.5.0-2.fc30.x86_64
DEBUG util.py:490:  BUILDSTDERR:   - nothing provides libboost_program_options.so.1.66.0()(64bit) needed by gazebo-9.5.0-2.fc30.x86_64
DEBUG util.py:490:  BUILDSTDERR:   - nothing provides libboost_iostreams.so.1.66.0()(64bit) needed by gazebo-9.5.0-2.fc30.x86_64

Comment 5 Rich Mattes 2019-02-18 02:53:29 UTC
Sorry for the delay, I finally got pcl and gazebo built in rawhide.  I'll kick off a fawkes build asap.

Comment 6 Till Hofmann 2019-02-18 09:24:16 UTC
I updated to a pre-release snapshot of 1.1.0 (due soon) to fix the FTBFS, but there is still an issue with festival.

Comment 7 Till Hofmann 2019-02-23 12:50:00 UTC
I disabled the festival plugin to remove the dependency on festival. Looking at the festival bug, it doesn't look like festival's FTBFS bug will be fixed anytime soon.

Comment 8 Till Hofmann 2019-05-09 13:18:26 UTC
I updated to 1.2.0 and added a bunch of fixes upstream (PR #111) and in the SPEC, which fixes the FTBFS.

Fixed in F31, F30 update coming.

Comment 9 Fedora Update System 2019-05-09 13:20:31 UTC
fawkes-1.2.0-3.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-04bf0ec94d

Comment 10 Fedora Update System 2019-05-10 02:06:10 UTC
fawkes-1.2.0-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-04bf0ec94d

Comment 11 Fedora Update System 2019-05-18 01:01:48 UTC
fawkes-1.2.0-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.