Bug 16749 - Secondary serial console doesn't allow you to pass kernel options
Secondary serial console doesn't allow you to pass kernel options
Status: CLOSED DUPLICATE of bug 24286
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-22 16:44 EDT by Pekka Savola
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-04 01:17:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2000-08-22 16:44:22 EDT
This is very much related to #13564.  The setup is described there in detail.

As of beta5 or so, the kernel messages will be shown properly when you use (secondary -- didn't test with primary) 
serial console.

However, LILO prompt appears broken if and only if you use the new VGA screen.  That is, you get:

---
LILO
Loading linux...........
---
Note!  You can't enter any input (e.g. linux single) there!

If you disable the VGA screen, secondary console fine, and the boot looks something like:

---
Lilo boot: 
Loading linux...........
---
Comment 1 Brock Organ 2000-08-23 09:58:42 EDT
hmmm ... I am unable to reproduce this problem (the inability to enter text mode
at the lilo splash screen, and subsequently type in boot parameters):

using rc2, I am able to install with an append="console=ttyS0,19200n8" line in
my lilo.conf for the default linux boot label ... and upon reboot, I'm able to
use ^X to enter text mode at the VGA splash screen, and am able to add boot
parameters ...

Comment 2 Pekka Savola 2000-08-23 10:22:57 EDT
Please try using:

append="console=ttyS0,19200n8 console=tty0"

I think the problem occurs only when serial console is secondary.  I use this to setup "backup" serial consoles (for systems that still do have VGA).
Comment 3 Brock Organ 2000-08-23 11:40:57 EDT
this behavior is verified with the above append line, you can not enter lilo
parameters over the serial line ...
Comment 4 Matt Wilson 2000-08-23 11:45:14 EDT
uh, why did you assign this to me?
Comment 5 Jeremy Katz 2002-06-04 01:17:09 EDT
Does this still happen with current releases?
Comment 6 Pekka Savola 2002-06-05 07:48:53 EDT
Tested on RHL73:

1) whether primary or secondary console, if using message= in lilo.conf, you
cannot pass any parameters (a "duplicate" of #24286)

2) you can pass parameters with secondary console is no message= is defined.

Marking as duplicate even though this was a much earlier report.

*** This bug has been marked as a duplicate of 24286 ***

Note You need to log in before you can comment on or make changes to this bug.