Bug 1675007 - golang-github-agl-ed25519: FTBFS in Fedora rawhide/f30 [NEEDINFO]
Summary: golang-github-agl-ed25519: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-github-agl-ed25519
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fridolín Pokorný
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1680040
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 18:33 UTC by Fedora Release Engineering
Modified: 2019-07-24 20:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-24 20:36:59 UTC
releng: needinfo? (fpokorny)


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 18:33 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 18:33 UTC, Fedora Release Engineering
no flags Details
state.log (765 bytes, text/plain)
2019-02-11 18:33 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 18:33:29 UTC
golang-github-agl-ed25519 failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32394439


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix golang-github-agl-ed25519 at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
golang-github-agl-ed25519 will be orphaned. Before branching of Fedora 31,
golang-github-agl-ed25519 will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 18:33:31 UTC
Created attachment 1530236 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 18:33:33 UTC
Created attachment 1530237 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 18:33:34 UTC
Created attachment 1530238 [details]
state.log

Comment 4 Jakub Čajka 2019-02-12 09:01:34 UTC
For the record this is caused by crash in tests on ppc64le:
+ go test -buildmode pie -compiler gc -ldflags '-extldflags '\''-Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld '\'''
unexpected fault address 0x3b3c0
fatal error: fault
[signal SIGSEGV: segmentation violation code=0x1 addr=0x3b3c0 pc=0x10e81dc94]
goroutine 21 [running]:
runtime.throw(0x10e8d6b6f, 0x5)
	/usr/lib/golang/src/runtime/panic.go:617 +0x68 fp=0xc00004bad8 sp=0xc00004ba98 pc=0x10e7ecc78
runtime.sigpanic()
	/usr/lib/golang/src/runtime/signal_unix.go:397 +0x464 fp=0xc00004bb18 sp=0xc00004bad8 pc=0x10e8039c4
runtime.memmove(0xc00004be28, 0x3b3c0, 0x28)
	/usr/lib/golang/src/runtime/memmove_ppc64x.s:57 +0x64 fp=0xc00004bb38 sp=0xc00004bb38 pc=0x10e81dc94
github.com/agl/ed25519/edwards25519.FeZero(...)
	/builddir/build/BUILD/ed25519-5312a61534124124185d41f09206b9fef1d88403/_build/src/github.com/agl/ed25519/edwards25519/edwards25519.go:22
github.com/agl/ed25519/edwards25519.(*ExtendedGroupElement).Zero(...)
	/builddir/build/BUILD/ed25519-5312a61534124124185d41f09206b9fef1d88403/_build/src/github.com/agl/ed25519/edwards25519/edwards25519.go:684
github.com/agl/ed25519/edwards25519.GeScalarMultBase(0xc00004be28, 0xc00004bdc8)
	/builddir/build/BUILD/ed25519-5312a61534124124185d41f09206b9fef1d88403/_build/src/github.com/agl/ed25519/edwards25519/edwards25519.go:989 +0x140 fp=0xc00004bd50 sp=0xc00004bb38 pc=0x10e8c25f0
github.com/agl/ed25519.Sign(0xc0000c4080, 0xc00008c0c0, 0xc, 0xc, 0x0)
	/builddir/build/BUILD/ed25519-5312a61534124124185d41f09206b9fef1d88403/_build/src/github.com/agl/ed25519/ed25519.go:74 +0x230 fp=0xc00004bef8 sp=0xc00004bd50 pc=0x10e8d3dc0
github.com/agl/ed25519.TestSignVerify(0xc0000c0200)
	/builddir/build/BUILD/ed25519-5312a61534124124185d41f09206b9fef1d88403/_build/src/github.com/agl/ed25519/ed25519_test.go:51 +0xb0 fp=0xc00004bf70 sp=0xc00004bef8 pc=0x10e8d4590
testing.tRunner(0xc0000c0200, 0x10e998b00)
	/usr/lib/golang/src/testing/testing.go:862 +0xdc fp=0xc00004bfb0 sp=0xc00004bf70 pc=0x10e87b66c
runtime.goexit()
	/usr/lib/golang/src/runtime/asm_ppc64x.s:856 +0x4 fp=0xc00004bfb0 sp=0xc00004bfb0 pc=0x10e81d944
created by testing.(*T).Run
	/usr/lib/golang/src/testing/testing.go:913 +0x304
goroutine 1 [chan receive]:
testing.(*T).Run(0xc0000c0200, 0x10e8d848c, 0xe, 0x10e998b00, 0x10ea67f01)
	/usr/lib/golang/src/testing/testing.go:914 +0x320
testing.runTests.func1(0xc0000c0000)
	/usr/lib/golang/src/testing/testing.go:1154 +0x8c
testing.tRunner(0xc0000c0000, 0xc0000addd8)
	/usr/lib/golang/src/testing/testing.go:862 +0xdc
testing.runTests(0xc00009c080, 0x10ea64ac0, 0x3, 0x3, 0x0)
	/usr/lib/golang/src/testing/testing.go:1152 +0x2a0
testing.(*M).Run(0xc0000be000, 0x0)
	/usr/lib/golang/src/testing/testing.go:1069 +0x174
main.main()
	_testmain.go:52 +0x150
exit status 2
FAIL	github.com/agl/ed25519	0.013s

Comment 5 Jakub Čajka 2019-02-28 11:54:01 UTC
This seems to be resolved with changes from BZ#1680040
https://koji.fedoraproject.org/koji/taskinfo?taskID=33102326

Comment 6 Fedora Release Engineering 2019-04-26 23:27:29 UTC
Dear Maintainer,

your package has not been built successfully in f30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 7 Fedora Release Engineering 2019-06-03 21:42:49 UTC
Dear Maintainer,

your package has not been built successfully in f30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 8 Fedora Release Engineering 2019-06-17 20:45:38 UTC
Dear Maintainer,

your package has not been built successfully in f30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 9 Fedora Release Engineering 2019-07-02 11:14:19 UTC
Dear Maintainer,

your package has not been built successfully in 30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 31 according to the schedule [3],
any packages which still have open FTBFS bugs from Fedora 30 will be retired.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/31/Schedule

Comment 10 Fedora Release Engineering 2019-07-02 13:30:47 UTC
Dear Maintainer,

your package has not been built successfully in 30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 31 according to the schedule [3],
any packages which still have open FTBFS bugs from Fedora 30 will be retired.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/31/Schedule

Comment 11 Fedora Release Engineering 2019-07-24 13:28:14 UTC
Dear Maintainer,

your package has not been built successfully in 30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 31 according to the schedule [3],
any packages which still have open FTBFS bugs from Fedora 30 will be retired.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/31/Schedule


Note You need to log in before you can comment on or make changes to this bug.