Bug 1675010 - golang-github-chaseadamsio-goorgeous: FTBFS in Fedora rawhide/f30
Summary: golang-github-chaseadamsio-goorgeous: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-github-chaseadamsio-goorgeous
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Athos Ribeiro
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 18:33 UTC by Fedora Release Engineering
Modified: 2019-02-26 09:27 UTC (History)
5 users (show)

Fixed In Version: golang-github-chaseadamsio-goorgeous-2.0.0-6.fc31 golang-github-chaseadamsio-goorgeous-2.0.0-6.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-26 09:27:03 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 18:33 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 18:33 UTC, Fedora Release Engineering
no flags Details
state.log (737 bytes, text/plain)
2019-02-11 18:33 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 18:33:48 UTC
golang-github-chaseadamsio-goorgeous failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32394803


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix golang-github-chaseadamsio-goorgeous at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
golang-github-chaseadamsio-goorgeous will be orphaned. Before branching of Fedora 31,
golang-github-chaseadamsio-goorgeous will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 18:33:50 UTC
Created attachment 1530245 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 18:33:51 UTC
Created attachment 1530246 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 18:33:53 UTC
Created attachment 1530247 [details]
state.log

Comment 4 Jakub Čajka 2019-02-12 09:58:54 UTC
Caused by undefined symbols in the tests(broken deps/api):
+ go test -buildmode pie -compiler gc -ldflags ' -extldflags '\''-Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld '\''' github.com/chaseadamsio/goorgeous
BUILDSTDERR: # github.com/chaseadamsio/goorgeous [github.com/chaseadamsio/goorgeous.test]
BUILDSTDERR: ../../BUILDROOT/golang-github-chaseadamsio-goorgeous-2.0.0-5.fc30.ppc64le/usr/share/gocode/src/github.com/chaseadamsio/goorgeous/goorgeous.go:44:14: undefined: blackfriday.HtmlRenderer
BUILDSTDERR: ../../BUILDROOT/golang-github-chaseadamsio-goorgeous-2.0.0-5.fc30.ppc64le/usr/share/gocode/src/github.com/chaseadamsio/goorgeous/goorgeous.go:44:39: undefined: blackfriday.HTML_USE_XHTML
BUILDSTDERR: ../../BUILDROOT/golang-github-chaseadamsio-goorgeous-2.0.0-5.fc30.ppc64le/usr/share/gocode/src/github.com/chaseadamsio/goorgeous/goorgeous.go:165:10: p.r.BlockQuote undefined (type blackfriday.Renderer has no field or method BlockQuote)
BUILDSTDERR: ../../BUILDROOT/golang-github-chaseadamsio-goorgeous-2.0.0-5.fc30.ppc64le/usr/share/gocode/src/github.com/chaseadamsio/goorgeous/goorgeous.go:174:10: p.r.BlockCode undefined (type blackfriday.Renderer has no field or method BlockCode)
BUILDSTDERR: ../../BUILDROOT/golang-github-chaseadamsio-goorgeous-2.0.0-5.fc30.ppc64le/usr/share/gocode/src/github.com/chaseadamsio/goorgeous/goorgeous.go:236:13: undefined: blackfriday.LIST_TYPE_DEFINITION
BUILDSTDERR: ../../BUILDROOT/golang-github-chaseadamsio-goorgeous-2.0.0-5.fc30.ppc64le/usr/share/gocode/src/github.com/chaseadamsio/goorgeous/goorgeous.go:238:13: undefined: blackfriday.LIST_TYPE_TERM
BUILDSTDERR: ../../BUILDROOT/golang-github-chaseadamsio-goorgeous-2.0.0-5.fc30.ppc64le/usr/share/gocode/src/github.com/chaseadamsio/goorgeous/goorgeous.go:240:7: p.r.ListItem undefined (type blackfriday.Renderer has no field or method ListItem)
BUILDSTDERR: ../../BUILDROOT/golang-github-chaseadamsio-goorgeous-2.0.0-5.fc30.ppc64le/usr/share/gocode/src/github.com/chaseadamsio/goorgeous/goorgeous.go:242:14: undefined: blackfriday.LIST_TYPE_TERM
BUILDSTDERR: ../../BUILDROOT/golang-github-chaseadamsio-goorgeous-2.0.0-5.fc30.ppc64le/usr/share/gocode/src/github.com/chaseadamsio/goorgeous/goorgeous.go:244:7: p.r.ListItem undefined (type blackfriday.Renderer has no field or method ListItem)
BUILDSTDERR: ../../BUILDROOT/golang-github-chaseadamsio-goorgeous-2.0.0-5.fc30.ppc64le/usr/share/gocode/src/github.com/chaseadamsio/goorgeous/goorgeous.go:253:7: p.r.ListItem undefined (type blackfriday.Renderer has no field or method ListItem)
BUILDSTDERR: ../../BUILDROOT/golang-github-chaseadamsio-goorgeous-2.0.0-5.fc30.ppc64le/usr/share/gocode/src/github.com/chaseadamsio/goorgeous/goorgeous.go:253:7: too many errors
FAIL	github.com/chaseadamsio/goorgeous [build failed]


Note You need to log in before you can comment on or make changes to this bug.