Bug 1675013 - golang-github-cosmos72-gomacro: FTBFS in Fedora rawhide/f30
Summary: golang-github-cosmos72-gomacro: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-github-cosmos72-gomacro
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Elliott Sales de Andrade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 18:34 UTC by Fedora Release Engineering
Modified: 2019-07-22 21:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-22 21:36:42 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 18:34 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 18:34 UTC, Fedora Release Engineering
no flags Details
state.log (705 bytes, text/plain)
2019-02-11 18:34 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 18:34:06 UTC
golang-github-cosmos72-gomacro failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32394949


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix golang-github-cosmos72-gomacro at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
golang-github-cosmos72-gomacro will be orphaned. Before branching of Fedora 31,
golang-github-cosmos72-gomacro will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 18:34:08 UTC
Created attachment 1530254 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 18:34:10 UTC
Created attachment 1530255 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 18:34:11 UTC
Created attachment 1530256 [details]
state.log

Comment 4 Jakub Čajka 2019-02-12 13:34:28 UTC
This is caused by something that appears to be broken interface/api in the tests suite:
+ go test -buildmode pie -compiler gc -ldflags '-extldflags '\''-Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld '\'''
// debug: importer: cannot find package "github.com/cosmos72/gomacro/xreflect" metadata, approximating it with reflection
// debug: struct xreflect.Request4Test
// debug: . map map[string]string
// debug: . ptr *xreflect.Response4Test
// debug: . . struct xreflect.Response4Test
// debug: . . . ptr *xreflect.Request4Test
--- FAIL: TestInterfaceIoReadWriter (0.00s)
    type_test.go:33: expecting interface{io.Reader; io.Writer} <*types.Interface>, found interface{Read([]uint8) (int, error)} <*types.Interface>
    type_test.go:33: expecting interface{io.Reader; io.Writer} <*types.Interface>, found interface{Write([]uint8) (int, error)} <*types.Interface>
FAIL
exit status 1
FAIL	github.com/cosmos72/gomacro/xreflect	0.139s

Comment 5 Elliott Sales de Andrade 2019-02-16 01:05:56 UTC
From some issues upstream, this may or may not be fixed by 1.12rc1.

Comment 6 Jakub Čajka 2019-02-18 08:03:10 UTC
(In reply to Elliott Sales de Andrade from comment #5)
> From some issues upstream, this may or may not be fixed by 1.12rc1.

Do you have reference handy?

Comment 7 Elliott Sales de Andrade 2019-02-18 08:17:25 UTC
Well, it's not exactly clear what bugs upstream has fixed yet, but from the changes that were made it appears to things other than this one. So see https://github.com/cosmos72/gomacro/issues/48#issuecomment-464150332

Comment 8 Jakub Čajka 2019-02-18 08:28:26 UTC
(In reply to Elliott Sales de Andrade from comment #7)
> Well, it's not exactly clear what bugs upstream has fixed yet, but from the
> changes that were made it appears to things other than this one. So see
> https://github.com/cosmos72/gomacro/issues/48#issuecomment-464150332

Thanks, it looks like they are doing something more "wild", that might have relied on unspecified behavior. It might have changed(read got broken) between all the Go versions.

Comment 9 Fedora Release Engineering 2019-04-26 23:27:31 UTC
Dear Maintainer,

your package has not been built successfully in f30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 10 Fedora Release Engineering 2019-06-03 21:42:50 UTC
Dear Maintainer,

your package has not been built successfully in f30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 11 Fedora Release Engineering 2019-06-17 20:45:37 UTC
Dear Maintainer,

your package has not been built successfully in f30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 12 Fedora Release Engineering 2019-07-02 11:14:21 UTC
Dear Maintainer,

your package has not been built successfully in 30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 31 according to the schedule [3],
any packages which still have open FTBFS bugs from Fedora 30 will be retired.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/31/Schedule

Comment 13 Fedora Release Engineering 2019-07-02 13:30:49 UTC
Dear Maintainer,

your package has not been built successfully in 30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 31 according to the schedule [3],
any packages which still have open FTBFS bugs from Fedora 30 will be retired.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/31/Schedule


Note You need to log in before you can comment on or make changes to this bug.