Bug 1675027 - golang-github-hashicorp-raft-boltdb: FTBFS in Fedora rawhide/f30
Summary: golang-github-hashicorp-raft-boltdb: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-github-hashicorp-raft-boltdb
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fridolín Pokorný
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1680040
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 18:35 UTC by Fedora Release Engineering
Modified: 2019-07-24 21:17 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-24 21:17:20 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 18:35 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 18:35 UTC, Fedora Release Engineering
no flags Details
state.log (805 bytes, text/plain)
2019-02-11 18:35 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 18:35:27 UTC
golang-github-hashicorp-raft-boltdb failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32395813


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix golang-github-hashicorp-raft-boltdb at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
golang-github-hashicorp-raft-boltdb will be orphaned. Before branching of Fedora 31,
golang-github-hashicorp-raft-boltdb will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 18:35:29 UTC
Created attachment 1530296 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 18:35:30 UTC
Created attachment 1530297 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 18:35:32 UTC
Created attachment 1530298 [details]
state.log

Comment 4 Jakub Čajka 2019-02-13 12:43:12 UTC
Caused by crash in tests suite on ppc64le:
+ go test -buildmode pie -compiler gc -ldflags '-extldflags '\''-Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld '\'''
unexpected fault address 0x115912550
fatal error: fault
[signal SIGSEGV: segmentation violation code=0x2 addr=0x115912550 pc=0x1155813ec]
goroutine 8 [running]:
runtime.throw(0x1158de6bf, 0x5)
	/usr/lib/golang/src/runtime/panic.go:617 +0x68 fp=0xc00004e908 sp=0xc00004e8c8 pc=0x115581998
runtime.sigpanic()
	/usr/lib/golang/src/runtime/signal_unix.go:397 +0x464 fp=0xc00004e948 sp=0xc00004e908 pc=0x11559a5d4
panic(0x1155ade94, 0x115623884)
	/usr/lib/golang/src/runtime/panic.go:490 +0xcc fp=0xc00004ea08 sp=0xc00004e968 pc=0x1155813ec
runtime.panicmakeslicelen(...)
	/usr/lib/golang/src/runtime/slice.go:27
runtime.makeslice(0x115587854, 0xc2, 0xc2, 0x8)
	/usr/lib/golang/src/runtime/slice.go:44 +0x1a4 fp=0xc00004ea48 sp=0xc00004ea08 pc=0x11559bab4
github.com/boltdb/bolt.(*Bucket).write(0xc000060580, 0xc00010a901, 0xc00004ec48, 0x115aa0300)
	/usr/share/gocode/src/github.com/boltdb/bolt/bucket.go:619 +0x6c fp=0xc00004eaa0 sp=0xc00004ea48 pc=0x11569de3c
github.com/boltdb/bolt.(*Bucket).spill(0xc000176398, 0x884a882, 0x115ded400)
	/usr/share/gocode/src/github.com/boltdb/bolt/bucket.go:535 +0xe4 fp=0xc00004eca8 sp=0xc00004eaa0 pc=0x11569d6b4
github.com/boltdb/bolt.(*Tx).Commit(0xc000176380, 0xc000018480, 0x8)
	/usr/share/gocode/src/github.com/boltdb/bolt/tx.go:163 +0xd0 fp=0xc00004ee20 sp=0xc00004eca8 pc=0x1156a9ec0
github.com/hashicorp/raft-boltdb.(*BoltStore).StoreLogs(0xc00000e360, 0xc00004ef58, 0x3, 0x3, 0x0, 0x0)
	/builddir/build/BUILD/raft-boltdb-d1e82c1ec3f15ee991f7cc7ffd5b67ff6f5bbaee/_build/src/github.com/hashicorp/raft-boltdb/bolt_store.go:157 +0x214 fp=0xc00004eec0 sp=0xc00004ee20 pc=0x1158d7cd4
github.com/hashicorp/raft-boltdb.TestBoltStore_FirstIndex(0xc00012a300)
	/builddir/build/BUILD/raft-boltdb-d1e82c1ec3f15ee991f7cc7ffd5b67ff6f5bbaee/_build/src/github.com/hashicorp/raft-boltdb/bolt_store_test.go:111 +0x300 fp=0xc00004ef70 sp=0xc00004eec0 pc=0x1158d9fb0
testing.tRunner(0xc00012a300, 0x115b1dd08)
	/usr/lib/golang/src/testing/testing.go:862 +0xdc fp=0xc00004efb0 sp=0xc00004ef70 pc=0x11564af7c
runtime.goexit()
	/usr/lib/golang/src/runtime/asm_ppc64x.s:856 +0x4 fp=0xc00004efb0 sp=0xc00004efb0 pc=0x1155b51c4
created by testing.(*T).Run
	/usr/lib/golang/src/testing/testing.go:913 +0x304
goroutine 1 [chan receive]:
testing.(*T).Run(0xc00012a300, 0x1158e9239, 0x18, 0x115b1dd08, 0x115db7f01)
	/usr/lib/golang/src/testing/testing.go:914 +0x320
testing.runTests.func1(0xc00012a000)
	/usr/lib/golang/src/testing/testing.go:1154 +0x8c
testing.tRunner(0xc00012a000, 0xc000119dd8)
	/usr/lib/golang/src/testing/testing.go:862 +0xdc
testing.runTests(0xc00000e140, 0x115db7400, 0xa, 0xa, 0x0)
	/usr/lib/golang/src/testing/testing.go:1152 +0x2a0
testing.(*M).Run(0xc00000c080, 0x0)
	/usr/lib/golang/src/testing/testing.go:1069 +0x174
main.main()
	_testmain.go:80 +0x150
goroutine 4 [syscall]:
os/signal.signal_recv(0x0)
	/usr/lib/golang/src/runtime/sigqueue.go:139 +0x10c
os/signal.loop()
	/usr/lib/golang/src/os/signal/signal_unix.go:23 +0x38
created by os/signal.init.0
	/usr/lib/golang/src/os/signal/signal_unix.go:29 +0x50
exit status 2
FAIL	github.com/hashicorp/raft-boltdb	0.147s

Comment 5 Jakub Čajka 2019-02-28 12:19:13 UTC
This seems to be resolved with changes from BZ#1680040.
https://koji.fedoraproject.org/koji/taskinfo?taskID=33102500

Comment 6 Fedora Release Engineering 2019-04-26 23:27:35 UTC
Dear Maintainer,

your package has not been built successfully in f30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 7 Fedora Release Engineering 2019-06-03 21:42:54 UTC
Dear Maintainer,

your package has not been built successfully in f30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 8 Fedora Release Engineering 2019-06-17 20:46:21 UTC
Dear Maintainer,

your package has not been built successfully in f30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 9 Fedora Release Engineering 2019-07-02 11:14:26 UTC
Dear Maintainer,

your package has not been built successfully in 30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 31 according to the schedule [3],
any packages which still have open FTBFS bugs from Fedora 30 will be retired.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/31/Schedule

Comment 10 Fedora Release Engineering 2019-07-02 13:30:53 UTC
Dear Maintainer,

your package has not been built successfully in 30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 31 according to the schedule [3],
any packages which still have open FTBFS bugs from Fedora 30 will be retired.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/31/Schedule

Comment 11 Fedora Release Engineering 2019-07-24 13:29:24 UTC
Dear Maintainer,

your package has not been built successfully in 30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 31 according to the schedule [3],
any packages which still have open FTBFS bugs from Fedora 30 will be retired.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/31/Schedule


Note You need to log in before you can comment on or make changes to this bug.