Bug 1675032 - golang-github-pengsrc-shared: FTBFS in Fedora rawhide/f30
Summary: golang-github-pengsrc-shared: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-github-pengsrc-shared
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Robert-André Mauchin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1680040
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 18:35 UTC by Fedora Release Engineering
Modified: 2019-03-03 16:39 UTC (History)
4 users (show)

Fixed In Version: 0.2.0-6.20180718git1ef0431
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-20 16:48:06 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 18:35 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 18:35 UTC, Fedora Release Engineering
no flags Details
state.log (781 bytes, text/plain)
2019-02-11 18:35 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 18:35:50 UTC
golang-github-pengsrc-shared failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32396633


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix golang-github-pengsrc-shared at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
golang-github-pengsrc-shared will be orphaned. Before branching of Fedora 31,
golang-github-pengsrc-shared will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 18:35:52 UTC
Created attachment 1530308 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 18:35:54 UTC
Created attachment 1530309 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 18:35:55 UTC
Created attachment 1530310 [details]
state.log

Comment 4 Jakub Čajka 2019-02-13 13:10:18 UTC
Caused by crash in tests on ppc64le:
+ go test -buildmode pie -compiler gc -ldflags '-extldflags '\''-Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld '\'''
unexpected fault address 0xffffffffffd02af8
fatal error: fault
[signal SIGSEGV: segmentation violation code=0x3 addr=0xffffffffffd02af8 pc=0x135db8c64]
goroutine 22 [running]:
runtime.throw(0x135dc7cbc, 0x5)
	/usr/lib/golang/src/runtime/panic.go:617 +0x68 fp=0xc0000afe58 sp=0xc0000afe18 pc=0x135b7a4d8
runtime.sigpanic()
	/usr/lib/golang/src/runtime/signal_unix.go:397 +0x464 fp=0xc0000afe98 sp=0xc0000afe58 pc=0x135b92d74
time.(*Time).unixSec(...)
	/usr/lib/golang/src/time/time.go:176
time.Time.Unix(...)
	/usr/lib/golang/src/time/time.go:1146
github.com/pengsrc/go-shared/convert.TimeToTimestamp(0x0, 0xecf59cff8, 0xc000092600, 0xf)
	/builddir/build/BUILD/go-shared-1ef04317652833067e47e2ee9815f1f254a7a1da/_build/src/github.com/pengsrc/go-shared/convert/time.go:44 +0x74 fp=0xc0000afef0 sp=0xc0000afeb8 pc=0x135db8c64
github.com/pengsrc/go-shared/convert.TestTimeToTimestamp(0xc000104400)
	/builddir/build/BUILD/go-shared-1ef04317652833067e47e2ee9815f1f254a7a1da/_build/src/github.com/pengsrc/go-shared/convert/time_test.go:59 +0xe0 fp=0xc0000aff70 sp=0xc0000afef0 pc=0x135dbc530
testing.tRunner(0xc000104400, 0x135f64b28)
	/usr/lib/golang/src/testing/testing.go:862 +0xdc fp=0xc0000affb0 sp=0xc0000aff70 pc=0x135c26fec
runtime.goexit()
	/usr/lib/golang/src/runtime/asm_ppc64x.s:856 +0x4 fp=0xc0000affb0 sp=0xc0000affb0 pc=0x135bacf44
created by testing.(*T).Run
	/usr/lib/golang/src/testing/testing.go:913 +0x304
goroutine 1 [chan receive]:
testing.(*T).Run(0xc000104400, 0x135dcbd36, 0x13, 0x135f64b28, 0x136127f01)
	/usr/lib/golang/src/testing/testing.go:914 +0x320
testing.runTests.func1(0xc000104000)
	/usr/lib/golang/src/testing/testing.go:1154 +0x8c
testing.tRunner(0xc000104000, 0xc0000addd8)
	/usr/lib/golang/src/testing/testing.go:862 +0xdc
testing.runTests(0xc00009c380, 0x136127f60, 0x2d, 0x2d, 0x0)
	/usr/lib/golang/src/testing/testing.go:1152 +0x2a0
testing.(*M).Run(0xc000102000, 0x0)
	/usr/lib/golang/src/testing/testing.go:1069 +0x174
main.main()
	_testmain.go:130 +0x150
exit status 2
FAIL	github.com/pengsrc/go-shared/convert	0.015s

Comment 5 Robert-André Mauchin 2019-02-20 16:48:06 UTC
I've reported the bug upstream and temporarily disabled tests for ppc64le
https://github.com/pengsrc/go-shared/issues/6

Comment 6 Robert-André Mauchin 2019-02-21 16:29:09 UTC
Upstream bug https://github.com/golang/go/issues/30283

Comment 7 Jakub Čajka 2019-02-28 08:40:18 UTC
This seems to be resolved with changes from BZ#1680040.
https://koji.fedoraproject.org/koji/taskinfo?taskID=33100739 (with enabled tests)


Note You need to log in before you can comment on or make changes to this bug.