Bug 1675039 - golang-googlecode-go-crypto: FTBFS in Fedora rawhide/f30
Summary: golang-googlecode-go-crypto: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-googlecode-go-crypto
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fridolín Pokorný
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1680040
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 18:36 UTC by Fedora Release Engineering
Modified: 2019-03-03 15:12 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-03 15:12:38 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 18:36 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 18:36 UTC, Fedora Release Engineering
no flags Details
state.log (773 bytes, text/plain)
2019-02-11 18:36 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 18:36:31 UTC
golang-googlecode-go-crypto failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32397410


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix golang-googlecode-go-crypto at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
golang-googlecode-go-crypto will be orphaned. Before branching of Fedora 31,
golang-googlecode-go-crypto will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 18:36:34 UTC
Created attachment 1530329 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 18:36:35 UTC
Created attachment 1530330 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 18:36:36 UTC
Created attachment 1530331 [details]
state.log

Comment 4 Jakub Čajka 2019-02-13 13:39:47 UTC
Caused by crash in the tests on ppc64le:
+ go test -buildmode pie -compiler gc -ldflags '-extldflags '\''-Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld '\'''
unexpected fault address 0x3b400
fatal error: fault
[signal SIGSEGV: segmentation violation code=0x1 addr=0x3b400 pc=0x12352ecd4]
goroutine 21 [running]:
runtime.throw(0x1235e990f, 0x5)
	/usr/lib/golang/src/runtime/panic.go:617 +0x68 fp=0xc00004ba88 sp=0xc00004ba48 pc=0x1234fdcb8
runtime.sigpanic()
	/usr/lib/golang/src/runtime/signal_unix.go:397 +0x464 fp=0xc00004bac8 sp=0xc00004ba88 pc=0x123514a04
runtime.memmove(0xc00004bdd8, 0x3b400, 0x28)
	/usr/lib/golang/src/runtime/memmove_ppc64x.s:57 +0x64 fp=0xc00004bae8 sp=0xc00004bae8 pc=0x12352ecd4
golang.org/x/crypto/ed25519/internal/edwards25519.FeZero(...)
	/builddir/build/BUILD/crypto-e84da0312774c21d64ee2317962ef669b27ffb41/_build/src/golang.org/x/crypto/ed25519/internal/edwards25519/edwards25519.go:21
golang.org/x/crypto/ed25519/internal/edwards25519.(*ExtendedGroupElement).Zero(...)
	/builddir/build/BUILD/crypto-e84da0312774c21d64ee2317962ef669b27ffb41/_build/src/golang.org/x/crypto/ed25519/internal/edwards25519/edwards25519.go:683
golang.org/x/crypto/ed25519/internal/edwards25519.GeScalarMultBase(0xc00004bdd8, 0xc00004bd78)
	/builddir/build/BUILD/crypto-e84da0312774c21d64ee2317962ef669b27ffb41/_build/src/golang.org/x/crypto/ed25519/internal/edwards25519/edwards25519.go:989 +0x140 fp=0xc00004bd00 sp=0xc00004bae8 pc=0x1235e2de0
golang.org/x/crypto/ed25519.Sign(0xc0000c8040, 0x40, 0x40, 0xc00008c0c0, 0xc, 0xc, 0x40, 0x40, 0x0)
	/builddir/build/BUILD/crypto-e84da0312774c21d64ee2317962ef669b27ffb41/_build/src/golang.org/x/crypto/ed25519/ed25519.go:149 +0x238 fp=0xc00004bea8 sp=0xc00004bd00 pc=0x1235e5cc8
golang.org/x/crypto/ed25519.TestSignVerify(0xc0000c0200)
	/builddir/build/BUILD/crypto-e84da0312774c21d64ee2317962ef669b27ffb41/_build/src/golang.org/x/crypto/ed25519/ed25519_test.go:53 +0xe4 fp=0xc00004bf70 sp=0xc00004bea8 pc=0x1235e66f4
testing.tRunner(0xc0000c0200, 0x1236a7718)
	/usr/lib/golang/src/testing/testing.go:862 +0xdc fp=0xc00004bfb0 sp=0xc00004bf70 pc=0x12358c6ac
runtime.goexit()
	/usr/lib/golang/src/runtime/asm_ppc64x.s:856 +0x4 fp=0xc00004bfb0 sp=0xc00004bfb0 pc=0x12352e984
created by testing.(*T).Run
	/usr/lib/golang/src/testing/testing.go:913 +0x304
goroutine 1 [chan receive]:
testing.(*T).Run(0xc0000c0200, 0x1235eb233, 0xe, 0x1236a7718, 0x123777f01)
	/usr/lib/golang/src/testing/testing.go:914 +0x320
testing.runTests.func1(0xc0000c0000)
	/usr/lib/golang/src/testing/testing.go:1154 +0x8c
testing.tRunner(0xc0000c0000, 0xc0000addd8)
	/usr/lib/golang/src/testing/testing.go:862 +0xdc
testing.runTests(0xc00009c080, 0x123774c00, 0x5, 0x5, 0x0)
	/usr/lib/golang/src/testing/testing.go:1152 +0x2a0
testing.(*M).Run(0xc0000be000, 0x0)
	/usr/lib/golang/src/testing/testing.go:1069 +0x174
main.main()
	_testmain.go:56 +0x150
exit status 2
FAIL	golang.org/x/crypto/ed25519	0.007s

Comment 5 Jakub Čajka 2019-02-28 08:59:09 UTC
This seems to be fixed by changes in the BZ#1680040.
https://koji.fedoraproject.org/koji/taskinfo?taskID=33100804

Comment 6 Zbigniew Jędrzejewski-Szmek 2019-03-03 15:12:38 UTC
A build was successfull: golang-googlecode-go-crypto-0-0.28.20190302git8dd112b.fc30 [1].
Closing the bug.

[1] https://koji.fedoraproject.org/koji/buildinfo?buildID=1219108


Note You need to log in before you can comment on or make changes to this bug.