Bug 1675040 - golang-googlecode-gogoprotobuf: FTBFS in Fedora rawhide/f30
Summary: golang-googlecode-gogoprotobuf: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-googlecode-gogoprotobuf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fridolín Pokorný
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 18:36 UTC by Fedora Release Engineering
Modified: 2019-03-29 19:10 UTC (History)
8 users (show)

Fixed In Version: golang-googlecode-gogoprotobuf-1.2.1-1.fc29 golang-googlecode-gogoprotobuf-1.2.1-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 06:04:35 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 18:36 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 18:36 UTC, Fedora Release Engineering
no flags Details
state.log (713 bytes, text/plain)
2019-02-11 18:36 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 18:36:37 UTC
golang-googlecode-gogoprotobuf failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32397441


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix golang-googlecode-gogoprotobuf at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
golang-googlecode-gogoprotobuf will be orphaned. Before branching of Fedora 31,
golang-googlecode-gogoprotobuf will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 18:36:40 UTC
Created attachment 1530332 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 18:36:42 UTC
Created attachment 1530333 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 18:36:43 UTC
Created attachment 1530334 [details]
state.log

Comment 4 Jakub Čajka 2019-02-13 13:45:40 UTC
Caused by tests failure on ppc64le:
+ go test -buildmode pie -compiler gc -ldflags '-extldflags '\''-Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld '\'''
PASS
ok  	github.com/gogo/protobuf/jsonpb	0.013s
Testing: "/builddir/build/BUILD/protobuf-1.1.1/_build/src/github.com/gogo/protobuf/proto"
+ GOPATH=/builddir/build/BUILD/protobuf-1.1.1/_build:/usr/share/gocode
+ go test -buildmode pie -compiler gc -ldflags '-extldflags '\''-Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld '\'''
--- FAIL: TestNumericPrimitives (0.00s)
    all_test.go:261: zigzag32 decode fail: -12345 4294954951
--- Dump of b ---
  0: t=  1 bytes [7] 08 01 12 .. 52 6f 62
  9: t=  1 bytes [7] 08 04 12 .. 49 61 6e
 18: t=  1 bytes [8] 08 08 12 .. 61 76 65
2019/02/01 04:10:54 proto: don't know how to compare extension 200 of test_proto.MyMessage
FAIL
exit status 1
FAIL	github.com/gogo/protobuf/proto	0.054s

Comment 5 Elliott Sales de Andrade 2019-03-04 01:38:55 UTC
Probably should be retired, because Google Code is dead. It seems to be used by goraft/raft, but that upstream is dead and unmaintained, and *that* package appears unused.

Comment 6 Robert-André Mauchin 2019-03-06 20:21:41 UTC
(In reply to Elliott Sales de Andrade from comment #5)
> Probably should be retired, because Google Code is dead. It seems to be used
> by goraft/raft, but that upstream is dead and unmaintained, and *that*
> package appears unused.

Used by:

etcd-devel-0:3.2.16-2.fc29.noarch
etcd-devel-0:3.2.16-6.fc29.noarch
golang-github-goraft-raft-devel-0:0-0.16.git73f9c44.fc29.noarch
golang-github-influxdb-influxdb-devel-0:0.9.5.1-0.8.git9eab563.fc29.noarch
golang-github-mesos-mesos-go-devel-0:0-0.9.git83b52d7.fc27.noarch
golang-github-prometheus-prometheus-devel-0:1.8.0-3.fc29.noarch
syncthing-devel-0:0.14.50-1.fc29.noarch
syncthing-devel-0:1.0.1-1.fc29.noarch

Last update was February: https://github.com/gogo/protobuf/releases/tag/v1.2.1

I will update to latest version (scratch build was successful).
https://koji.fedoraproject.org/koji/taskinfo?taskID=33243137

Comment 7 Fedora Update System 2019-03-06 20:59:46 UTC
golang-googlecode-gogoprotobuf-1.2.1-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-fd099ba5a2

Comment 8 Fedora Update System 2019-03-06 21:15:45 UTC
golang-googlecode-gogoprotobuf-1.2.1-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-0c7a3e460a

Comment 9 Fedora Update System 2019-03-06 22:54:16 UTC
golang-googlecode-gogoprotobuf-1.2.1-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-fd099ba5a2

Comment 10 Fedora Update System 2019-03-07 20:31:49 UTC
golang-googlecode-gogoprotobuf-1.2.1-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-0c7a3e460a

Comment 11 Fedora Update System 2019-03-25 06:04:35 UTC
golang-googlecode-gogoprotobuf-1.2.1-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2019-03-29 19:10:34 UTC
golang-googlecode-gogoprotobuf-1.2.1-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.