Bug 167522 - cannot record sound with Sound Blaster Live! 5.1
cannot record sound with Sound Blaster Live! 5.1
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-03 18:39 EDT by Vladimir Kotal
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-12 05:38:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
list of kernel modules running in the time when no sound can be recorded (3.02 KB, text/plain)
2005-09-03 18:39 EDT, Vladimir Kotal
no flags Details
list of devices (398 bytes, text/plain)
2005-09-03 18:42 EDT, Vladimir Kotal
no flags Details
dmesg output (15.91 KB, text/plain)
2005-09-03 18:43 EDT, Vladimir Kotal
no flags Details

  None (edit)
Description Vladimir Kotal 2005-09-03 18:39:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
It is not possible to record any sound with Sound Blaster Live. 

I have set volume of microphone via /usr/libexec/mixer_applet2 and I am able to hear myself in earphones when I talk into the microphone. However, no sound is recorded. I have tried various recording programs such as arecord, audacity - resulting recording does not contain any sound.

I am not really sure if this is a bug in ALSA or something else.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1447_FC4, alsa-lib-1.0.9rf-2.FC4, alsa-utils-1.0.9rf-2.FC4

How reproducible:
Always

Steps to Reproduce:
1. install Sound Blaster Live! 5.1
2. try to record sound via e.g. arecord
3. play the sound via e.g. aplay
  

Actual Results:  no sound can be heard

Expected Results:  sound should be heard

Additional info:
Comment 1 Vladimir Kotal 2005-09-03 18:39:50 EDT
Created attachment 118429 [details]
list of kernel modules running in the time when no sound can be recorded
Comment 2 Vladimir Kotal 2005-09-03 18:42:12 EDT
Created attachment 118430 [details]
list of devices 

taken from /proc/devices in the time when no sound can be recorded
Comment 3 Vladimir Kotal 2005-09-03 18:43:22 EDT
Created attachment 118431 [details]
dmesg output

dmesg output from the time when no sound can be recorded
Comment 4 Vladimir Kotal 2005-09-04 03:30:57 EDT
from following post it is clear that I am not alone:
  http://forums.fedoraforum.org/showthread.php?t=62710
Comment 5 Vladimir Kotal 2005-09-05 15:06:30 EDT
I have found that this bug is actually in ALSA emu10k driver itself and not it alsa-utils, so this bug can 
be closed.

The ALSA bug info:
  https://bugtrack.alsa-project.org/alsa-bug/view.php?id=1218

This will be fixed in FC4 after upgrade to 2.6.13 kernel according to:
  http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.13
  (this bug was fixed in alsa version 1.0.9b)
Comment 6 Joe Acosta 2005-09-07 23:32:19 EDT
I can duplicate this on FC 4 2.6.12-1.1447_FC4.

/sbin/lspci: 
00:0f.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 08)

/sbin/lsmod |grep snd:
snd_emu10k1_synth       6912  0
snd_emux_synth         36224  1 snd_emu10k1_synth
snd_seq_virmidi         6400  1 snd_emux_synth
snd_seq_midi_emul       6784  1 snd_emux_synth
snd_emu10k1           115204  4 snd_emu10k1_synth
snd_rawmidi            21408  2 snd_seq_virmidi,snd_emu10k1
snd_ac97_codec         79992  1 snd_emu10k1
snd_seq_dummy           2820  0
snd_seq_oss            33536  0
snd_seq_midi_event      6912  2 snd_seq_virmidi,snd_seq_oss
snd_seq                50832  8
snd_emux_synth,snd_seq_virmidi,snd_seq_midi_emul,snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          7180  7
snd_emu10k1_synth,snd_emux_synth,snd_emu10k1,snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            50224  0
snd_mixer_oss          17792  4 snd_pcm_oss
snd_pcm                85000  3 snd_emu10k1,snd_ac97_codec,snd_pcm_oss
snd_timer              22020  3 snd_emu10k1,snd_seq,snd_pcm
snd_page_alloc          7812  2 snd_emu10k1,snd_pcm
snd_util_mem            3584  2 snd_emux_synth,snd_emu10k1
snd_hwdep               7328  2 snd_emux_synth,snd_emu10k1
snd                    47076  13
snd_emux_synth,snd_seq_virmidi,snd_emu10k1,snd_rawmidi,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
soundcore               7648  4 snd

when will 2.6.13 be released or do you have a test kernel I could try ... SRPM
preferred...
Comment 7 Vladimir Kotal 2005-09-26 14:05:48 EDT
The bug still persists even with testing kernel:

[techie@erazim ~]$ uname -a
Linux erazim.devnull-lab.cz 2.6.13-1.1524_FC4 #1 Wed Sep 21 00:00:00 EDT 2005
i686 athlon i386 GNU/Linux

[techie@erazim ~]$ more /etc/sysconfig/hwconf
-
class: OTHER
bus: PCI
detached: 0
driver: emu10k1-gp
desc: "Creative Labs SB Live! MIDI/Game Port"
vendorId: 1102
deviceId: 7002
subVendorId: 1102
subDeviceId: 0020
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  a
pcifn:  1
-

<snip>

-
class: AUDIO
bus: PCI
detached: 0
driver: snd-emu10k1
desc: "Creative Labs SB Live! EMU10k1"
vendorId: 1102
deviceId: 0002
subVendorId: 1102
subDeviceId: 8065
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  a
pcifn:  0
-
Comment 8 Martin A. Boegelund 2005-09-29 18:27:02 EDT
I'm experiencing the same bug; Can hear my voice when talking into microphone,
but cannot record anything in KRec, and cannot talk through gnomemeeting.
I have tried diferent things in alsamixer and gnome-volume-control, but nothing
helps.

Relevant config summary:
FC4
Kernel 2.6.12-1.1456_FC4
alsa-lib-devel-1.0.9rf-2.FC4
alsa-lib-1.0.9rf-2.FC4
alsa-utils-1.0.9rf-2.FC4
SB Live 5.1
Comment 9 Joe Acosta 2005-09-30 01:40:49 EDT
2.6.13-1.1526_FC4 still has this bug.  I can hear myself also, but nothing gets
recorded.

playing sound is fine.
Comment 10 Martin Stransky 2005-09-30 01:57:50 EDT
You can check the latest kernel from devel (kernel-2.6.13-1.1582_FC5), it has
alsa-driver-1.0.10rc1. It's here:
http://download.fedora.redhat.com/pub/fedora/linux/core/development/
Comment 11 Vladimir Kotal 2005-09-30 14:28:53 EDT
Thanks, but I will rather stay with my current kernel and wait for the 2.6.14 (or 2.6.13 with ALSA 
1.0.10rc1) to be released for FC4, because of:

[root@erazim techie]# rpm -Uvh kernel-2.6.13-1.1586_FC5.i686.rpm 
error: Failed dependencies:
        mkinitrd >= 4.2.21-1 is needed by kernel-2.6.13-1.1586_FC5.i686
        ppp < 2.4.3-3 conflicts with kernel-2.6.13-1.1586_FC5.i686
        isdn4k-utils < 3.2-32 conflicts with kernel-2.6.13-1.1586_FC5.i686
        nfs-utils < 1.0.7-12 conflicts with kernel-2.6.13-1.1586_FC5.i686
        procps < 3.2.5-6.3 conflicts with kernel-2.6.13-1.1586_FC5.i686
        oprofile < 0.9.1-2 conflicts with kernel-2.6.13-1.1586_FC5.i686
        udev < 063-6 conflicts with kernel-2.6.13-1.1586_FC5.i686
        iptables < 1.3.2-1 conflicts with kernel-2.6.13-1.1586_FC5.i686
[root@erazim techie]# 
Comment 12 Martin Stransky 2005-10-02 04:23:15 EDT
I'm afraid 1.0.10 will never go to FC4...we don't update alsa-drivers in
released distros.
Comment 13 Vladimir Kotal 2005-10-02 05:48:23 EDT
Oh well.. Maybe I will try to install one of the FC5 test releases. Thanks for the info.
Comment 14 Joe Acosta 2005-10-08 19:29:00 EDT
I tried to install and it failed, I tried to compile and it failed.  

So let me get this straight, I need to upgrade to FC 5 when FC 5 comes out to
get my sound recording back?

I guess I should have stayed with FC2 cause it worked then :-(
Comment 15 Vincent de Grandpré 2005-10-10 20:55:36 EDT
Hi all!

This issue can be solved by modifying accordingly /etc/modprobe.conf.

The Stentz release of FC4 added snd-card-0, then added snd-emu10k1, then removed
snd-emu10k1 with parameters, wich caused this "unable to record by I can hear
myself" error.

Details at http://forums.fedoraforum.org/showthread.php?p=381506#post381506

Merci!

Vincent de Grandpré
Montréal, Québec
Comment 16 Joe Acosta 2005-10-10 23:44:58 EDT
First I comment out the two lines below in my modprobe.conf file, then rebooted. 

#install sound-slot-0 /sbin/modprobe --first-time --ignore-install sound-slot-0
&& { /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :; }
#remove sound-slot-0 { /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 ||
:; } ; /sbin/modprobe -r --first-time --ignore-remove sound-slot-0


Nothing seemed to change, so I went into my volume control and I had to go into
preferences and turn the capture device on.  Then I saw it was mutted and
unmutted it.  I can now record.

:-)

BTW: the 2.6.13-FC kernel I finally got it to compile and it did not seem to
change anything. The above did work though. 
Comment 17 Vladimir Kotal 2005-10-11 03:08:47 EDT
This solution does not work for me, since I have no emu10k1-related entries in /etc/modrprobe.conf

I have been using on-board sound card, then installed Sound Blaster Live! so I had some leftover entries 
in modprobe.conf. After commenting them out, my modprobe.conf now looks like this:

[techie@erazim ~]$ cat /etc/modprobe.conf
alias eth0 8139too
alias eth1 e100
alias scsi_hostadapter sata_via
#alias snd-card-0 snd-via82xx
#options snd-card-0 index=0
#install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx && /usr/sbin/alsactl restore >/
dev/null 2>&1 || :
#remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-
remove snd-via82xx
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
alias ieee1394-controller ohci1394
[techie@erazim ~]$ 
[techie@erazim ~]$ uname -a
Linux erazim.devnull-lab.cz 2.6.13-1.1524_FC4 #1 Wed Sep 21 00:00:00 EDT 2005 i686 athlon i386 
GNU/Linux
[techie@erazim ~]$ cat /proc/asound/version 
Advanced Linux Sound Architecture Driver Version 1.0.9b (Thu Jul 28 12:20:13 2005 UTC).
[techie@erazim ~]$ 


No change after reboot with this config file - I am still not able to record.
Comment 18 Martin A. Boegelund 2005-10-11 15:38:02 EDT
Uncommenting the mentioned entries i /etc/modprobe.conf doesn't solve the 
problem for my system either - still can't record.
And I have turned up the capture volume, unmuted it etc.
Comment 19 Joe Acosta 2005-10-11 23:58:00 EDT
my modprobe.conf looks like this:

# Note: for use under 2.4, changes must also be made to modules.conf!
alias parport_lowlevel parport_pc
alias eth0 tulip
alias char-major-10-200 tun
alias scsi_hostadapter sym53c8xx
alias usb-controller uhci-hcd
alias ieee1394-controller ohci1394
alias char-major-195 nvidia
alias char-major-89 i2c-dev
alias char-major-116 snd
alias char-major-14 soundcore
alias snd-card-0 snd-emu10k1
options snd-emu10k index=0
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
#install sound-slot-0 /sbin/modprobe --first-time --ignore-install sound-slot-0
&& { /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :; }
#remove sound-slot-0 { /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 ||
:; } ; /sbin/modprobe -r --first-time --ignore-remove sound-slot-0


Also make sure that capture has a volume set to it.  In alsamixer, use the tab
to look at the capture settings, then use the right arrow key to move to see the
capture settings.

It works okay for me, but my mic is kinda crappy ;-).


Comment 20 Martin A. Boegelund 2005-10-14 17:30:31 EDT
In my message above, "Uncommenting" of course should have been "Commenting out".
I've tried to use the sound card build in on my motherboard instead of the SB 
Live, and recording worked.
I guess I'll have to wait for FC5, then...
Comment 21 Vladimir Kotal 2005-10-16 06:05:07 EDT
Same for me - recording works with onboard soundcard, but does not with SB Live.

If you don't want to wait for FC5 which is due in some 4 months (according to http://
fedora.redhat.com/participate/schedule/), you can use custom-built kernel with newer ALSA or use 
some of FC5 devel versions.
Comment 22 Joe Acosta 2005-10-25 23:13:36 EDT
It may be a on board sound card is conflicting with the SBLive card.  IE:
Interrupts, adresses, etc.
Comment 23 Vladimir Kotal 2005-10-27 04:17:44 EDT
No, this is not the case because:
  - I have switched off the on-board sound card in BIOS
  - ALSA folks have confirmed that the bug exists (see ALSA bug id somewhere in this 'thread')

To summarize:
This is well known problem in ALSA driver for SB Live (ALSA emu10k1 driver) which was fixed in recent 
versions of ALSA drivers (1.0.10). The only problem is that FC4 does not and will never incorporate 
ALSA 1.0.10 in their kernels.
Comment 24 Martin Stransky 2006-01-03 10:29:53 EST
Some how-to for the latest alsa-driver and FC4 is here:
http://people.redhat.com/stransky/alsa/

Note You need to log in before you can comment on or make changes to this bug.