Bug 1675227 - automoc regression causes kdelibs FTBFS in Fedora rawhide/f30
Summary: automoc regression causes kdelibs FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: automoc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F30FTBFS 1695162
TreeView+ depends on / blocked
 
Reported: 2019-02-11 20:37 UTC by Fedora Release Engineering
Modified: 2019-04-08 00:01 UTC (History)
8 users (show)

Fixed In Version: automoc-1.0-0.34.rc3.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-08 00:01:18 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 20:37 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 20:37 UTC, Fedora Release Engineering
no flags Details
state.log (633 bytes, text/plain)
2019-02-11 20:37 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 20:37:30 UTC
kdelibs failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32404350


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix kdelibs at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
kdelibs will be orphaned. Before branching of Fedora 31,
kdelibs will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 20:37:38 UTC
Created attachment 1530792 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 20:37:40 UTC
Created attachment 1530793 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 20:37:41 UTC
Created attachment 1530794 [details]
state.log

Comment 4 Rex Dieter 2019-02-14 17:51:25 UTC
BUILDSTDERR: /builddir/build/BUILD/kdelibs-4.14.38/kdecore/auth/backends/dbus/DBusHelperProxy.h:35: Error: Undefined interface
BUILDSTDERR: automoc4: process for /builddir/build/BUILD/kdelibs-4.14.38/x86_64-redhat-linux-gnu/kdecore/moc_DBusHelperProxy.cpp failed: Unknown error
BUILDSTDERR: pid to wait for: 0
Generating kssld.moc
BUILDSTDERR: returning failed..
Generating moc_klibloadertest_module.cpp
make[2]: Leaving directory '/builddir/build/BUILD/kdelibs-4.14.38/x86_64-redhat-linux-gnu'
BUILDSTDERR: make[2]: *** [kdecore/CMakeFiles/kauth_helper_plugin_automoc.dir/build.make:60: kdecore/CMakeFiles/kauth_helper_plugin_automoc] Error 1
Generating kcolorutilsdemo.moc
Generating kactioncollection.moc
Generating moc_dynamictreemodel.cpp
BUILDSTDERR: /builddir/build/BUILD/kdelibs-4.14.38/kdecore/auth/backends/polkit-1/Polkit1Backend.h:41: Error: Undefined interface
Generating networking_p.moc
BUILDSTDERR: automoc4: process for /builddir/build/BUILD/kdelibs-4.14.38/x86_64-redhat-linux-gnu/kdecore/moc_Polkit1Backend.cpp failed: Unknown error
BUILDSTDERR: pid to wait for: 0
BUILDSTDERR: returning failed..

looks like automoc fun

Comment 5 Ngo Than 2019-02-27 14:00:08 UTC
it built fine with automoc-1.0-0.32.rc3. It's regression in automoc-1.0-0.33.rc3

Comment 6 Fedora Update System 2019-04-03 18:38:11 UTC
automoc-1.0-0.34.rc3.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-cedbce2936

Comment 7 Fedora Update System 2019-04-04 01:59:46 UTC
automoc-1.0-0.34.rc3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-cedbce2936

Comment 8 Fedora Update System 2019-04-08 00:01:18 UTC
automoc-1.0-0.34.rc3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.