Bug 1675573 - opal-prd: FTBFS in Fedora rawhide/f30
Summary: opal-prd: FTBFS in Fedora rawhide/f30
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: opal-prd
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Vasant Hegde
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks: PPCTracker F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 21:19 UTC by Fedora Release Engineering
Modified: 2019-04-27 12:46 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-04-27 07:50:16 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 21:19 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 21:19 UTC, Fedora Release Engineering
no flags Details
state.log (617 bytes, text/plain)
2019-02-11 21:19 UTC, Fedora Release Engineering
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 175573 None None None 2019-05-07 08:31 UTC

Description Fedora Release Engineering 2019-02-11 21:19:31 UTC
opal-prd failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32428170


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix opal-prd at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
opal-prd will be orphaned. Before branching of Fedora 31,
opal-prd will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 21:19:33 UTC
Created attachment 1531774 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 21:19:34 UTC
Created attachment 1531775 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 21:19:36 UTC
Created attachment 1531776 [details]
state.log

Comment 4 Michel Normand 2019-02-13 12:53:34 UTC
related to gcc9 new compiler version, associated reported warning/error:
===
gcc -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mcpu=power8 -mtune=power8 -fasynchronous-unwind-tables -fstack-clash-protection -I. -I../../include -I../../  -c libflash/libffs.c -o libflash-libffs.o
In file included from /usr/include/string.h:494,
                 from libflash/libffs.c:21:
In function 'strncpy',
    inlined from 'ffs_part_info' at libflash/libffs.c:525:3:
/usr/include/bits/string_fortified.h:106:10: warning: '__builtin_strncpy' output may be truncated copying 15 bytes from a string of length 15 [-Wstringop-truncation]
  106 |   return __builtin___strncpy_chk (__dest, __src, __len, __bos (__dest));
      |          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
...
gcc -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mcpu=power8 -mtune=power8 -fasynchronous-unwind-tables -fstack-clash-protection -I. -I../../include -I../../  -c libflash/libffs.c -o libflash-libffs.o
In file included from /usr/include/string.h:494,
                 from libflash/libffs.c:21:
In function 'strncpy',
    inlined from 'ffs_part_info' at libflash/libffs.c:525:3:
/usr/include/bits/string_fortified.h:106:10: warning: '__builtin_strncpy' output may be truncated copying 15 bytes from a string of length 15 [-Wstringop-truncation]
  106 |   return __builtin___strncpy_chk (__dest, __src, __len, __bos (__dest));
      |          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
...
gcc -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mcpu=power8 -mtune=power8 -fasynchronous-unwind-tables -fstack-clash-protection -O2 -Wall -Werror -Wno-stringop-truncation -I. -c libflash/ecc.c -o libflash-ecc.o
libflash/ecc.c: In function 'memcpy_to_ecc_unaligned':
libflash/ecc.c:419:24: error: taking address of packed member of 'struct ecc64' may result in an unaligned pointer value [-Werror=address-of-packed-member]
  419 |   memcpy(inc_uint64_by(&ecc_word.data, alignment), src, bytes_wanted);
      |                        ^~~~~~~~~~~~~~
libflash/ecc.c:448:24: error: taking address of packed member of 'struct ecc64' may result in an unaligned pointer value [-Werror=address-of-packed-member]
  448 |   memcpy(inc_uint64_by(&ecc_word.data, len), inc_ecc64_by(dst, len),
      |                        ^~~~~~~~~~~~~~
cc1: all warnings being treated as errors
===

Comment 5 Michel Normand 2019-02-13 12:58:58 UTC
create new issue upstream: https://github.com/open-power/skiboot/issues/218

Comment 6 IBM Bug Proxy 2019-02-15 17:30:24 UTC
------- Comment From hegdevasant@in.ibm.com 2019-02-15 12:23 EDT-------
Part of the issue is fixed by https://github.com/open-power/skiboot/pull/212... which is not yet merged in upstream.. will let you know once it gets merged.

I have to look into other part and see how to fix that..

-Vasant

Comment 7 IBM Bug Proxy 2019-02-18 08:30:25 UTC
------- Comment From hegdevasant@in.ibm.com 2019-02-18 03:21 EDT-------
And https://lists.ozlabs.org/pipermail/skiboot/2019-February/013297.html this should remaining issue.

FYI https://koji.fedoraproject.org/koji/taskinfo?taskID=32879051
--> Sample koji build with above two fixes.

-Vasant

Comment 8 IBM Bug Proxy 2019-03-07 08:50:26 UTC
------- Comment From hegdevasant@in.ibm.com 2019-03-07 03:47 EDT-------
rawhide / master build : https://koji.fedoraproject.org/koji/taskinfo?taskID=33260121

F30 build : https://koji.fedoraproject.org/koji/taskinfo?taskID=33260216

-Vasant

Comment 9 Fedora Release Engineering 2019-04-26 23:30:54 UTC
Dear Maintainer,

your package has not been built successfully in f30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/


Note You need to log in before you can comment on or make changes to this bug.