Bug 1675634 - perl-Sys-CPU: FTBFS in Fedora rawhide/f30
Summary: perl-Sys-CPU: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Sys-CPU
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Emmanuel Seyman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 21:25 UTC by Fedora Release Engineering
Modified: 2019-02-12 11:14 UTC (History)
3 users (show)

Fixed In Version: perl-Sys-CPU-0.61-18.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-12 11:14:10 UTC


Attachments (Terms of Use)
build.log (21 bytes, text/plain)
2019-02-11 21:25 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 21:25 UTC, Fedora Release Engineering
no flags Details
state.log (92 bytes, text/plain)
2019-02-11 21:25 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 21:25:03 UTC
perl-Sys-CPU failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32441386


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix perl-Sys-CPU at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
perl-Sys-CPU will be orphaned. Before branching of Fedora 31,
perl-Sys-CPU will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 21:25:05 UTC
Created attachment 1531944 [details]
build.log

Comment 2 Fedora Release Engineering 2019-02-11 21:25:07 UTC
Created attachment 1531945 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 21:25:08 UTC
Created attachment 1531946 [details]
state.log

Comment 4 Jan Pazdziora 2019-02-12 08:39:13 UTC
https://kojipkgs.fedoraproject.org//work/tasks/5282/32465282/mock_output.log ends with

Error: Error downloading packages:
  Cannot download toplink/packages/gdb/8.2.50.20190120/13.fc30/armv7hl/gdb-headless-8.2.50.20190120-13.fc30.armv7hl.rpm: All mirrors were tried

Not sure how I could fix the problem.

Comment 5 Emmanuel Seyman 2019-02-12 08:42:17 UTC
Yes, this looks like a fluke.
At the end of week, I'll bump and rebuild all my FTBFS packages just to make sure I can reproduce this.

Comment 6 Jan Pazdziora 2019-02-12 11:14:10 UTC
Built respun: https://koji.fedoraproject.org/koji/taskinfo?taskID=32760620


Note You need to log in before you can comment on or make changes to this bug.