Bug 1675670 - planets: FTBFS in Fedora rawhide/f30
Summary: planets: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: planets
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1556127 1605470 (view as bug list)
Depends On:
Blocks: F29FTBFS F30FTBFS F28FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 21:28 UTC by Fedora Release Engineering
Modified: 2019-04-06 20:18 UTC (History)
4 users (show)

Fixed In Version: planets-0.1.13-25.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-06 20:18:50 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 21:28 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 21:28 UTC, Fedora Release Engineering
no flags Details
state.log (629 bytes, text/plain)
2019-02-11 21:28 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 21:28:16 UTC
planets failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32451088


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix planets at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
planets will be orphaned. Before branching of Fedora 31,
planets will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 21:28:18 UTC
Created attachment 1532034 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 21:28:19 UTC
Created attachment 1532035 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 21:28:20 UTC
Created attachment 1532036 [details]
state.log

Comment 4 Gwyn Ciesla 2019-02-22 17:33:52 UTC
*** Bug 1556127 has been marked as a duplicate of this bug. ***

Comment 5 Gwyn Ciesla 2019-02-22 17:34:14 UTC
*** Bug 1605470 has been marked as a duplicate of this bug. ***

Comment 6 Gwyn Ciesla 2019-02-22 17:35:03 UTC
Richard, I feel like this is a simple fix, but I don't know ocaml. Can you provide any insight?

Comment 7 Richard W.M. Jones 2019-04-01 08:06:04 UTC
Oh yes this should be simple - I'll take this one.

Comment 8 Fedora Update System 2019-04-01 08:31:11 UTC
planets-0.1.13-25.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-6618073e2a

Comment 9 Gwyn Ciesla 2019-04-01 13:41:24 UTC
Thank you so much!

Comment 10 Fedora Update System 2019-04-02 02:29:51 UTC
planets-0.1.13-25.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-6618073e2a

Comment 11 Fedora Update System 2019-04-06 20:18:50 UTC
planets-0.1.13-25.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.