Bug 167593 - system-config-network doesn't add default gw in DHCP mode if greyed out default gateway previously configured.
system-config-network doesn't add default gw in DHCP mode if greyed out defau...
Status: CLOSED DUPLICATE of bug 149780
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-05 21:30 EDT by Steven Elliott
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-19 06:14:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Elliott 2005-09-05 21:30:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
When a one of the devices in system-config-network is in DHCP mode, but there is a greyed out "Default gateway address" from a previous static IP address configuration, the resulting non-blank "GATEWAY=" in the /etc/sysconfig/network-scripts/ifcfg-<interface> file causes the DHCP client to ignore the "routers" option.  So, a default gateway is not configured.

Version-Release number of selected component (if applicable):
system-config-network-tui-1.3.22-1

How reproducible:
Always

Steps to Reproduce:
1. Configure an intreface, such as eth0 (any will work) with a static IP adderss with a "Default gateway address".
2. Save the interface.
3. Change to DHCP mode by moving the radio button to "Automatically obtain IP address settings with dhcp".
4. Attempt to bring up the intreface in DHCP mode using a DHCP server that will provide a default gateway via the "option routers <default gateway>" option in /etc/dhcpd.conf
  

Actual Results:  A default gateway was not created.  Manually creating the default gateway with 
    route add default gw <ip addr of the gateway>
where the IP address is obtained from
    grep routers /var/lib/dhcp/dhclient-eth0.leases | tail -1
fixes the problem.  It does not route correctly without the default gateway.

Expected Results:  The default gateway should have been created.  One way of fixing the problem would  be for the DHCP client to ignore the "GATEWAY=" attribute if "BOOTPROTO=dhcp".

Additional info:
Comment 1 Harald Hoyer 2006-05-19 06:14:30 EDT

*** This bug has been marked as a duplicate of 149780 ***

Note You need to log in before you can comment on or make changes to this bug.