Bug 167616 - Add apt metadata to official mirrors
Add apt metadata to official mirrors
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: apt (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-06 07:13 EDT by Mephisto
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-06 14:44:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mephisto 2005-09-06 07:13:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050818 Fedora/1.1-0.2.7.deerpark.alpha2.1 Firefox/1.0+

Description of problem:
I've been using apt with synaptic since fc1 or 2, and i've mainly relied on the Freshrpms repository, since the official mirrors don't support apt.
However, since a week or so, Freshrpms stopped updating its metadata due to some hardware problems, and i've been looking for a replacement mirror.
I haven't found one yet, and i'm getting pretty fed up with this. As long as yum doesn't have a decent frontend like Synaptic, where i can pick single updates instead of having to update everything at once (no, up2date does not count as 'decent'), i'll stick with apt. If i can't use apt anymore, because my main source for packages is messed up, i'll probably switch to debian or ubuntu.
Sorry for the rant, but this issue has been around for some time. The only reason i heard so far for not adding apt metadata is because someone who's in charge with this thinks they're "not compatible". How can they not be compatible, it works fine on FreshRPMs?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install apt and try to find mirrors for it :/
  

Additional info:
Comment 1 Panu Matilainen 2005-09-06 14:44:15 EDT
Sorry but that's not going to happen - apt doesn't work on multilib systems such
as x86_64 which is one of the reasons RH doesn't (want to) support it at all and
I can't help with that. If somebody were to add support for the new repository
metadata it could be used with the official FC mirrors, but nobody seems
interested in doing that. So people using apt/synaptic will have to keep using
whatever 3rd party repositories they can find: freshrpms, Dag Wieers repo and
ATrpms all provide apt-repositories for FC.

Oh and for Synaptic replacement I'd suggest you take a look at 'yumex'
(available in FE) which is pretty decent GUI for yum. 

Note You need to log in before you can comment on or make changes to this bug.