Bug 1676285 - golang-github-keybase-go-crypto: FTBFS in Fedora rawhide/f30
Summary: golang-github-keybase-go-crypto: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-github-keybase-go-crypto
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ed Marshall
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1680040
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-02-11 22:29 UTC by Fedora Release Engineering
Modified: 2019-02-28 20:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-28 20:43:48 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 22:30 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 22:30 UTC, Fedora Release Engineering
no flags Details
state.log (785 bytes, text/plain)
2019-02-11 22:30 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 22:29:59 UTC
golang-github-keybase-go-crypto failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32563493


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix golang-github-keybase-go-crypto at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
golang-github-keybase-go-crypto will be orphaned. Before branching of Fedora 31,
golang-github-keybase-go-crypto will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 22:30:01 UTC
Created attachment 1533787 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 22:30:02 UTC
Created attachment 1533788 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 22:30:04 UTC
Created attachment 1533789 [details]
state.log

Comment 4 Jakub Čajka 2019-02-13 20:21:45 UTC
Caused by crash in the tests on ppc64le:
+ go test -buildmode pie -compiler gc -ldflags '-extldflags '\''-Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld '\'''
unexpected fault address 0x3b400
fatal error: fault
[signal SIGSEGV: segmentation violation code=0x1 addr=0x3b400 pc=0x100cdec34]
goroutine 7 [running]:
runtime.throw(0x100d9924f, 0x5)
	/usr/lib/golang/src/runtime/panic.go:617 +0x68 fp=0xc00004ba88 sp=0xc00004ba48 pc=0x100cadc18
runtime.sigpanic()
	/usr/lib/golang/src/runtime/signal_unix.go:397 +0x464 fp=0xc00004bac8 sp=0xc00004ba88 pc=0x100cc4964
runtime.memmove(0xc00004bdd8, 0x3b400, 0x28)
	/usr/lib/golang/src/runtime/memmove_ppc64x.s:57 +0x64 fp=0xc00004bae8 sp=0xc00004bae8 pc=0x100cdec34
github.com/keybase/go-crypto/ed25519/internal/edwards25519.FeZero(...)
	/builddir/build/BUILD/go-crypto-670ebd3adf7a737d69ffe83a777a8e34eadc1b32/_build/src/github.com/keybase/go-crypto/ed25519/internal/edwards25519/edwards25519.go:21
github.com/keybase/go-crypto/ed25519/internal/edwards25519.(*ExtendedGroupElement).Zero(...)
	/builddir/build/BUILD/go-crypto-670ebd3adf7a737d69ffe83a777a8e34eadc1b32/_build/src/github.com/keybase/go-crypto/ed25519/internal/edwards25519/edwards25519.go:683
github.com/keybase/go-crypto/ed25519/internal/edwards25519.GeScalarMultBase(0xc00004bdd8, 0xc00004bd78)
	/builddir/build/BUILD/go-crypto-670ebd3adf7a737d69ffe83a777a8e34eadc1b32/_build/src/github.com/keybase/go-crypto/ed25519/internal/edwards25519/edwards25519.go:989 +0x140 fp=0xc00004bd00 sp=0xc00004bae8 pc=0x100d92d40
github.com/keybase/go-crypto/ed25519.Sign(0xc000022080, 0x40, 0x40, 0xc000018170, 0xc, 0xc, 0x40, 0x40, 0x0)
	/builddir/build/BUILD/go-crypto-670ebd3adf7a737d69ffe83a777a8e34eadc1b32/_build/src/github.com/keybase/go-crypto/ed25519/ed25519.go:120 +0x238 fp=0xc00004bea8 sp=0xc00004bd00 pc=0x100d95aa8
github.com/keybase/go-crypto/ed25519.TestSignVerify(0xc0000aa200)
	/builddir/build/BUILD/go-crypto-670ebd3adf7a737d69ffe83a777a8e34eadc1b32/_build/src/github.com/keybase/go-crypto/ed25519/ed25519_test.go:53 +0xe4 fp=0xc00004bf70 sp=0xc00004bea8 pc=0x100d964d4
testing.tRunner(0xc0000aa200, 0x100e57778)
	/usr/lib/golang/src/testing/testing.go:862 +0xdc fp=0xc00004bfb0 sp=0xc00004bf70 pc=0x100d3c60c
runtime.goexit()
	/usr/lib/golang/src/runtime/asm_ppc64x.s:856 +0x4 fp=0xc00004bfb0 sp=0xc00004bfb0 pc=0x100cde8e4
created by testing.(*T).Run
	/usr/lib/golang/src/testing/testing.go:913 +0x304
goroutine 1 [chan receive]:
testing.(*T).Run(0xc0000aa200, 0x100d9ab73, 0xe, 0x100e57778, 0x100f27f01)
	/usr/lib/golang/src/testing/testing.go:914 +0x320
testing.runTests.func1(0xc0000aa000)
	/usr/lib/golang/src/testing/testing.go:1154 +0x8c
testing.tRunner(0xc0000aa000, 0xc00009bdd8)
	/usr/lib/golang/src/testing/testing.go:862 +0xdc
testing.runTests(0xc00000e0e0, 0x100f24c00, 0x5, 0x5, 0x0)
	/usr/lib/golang/src/testing/testing.go:1152 +0x2a0
testing.(*M).Run(0xc00000c080, 0x0)
	/usr/lib/golang/src/testing/testing.go:1069 +0x174
main.main()
	_testmain.go:56 +0x150
exit status 2
FAIL	github.com/keybase/go-crypto/ed25519	0.007s

Comment 5 Ed Marshall 2019-02-13 20:26:10 UTC
FWIW, this seems to work if you remove "-buildmode=pie".

Comment 6 Jakub Čajka 2019-02-13 20:33:08 UTC
Yes there seems to be some sort of pattern with other BZs. I will investigate as it might be compiler bug.

Comment 7 Jakub Čajka 2019-02-28 11:41:07 UTC
For the record this seems to be resolved with the changes in the BZ#1680040.

Comment 8 Jakub Čajka 2019-02-28 11:41:30 UTC
(In reply to Jakub Čajka from comment #7)
> For the record this seems to be resolved with the changes in the BZ#1680040.

https://koji.fedoraproject.org/koji/taskinfo?taskID=33102153

Comment 9 Ed Marshall 2019-02-28 20:43:48 UTC
Yep, builds for both f30 and rawhide are back to normal. Thanks!


Note You need to log in before you can comment on or make changes to this bug.