Bug 1676291 - qt: FTBFS in Fedora rawhide/f30
Summary: qt: FTBFS in Fedora rawhide/f30
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL: https://src.fedoraproject.org/rpms/qt...
Whiteboard:
Depends On: 1683408
Blocks: F30FTBFS 1674649
TreeView+ depends on / blocked
 
Reported: 2019-02-11 22:30 UTC by Fedora Release Engineering
Modified: 2019-03-03 15:40 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-03 15:40:08 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2019-02-11 22:30 UTC, Fedora Release Engineering
no flags Details
root.log (1.00 KB, text/plain)
2019-02-11 22:30 UTC, Fedora Release Engineering
no flags Details
state.log (605 bytes, text/plain)
2019-02-11 22:30 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-02-11 22:30:38 UTC
qt failed to build from source in Fedora rawhide/f30

https://koji.fedoraproject.org/koji/taskinfo?taskID=32603145


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
Please fix qt at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
qt will be orphaned. Before branching of Fedora 31,
qt will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-02-11 22:30:40 UTC
Created attachment 1533805 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Fedora Release Engineering 2019-02-11 22:30:42 UTC
Created attachment 1533806 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Fedora Release Engineering 2019-02-11 22:30:44 UTC
Created attachment 1533807 [details]
state.log

Comment 4 Richard Shaw 2019-02-26 21:25:49 UTC
Problem is caused by a longstanding gcc bug which qt took advantage of which was finally fixed in gcc 9.

Relevant patch for qt 5:

https://github.com/qt/qtbase/commit/c35a3f519007af44c3b364b9af86f6a336f6411b

Which I adapted to qt 4 (but have not committed). 

Qt has other build problems though...

Comment 5 Ngo Than 2019-02-27 14:55:26 UTC
it should be fixed in qt-4.8.7-45

Comment 6 Richard Shaw 2019-02-27 15:57:52 UTC
I ran into the same errors with some missing headers and a bunch of ...has no member named...

https://kojipkgs.fedoraproject.org//work/tasks/6937/33086937/build.log

Comment 7 Richard Shaw 2019-02-27 21:53:49 UTC
Please also review the pull request for the needed patch from comment 4 before doing another build or Q_FOREACH will remain broken.

Comment 8 Richard Shaw 2019-02-28 13:28:52 UTC
Pull request submitted now that pagure is back up.

Comment 9 Rex Dieter 2019-02-28 18:31:01 UTC
%changelog
* Thu Feb 28 2019 Rex Dieter <rdieter@fedoraproject.org> - 1:4.8.7-46
- backport qforeach.patch from qt5
- -no-javascript-jit on f30 to workaround gcc9 FTBFS for now

added temporary -no-javascript-jit workaround until we have something better.

Comment 10 Zbigniew Jędrzejewski-Szmek 2019-03-03 15:40:08 UTC
A build was successfull: qt-4.8.7-46.fc30 [1].
Closing the bug.

[1] https://koji.fedoraproject.org/koji/buildinfo?buildID=1217621


Note You need to log in before you can comment on or make changes to this bug.