Bug 1676333 - booting live media, journal starts 78seconds into the startup sequence
Summary: booting live media, journal starts 78seconds into the startup sequence
Keywords:
Status: CLOSED DUPLICATE of bug 1715699
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-12 02:23 UTC by Chris Murphy
Modified: 2019-07-15 23:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-15 23:58:39 UTC


Attachments (Terms of Use)
system.journal (8.00 MB, application/octet-stream)
2019-02-12 02:24 UTC, Chris Murphy
no flags Details
virsh console (360.47 KB, text/plain)
2019-02-12 02:43 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2019-02-12 02:23:50 UTC
Description of problem:

When booting from live


Version-Release number of selected component (if applicable):
systemd-240-6.gitf02b547.fc30.x86_64
Fedora-Workstation-Live-x86_64-Rawhide-20190201.n.0.iso

How reproducible:
Always


Steps to Reproduce:
1. Boot Fedora-Workstation-Live-x86_64-Rawhide-20190201.n.0.iso in a VM using default settings (this is a UEFI VM, not sure if it matters)
2. Check the journal
3.

Actual results:


[liveuser@localhost-live ~]$ sudo journalctl -b -o short-monotonic
-- Logs begin at Mon 2019-02-11 20:57:59 EST, end at Tue 2019-02-12 01:58:00 EST. --
[   78.230893] localhost systemd[1451]: Listening on Sound System.
[   78.475652] localhost systemd[1451]: Listening on Multimedia System.
[   78.477425] localhost systemd[1451]: Starting D-Bus User Message Bus Socket.
[   78.478991] localhost systemd[1451]: Reached target Paths.
[   78.479593] localhost systemd[1451]: Started Mark boot as successful after the user session has run 2 minutes.
[   78.479940] localhost systemd[1451]: Reached target Timers.
[   78.481715] localhost systemd[1451]: Listening on D-Bus User Message Bus Socket.
[   78.482135] localhost systemd[1451]: Reached target Sockets.
[   78.482404] localhost systemd[1451]: Reached target Basic System.
[   78.507095] localhost systemd[1451]: Starting Sound Service...
[   79.561659] localhost systemd[1451]: Starting D-Bus User Message Bus...
[   80.098700] localhost systemd[1451]: Started D-Bus User Message Bus.



Expected results:

Should start with 0.000000, same as dmesg contents.


Additional info:

Comment 1 Chris Murphy 2019-02-12 02:24:21 UTC
Created attachment 1533861 [details]
system.journal

Comment 2 Chris Murphy 2019-02-12 02:43:18 UTC
Created attachment 1533878 [details]
virsh console

This is in a virt-manager VM, so I added 'systemd.log_level=debug systemd.log_target=console console=ttyS0,38400 console=tty1' to boot parameters. I don't know why but the virt-manager console shows a bunch of stuff that's not going to what I captured and am attaching by using 'sudo virsh console <VMname>'

Comment 3 Chris Murphy 2019-02-12 02:49:22 UTC
The first instance of systemd-journald is:
[   22.719371] audit: type=1130 audit(1549939070.979:3): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=systemd-journald comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'

In the log I see several instances of
systemd-journald.service: Received EPOLLHUP on stored fd 55 (stored), closing.

I see nothing in this console log about the switch from /run to /var and flushing the journal to persistent media. Maybe that happens before 78s monotonic time and is just lost in the journal, but I'd think a reference to this event should be captures in the console log - but it's not here.

Comment 4 Chris Murphy 2019-02-12 02:53:58 UTC
Same problem with selinux=0

Comment 5 Chris Murphy 2019-02-12 04:22:14 UTC
Problem doesn't happen on the installed system, only when booting live media. The attached system.journal file was found in /var/log/journal - not on /run/ so I'm guessing either the flush to persistent media didn't happen, or possibly some problem with the initial journal setup on /run/ ?

Comment 6 Chris Murphy 2019-02-12 06:39:46 UTC
OK I'm not seeing this with systemd-241~rc2-2.fc30.x86_64 in the 20190211 Live media.

Comment 7 Chris Murphy 2019-07-15 23:58:39 UTC
I spaced this out and started bug 1715699. I'm closing this one, as the other has more troubleshooting info thus far.

*** This bug has been marked as a duplicate of bug 1715699 ***


Note You need to log in before you can comment on or make changes to this bug.