Bug 1676357 - dracut-install[7836]: segfault at 0 ip 0000562144297444 sp 00007ffdb5ad3588 error 4 in dracut-install
Summary: dracut-install[7836]: segfault at 0 ip 0000562144297444 sp 00007ffdb5ad3588 e...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: dracut-maint-list
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1677450 1677455 1692189 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-12 03:55 UTC by Chris Murphy
Modified: 2019-03-29 02:59 UTC (History)
12 users (show)

Fixed In Version: dracut-049-26.git20181204.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-29 02:59:03 UTC


Attachments (Terms of Use)
journal (1.10 MB, text/plain)
2019-02-12 03:56 UTC, Chris Murphy
no flags Details
full backtrace from the crash (11.48 KB, text/plain)
2019-02-14 18:50 UTC, Adam Williamson
no flags Details

Description Chris Murphy 2019-02-12 03:55:15 UTC
Description of problem:


Version-Release number of selected component (if applicable):
dracut-049-25.git20181204.fc30.x86_64

How reproducible:
1 for 1

Steps to Reproduce:
1. Do an installation of Fedora-Workstation-Live-x86_64-Rawhide-20190201.n.0.iso
2.
3.

Actual results:

dracut-install crashes


Expected results:

No crash

Additional info:


At the time of the crash
[liveuser@localhost-live ~]$ free -m
              total        used        free      shared  buff/cache   available
Mem:           1966         906         164           5         895         746
Swap:          2095         144        1951
 [liveuser@localhost-live ~]$ sudo coredumpctl info 7836
           PID: 7836 (dracut-install)
           UID: 0 (root)
           GID: 0 (root)
        Signal: 11 (SEGV)
     Timestamp: Mon 2019-02-11 22:31:26 EST (9min ago)
  Command Line: /usr/lib/dracut/dracut-install -D /var/tmp/dracut.zsFmSF/initramfs --kerneldir /lib/modules/5.0.0-0.rc4.git2.1.fc30.x86_64/ -o -m =drivers/net/phy =drivers/>
    Executable: /mnt/sysimage/usr/lib/dracut/dracut-install
 Control Group: /user.slice/user-1000.slice/session-1.scope
          Unit: session-1.scope
         Slice: user-1000.slice
       Session: 1
     Owner UID: 1000 (liveuser)
       Boot ID: 65e102ba2b7d440e8f66306004cf78b4
    Machine ID: 8a6804fc8b1447b49bf2b522e419f2ae
      Hostname: localhost-live
       Storage: /var/lib/systemd/coredump/core.dracut-install.0.65e102ba2b7d440e8f66306004cf78b4.7836.1549942286000000.lz4
       Message: Process 7836 (dracut-install) of user 0 dumped core.
                
                Stack trace of thread 7836:
                #0  0x0000562144297444 n/a (dracut-install)
                #1  0x000056214429787a n/a (dracut-install)
                #2  0x0000562144293829 n/a (dracut-install)
                #3  0x00005621442957cf n/a (dracut-install)
                #4  0x0000562144295e6b n/a (dracut-install)
                #5  0x0000562144296874 n/a (dracut-install)
                #6  0x000056214429279d n/a (dracut-install)
                #7  0x00007fbcfedb7f33 __libc_start_main (libc.so.6)
                #8  0x0000562144292a7e n/a (dracut-install

Comment 1 Chris Murphy 2019-02-12 03:56:56 UTC
Created attachment 1533887 [details]
journal

Comment 2 Adam Williamson 2019-02-14 18:47:55 UTC
I saw what's probably the same crash today. I noticed I have kernel-core-5.0.0-0.rc6.git0.1.fc30.x86_64 installed but my system booted to an older kernel, and looking in /boot/loader/entries , there was no entry for the rc6 kernel. So I did 'dnf reinstall kernel-core-5.0.0-0.rc6.git0.1.fc30.x86_64' to see what would happen, and saw a scriptlet fail:

  Running scriptlet: kernel-core-5.0.0-0.rc6.git0.1.fc30.x86_64                                                   2/2 
/usr/lib/dracut/dracut-init.sh: line 969: 12931 Segmentation fault      (core dumped) $DRACUT_INSTALL ${initdir:+-D "$initdir"} ${loginstall:+-L "$loginstall"} ${hostonly:+-H} ${omit_drivers:+-N "$omit_drivers"} ${srcmods:+--kerneldir "$srcmods"} ${_optional:+-o} ${_silent:+--silent} -m "$@"
dracut: FAILED:  /usr/lib/dracut/dracut-install -D /var/tmp/dracut.WlwtEn/initramfs -H --kerneldir /lib/modules/5.0.0-0.rc6.git0.1.fc30.x86_64/ -o -m =drivers/net/phy =drivers/net/team =drivers/net/ethernet ecb arc4 bridge stp llc ipv6 bonding 8021q ipvlan macvlan af_packet virtio_net xennet

Looking at abrt I saw a core dump for dracut-install. I couldn't automatically report it with abrt-gui or abrt-cli because there seem to be issues with the FAF server right now (I have reported these to the maintainer by email), but I could generate the backtrace with gdb, and it's all in dracut-install, like Chris's partial trace. I will attach the full gdb-generated backtrace.

This seems pretty significant, if it's preventing newly-installed kernels from booting.

Comment 3 Adam Williamson 2019-02-14 18:50:06 UTC
Created attachment 1534939 [details]
full backtrace from the crash

Comment 4 Adam Williamson 2019-02-14 18:59:54 UTC
If I run 'dracut -f' I get the same failure for the currently-booted kernel, though it seems the same dracut-install must have worked at the time that kernel was installed. So I think this is not a case of it only failing with kernel rc6, but instead some other change has caused dracut to fail in this way on all kernels when previously it didn't...

Comment 5 Lukáš Nykrýn 2019-02-14 19:20:47 UTC
https://github.com/dracutdevs/dracut/pull/541

Comment 6 Adam Williamson 2019-02-14 20:01:33 UTC
Fix tested, works, thanks. I am sending a Rawhide package build with it backported (dracut-049-26.git20181204).

Comment 7 Adam Williamson 2019-02-14 22:22:59 UTC
*** Bug 1677415 has been marked as a duplicate of this bug. ***

Comment 8 Vendula Poncova 2019-02-15 09:17:18 UTC
*** Bug 1677455 has been marked as a duplicate of this bug. ***

Comment 9 Vendula Poncova 2019-02-15 09:18:49 UTC
*** Bug 1677450 has been marked as a duplicate of this bug. ***

Comment 10 Tom Hughes 2019-03-25 17:52:53 UTC
Looks like I am seeing this (or at least a crash in dracut-install) in F29 with the newly arrived 5.0.3 kernel...

Comment 11 Tom Hughes 2019-03-25 17:56:49 UTC
Trace seems to be the same:

           PID: 5356 (dracut-install)
           UID: 0 (root)
           GID: 0 (root)
        Signal: 11 (SEGV)
     Timestamp: Mon 2019-03-25 17:55:36 GMT (30s ago)
  Command Line: /usr/lib/dracut/dracut-install -D /var/tmp/dracut.Nn3322/initramfs -H --kerneldir /lib/modules/5.0.3-200.fc29.x86_64/ -o -m =drivers/net/phy =drive>
    Executable: /usr/lib/dracut/dracut-install
 Control Group: /user.slice/user-1000.slice/user@1000.service/gnome-terminal-server.service
          Unit: user@1000.service
     User Unit: gnome-terminal-server.service
         Slice: user-1000.slice
     Owner UID: 1000 (tom)
       Boot ID: dc9bc9bf94724a84bd437cf5a43508b0
    Machine ID: 915a7d3d1c624d789e906030a1dafb2f
      Hostname: bericote.compton.nu
       Storage: /var/lib/systemd/coredump/core.dracut-install.0.dc9bc9bf94724a84bd437cf5a43508b0.5356.1553536536000000.lz4 (inaccessible)
       Message: Process 5356 (dracut-install) of user 0 dumped core.
                
                Stack trace of thread 5356:
                #0  0x000055d2edaf9444 string_hash_func (dracut-install)
                #1  0x000055d2edaf987a hashmap_get (dracut-install)
                #2  0x000055d2edaf5829 check_hashmap (dracut-install)
                #3  0x000055d2edaf77cf install_dependent_modules (dracut-install)
                #4  0x000055d2edaf7e6b install_module (dracut-install)
                #5  0x000055d2edaf8874 install_modules (dracut-install)
                #6  0x000055d2edaf479d main (dracut-install)
                #7  0x00007fb5c2eb6413 __libc_start_main (libc.so.6)
                #8  0x000055d2edaf4a7e _start (dracut-install)

For some reason it only seemed to happen on two of the machines I just updated, and not on the other two.

Comment 12 Tom Hughes 2019-03-25 18:03:55 UTC
I can confirm that rebuilding the current F30 package (with the extra patch) for F29 fixes this.

Comment 13 Chris Murphy 2019-03-25 19:38:56 UTC
*** Bug 1692189 has been marked as a duplicate of this bug. ***

Comment 14 Chris Murphy 2019-03-25 19:41:49 UTC
Bug 1692189 is a dup, but I did process with `coredumpctl gdb` and attached the output. It definitely happens on F29 and F30, and seems to be kernel 5.0 specific, it's not happening with 4.20 kernels; also is reproducible by running dracut standalone.

Comment 15 Adam Williamson 2019-03-25 19:59:44 UTC
I'll send the fix to F29 too, then. And probably F28 as well as presumably kernel 5 is going to wind up there eventually.

Comment 16 Fedora Update System 2019-03-25 20:19:51 UTC
dracut-049-26.git20181204.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-38c666fc03

Comment 17 Adam Williamson 2019-03-25 20:33:43 UTC
In fact having looked at it, I think the dracut in f28 shouldn't be affected by this, for the record.

Comment 18 Russell Odom 2019-03-26 13:03:45 UTC
I'm also seeing this in F29 on install of kernel-core-5.0.3-200.fc29.x86_64. Trace the same as in comment 11.
After installing the packages from bodhi, I could "dnf reinstall kernel-core-5.0.3-200.fc29.x86_64" with no error. Thanks!

Comment 19 Fedora Update System 2019-03-27 04:34:18 UTC
dracut-049-26.git20181204.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-38c666fc03

Comment 20 Mark B 2019-03-28 01:19:30 UTC
confirming dracut-049-26.git20181204.fc29 is a working fix
although an alternant method was used.

 Booted to previous unaffected kernel (kernel-4.20.16-200.fc29) 
   uninstalled kernel-5.0.3-200.fc29 
     updated to dracut-049-26.git20181204.fc29
        installed kernel-5.0.4-200.fc29 from koji

Result : No error messages upon installation.

Comment 21 Fedora Update System 2019-03-29 02:59:03 UTC
dracut-049-26.git20181204.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.