Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1676427

Summary: [downstream clone - 4.2.8] Starting the HA VMs with lease is failing when using ovirt-ansible-disaster-recovery role
Product: Red Hat Enterprise Virtualization Manager Reporter: RHV bug bot <rhv-bugzilla-bot>
Component: ovirt-engineAssignee: Eyal Shenitzky <eshenitz>
Status: CLOSED ERRATA QA Contact: Yosi Ben Shimon <ybenshim>
Severity: high Docs Contact:
Priority: medium    
Version: 4.2.7CC: ebenahar, eshenitz, lsvaty, ratamir, Rhev-m-bugs, tnisan
Target Milestone: ovirt-4.2.8-3Keywords: ZStream
Target Release: ---Flags: lsvaty: testing_plan_complete-
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1653230 Environment:
Last Closed: 2019-03-05 11:09:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Storage RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1653230    
Bug Blocks:    

Description RHV bug bot 2019-02-12 09:22:39 UTC
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1653230 +++
======================================================================

Description of problem:

While importing the VM from the storage domain in the DR site and starting the same using ovirt-ansible-disaster-recovery role, the VM may fail to start with the error below. 

===
2018-11-26 02:02:53,670-05 WARN  [org.ovirt.engine.core.bll.RunVmCommand] (default task-38) [05a1b0c9-a098-413f-9a93-9d086096c345] Validation of action 'RunVm' failed for user admin@internal-authz. Reasons: VAR__ACTION__RUN,VAR__TYPE__VM,ACTION_TYPE_FAILED_INVALID_VM_LEASE
2018-11-26 02:02:53,670-05 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-38) [05a1b0c9-a098-413f-9a93-9d086096c345] EVENT_ID: USER_FAILED_RUN_VM(54), Failed to run VM ha_vm due to a failed validation: [Cannot run VM. Invalid VM lease. Please note that it may take few minutes to create the lease.] (User: admin@internal-authz).
===

The ansible is trying to start the VMs immediately after registering the same. However, by this time, the storage lease addition operation will be still going on for the VM and it will fail with the mentioned error.

Version-Release number of selected component (if applicable):

ovirt-ansible-roles-1.1.5-2.el7ev.noarch
RHV 4.2.7

How reproducible:

100 %

Steps to Reproduce:

1. Test the failover using ovirt-ansible-disaster-recovery role which is having HA VMs with the lease.
2. We can observe that these VMs will fail to start with the mentioned error.


Actual results:

HA VMs with the lease is failing to start during Active Passive DR failover.

Expected results:

HA VMs should start.

Additional info:

(Originally by Nijin Ashok)

Comment 2 RHV bug bot 2019-02-12 09:22:42 UTC
Tested using:
ovirt-engine-4.3.0.2-0.1.el7.noarch

A running HA VM on the primary site failover (and start) successfully on the secondary site.
Same result for failback.

Moving to VERIFIED

(Originally by Yosef Ben Shimon)

Comment 4 RHV bug bot 2019-02-12 09:22:48 UTC
In addition to comment #2:
Tested using:
ovirt-engine-4.3.0.2-0.1.el7.noarch
ansible-2.7.6-1.el7ae.noarch
ovirt-ansible-disaster-recovery-1.1.4-1.el7ev.noarch

(Originally by Yosef Ben Shimon)

Comment 6 Sandro Bonazzola 2019-02-15 14:01:49 UTC
Moving back to POST for ensuring this get visibility.
Are all the needed patches being backported to 4.2? Which packages needs to be rebuilt?

Comment 7 Eyal Shenitzky 2019-02-18 06:40:19 UTC
(In reply to Sandro Bonazzola from comment #6)
> Moving back to POST for ensuring this get visibility.
> Are all the needed patches being backported to 4.2? Which packages needs to
> be rebuilt?

Yes, all the patches are in.
The fix was only on the engine.

Comment 9 Yosi Ben Shimon 2019-02-26 07:47:24 UTC
Tested using:
ovirt-engine-4.2.8.5-0.1.el7ev.noarch
ansible-2.7.8-1.el7ae.noarch
ovirt-ansible-disaster-recovery-1.1.4-1.el7ev.noarch

A running HA VM on the primary site failover (and start) successfully on the secondary site.
Same result for failback.

Moving to VERIFIED

Comment 11 errata-xmlrpc 2019-03-05 11:09:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0459

Comment 12 Daniel Gur 2019-08-28 13:11:38 UTC
sync2jira

Comment 13 Daniel Gur 2019-08-28 13:15:51 UTC
sync2jira