Bug 1676439 - Can't complete initial-setup using ssh
Summary: Can't complete initial-setup using ssh
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: initial-setup
Version: 8.0
Hardware: s390x
OS: Unspecified
unspecified
high
Target Milestone: rc
: 8.0
Assignee: Martin Kolman
QA Contact: Release Test Team
Jiri Herrmann
URL:
Whiteboard:
: 1859600 (view as bug list)
Depends On: 1678941
Blocks: 1842946 1515824
TreeView+ depends on / blocked
 
Reported: 2019-02-12 10:01 UTC by Jiri Kortus
Modified: 2020-11-04 21:35 UTC (History)
12 users (show)

Fixed In Version: initial-setup-0.3.81.5-1
Doc Type: Bug Fix
Doc Text:
.RHEL 8 initial setup now works properly via SSH Previously, the RHEL 8 initial setup interface did not display when logged in to the system using SSH. As a consequence, it was impossible to perform the initial setup on a RHEL 8 machine managed via SSH. This problem has been fixed, and RHEL 8 initial setup now works correctly when performed via SSH.
Clone Of:
Environment:
Last Closed: 2020-11-04 03:36:18 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4754 0 None None None 2020-11-04 03:36:27 UTC

Description Jiri Kortus 2019-02-12 10:01:45 UTC
Description of problem:
It's not possible to do initial-setup configuration using ssh on RHEL-8.0.0-20190129.0 / s390x. initial-setup starts on the main console (ttyS0) after reboot to installed system, but doesn't start when logging in to the system via ssh (pts/0). After logging via ssh, only a warning message is printed and it's not possible to provide any input using ssh, moreover the initial-setup main menu (hub) is printed for a second time to the main console. I could at least finish initial-setup configuration using the main console though.

This is the warning after ssh login to the machine:
warning: consoletype is now deprecated, and will be removed in the near future!
warning: use tty (1) instead! More info: 'man 1 tty'


Version-Release number of selected component (if applicable):
initial-setup-0.3.62.1-1.el8.s390x

How reproducible:
Probably always.

Steps to Reproduce:
1. Install RHEL-8.0.0 on an s390x machine using kickstart with initial-setup package included, as well as 'firstboot --reconfig' kickstart command
2. Log in to the installed system for the first time using ssh


Actual results:
Just a warning appears, user can't finish initial-setup configuration using ssh.

Expected results:
User can successfully finish initial-setup configuration using ssh.

Comment 2 Peter Kotvan 2019-06-10 12:22:00 UTC
Take

Comment 5 Martin Kolman 2019-10-31 12:49:29 UTC
Doc text looks good to me.

Comment 17 Martin Kolman 2020-06-25 00:22:27 UTC
Should be fixed by the following pull request: https://github.com/rhinstaller/initial-setup/pull/103

Comment 23 Jan Stodola 2020-07-09 17:23:13 UTC
Moving to VERIFIED based on testing with initial-setup-0.3.81.5-1.el8.

Comment 26 Jan Stodola 2020-07-22 15:06:39 UTC
*** Bug 1859600 has been marked as a duplicate of this bug. ***

Comment 29 errata-xmlrpc 2020-11-04 03:36:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (initial-setup bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4754


Note You need to log in before you can comment on or make changes to this bug.