Bug 1676537 - kubapiserver.operator.openshift.io contains unsupportedConfigOverrides for oauth
Summary: kubapiserver.operator.openshift.io contains unsupportedConfigOverrides for oauth
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Auth
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.0
Assignee: Erica von Buelow
QA Contact: Chuan Yu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-12 13:59 UTC by Justin Pierce
Modified: 2019-06-04 10:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:07 UTC

Description Justin Pierce 2019-02-12 13:59:14 UTC
Description of problem:
kubapiserver.operator.openshift.io/cluster contains the section:

----
  unsupportedConfigOverrides:
    oauthConfig:
      masterCA: /etc/kubernetes/static-pod-resources/configmaps/client-ca/ca-bundle.crt
      masterPublicURL: https://rhcos-starter-int-1-api.cr.openshift.com:6443
      masterURL: https://rhcos-starter-int-1-api.cr.openshift.com:6443
----

Version-Release number of selected component (if applicable):
oc v4.0.0-0.164.0

How reproducible:
100% after clean install.


Steps to Reproduce:
1. Install a 4.0 cluster.
2. `oc edit kubeapiserver cluster` and check unsupportedConfigOverrides
3.

Actual results:
There are oauth settings.

Expected results:
This setting should be reserved for customer settings.


Additional info:
Unless this field is empty after an install, it becomes effectively impossible for a customer to programmatically manage necessary overrides.

Comment 1 Standa Laznicka 2019-02-12 14:17:20 UTC
Should be solved by https://github.com/openshift/cluster-authentication-operator/pull/59

Comment 2 Chuan Yu 2019-02-27 07:06:39 UTC
Verified.

$ oc get kubeapiserver cluster -o jsonpath={.spec.unsupportedConfigOverrides}
<nil>

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-02-26-125216   True        False         26m     Cluster version is 4.0.0-0.nightly-2019-02-26-125216

Comment 5 errata-xmlrpc 2019-06-04 10:44:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.