Bug 1676582 - hosted-engine --deploy uses inconsistent storage units (uses both GiB and GB)
Summary: hosted-engine --deploy uses inconsistent storage units (uses both GiB and GB)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: cockpit-ovirt
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ovirt-4.4.1
: 4.4.1
Assignee: Asaf Rachmani
QA Contact: Wei Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-12 15:35 UTC by Steve Goodman
Modified: 2020-08-04 13:26 UTC (History)
8 users (show)

Fixed In Version: cockpit-ovirt-0.14.9-1
Doc Type: Bug Fix
Doc Text:
Previously, the user interface used the wrong unit of measure for the VM memory size in the VM settings of Hosted Engine deployment via cockpit: It showed MB instead of MiB. The current release fixes this issue: It uses MiB as the unit of measure.
Clone Of:
Environment:
Last Closed: 2020-08-04 13:26:25 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)
picture (57.36 KB, image/png)
2019-12-18 07:35 UTC, Wei Wang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:3246 0 None None None 2020-08-04 13:26:51 UTC
oVirt gerrit 109839 0 master MERGED wizard: Change the memory unit size from MB to MiB 2020-09-22 06:46:13 UTC

Description Steve Goodman 2019-02-12 15:35:22 UTC
Description of problem:
The wizard that runs when you enter "hosted-engine --deploy" mentions storage sizes in several places. Sometimes the storage unit is GiB, and sometimes it's GB. This inconsistency is confusing and is potentially an unnecessary source of user error. 

How reproducible: 100%


Steps to Reproduce:
Run hosted-engine --deploy and notice the different area where units of storage are mentioned.

Actual results:
Here are some examples:

- I was prompted to enter the shared storage disk size in GiB.
- FROM SHE GUIDE: The following luns have been found on the requested target:
  [1] 360003ff44dc75adcb5046390a16b4beb   199GiB  MSFT   Virtual HD
- Please specify the size of the VM disk in GB: [50]:

Expected results:
Consistent terminology, unless there's a clearly called-out reason for the inconsistency.

Comment 2 Wei Wang 2019-10-30 06:25:13 UTC
QE cannot reproduce this bug, test info as blow:

Test Version
rhvh-4.3.7.0-0.20191024.0
ovirt-hosted-engine-ha-2.3.5-1.el7ev.noarch
ovirt-hosted-engine-setup-2.3.12-1.el7ev.noarch
rhvm-appliance-4.3-20191024.0.el7.x86_64

Test Steps:
1. Clean install rhvh-4.3.7.0-0.20191024.0
2. Prepare iscsi storage for hosted engine deployment
3. Run hosted-engine --deploy
4. Select iscsi storage type
5. Select the iscsi target and lun
6. Notice the different area where units of storage are mentioned.

Test Result:
Units of storage are consistently displayed. 

- The following luns have been found on the requested target:
          	[1]	36005076300810b3e000000000000029b	80GiB	IBM	2145
          		status: free, paths: 1 active
- Please specify the size of the VM disk in GiB: [58]: 

Steve, do you use the iscsi storage for this bug? Or some steps are not correct during the reproducing?

Comment 3 Steve Goodman 2019-10-30 11:01:28 UTC
I was using NFS storage. Other than that, your steps for reproducing look fine.

Comment 4 Wei Wang 2019-10-31 02:20:56 UTC
(In reply to Steve Goodman from comment #3)
> I was using NFS storage. Other than that, your steps for reproducing look
> fine.

Using NFS storage instead, QE still cannot reproduce this bug
-Please specify the size of the VM disk in GiB: [58]: 

Change flag to "-"

Comment 5 Wei Wang 2019-12-18 07:34:54 UTC
Test with rhvh-4.4.0.10-0.20191204.0, found a similar issue:

The memory size in VM settings of hosted enging deployment via cockpit. It displays as:
Memory Size(MiB) 16384 62,827MB available

Please refer the attachment picture.

Comment 6 Wei Wang 2019-12-18 07:35:31 UTC
Created attachment 1646023 [details]
picture

Comment 7 Sandro Bonazzola 2019-12-18 08:37:31 UTC
Let's handle all those labeling at once in this bug.

Comment 8 Sandro Bonazzola 2019-12-18 08:40:11 UTC
We need also to check if it's just labeling or calculations are done on assumptions of using Gib/Mib and getting wrongly inputs in Gb/Mb.
If we have this issue we need to backport this to zstream.

Comment 10 Wei Wang 2020-06-30 23:00:15 UTC
QE will verify this issue until the new build is coming.

Comment 11 Wei Wang 2020-07-02 02:25:21 UTC
Test with RHVH-4.4-20200701.0-RHVH-x86_64-dvd1.iso, cockpit-ovirt-dashboard-0.14.9-1.el8ev.noarch, bug is fixed, move it to "VERIFIED"

Comment 16 errata-xmlrpc 2020-08-04 13:26:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (RHV RHEL Host (ovirt-host) 4.4), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:3246


Note You need to log in before you can comment on or make changes to this bug.