Bug 1676687 - Log spam: origin-cluster-authetication-operator1 writing the same error every second [NEEDINFO]
Summary: Log spam: origin-cluster-authetication-operator1 writing the same error ever...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Auth
Version: 4.1.0
Hardware: x86_64
OS: Linux
medium
unspecified
Target Milestone: ---
: 4.1.0
Assignee: Erica von Buelow
QA Contact: Chuan Yu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-12 21:16 UTC by Mike Fiedler
Modified: 2019-06-04 10:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:00 UTC
Target Upstream Version:
evb: needinfo? (evb)


Attachments (Terms of Use)
pod logs (48.16 KB, application/gzip)
2019-02-12 21:16 UTC, Mike Fiedler
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:07 UTC

Description Mike Fiedler 2019-02-12 21:16:28 UTC
Created attachment 1534258 [details]
pod logs

Description of problem:

Every second, the origin-cluster-authentication-operator1 pod is writing the following three messages:

I0212 20:28:00.224530       1 reflector.go:169] Listing and watching *unstructured.Unstructured from github.com/openshift/cluster-authentication-operator/pkg/operator/starter.go:67                                                                                                     
E0212 20:28:00.230675       1 reflector.go:134] github.com/openshift/cluster-authentication-operator/pkg/operator/starter.go:67: Failed to list *unstructured.Unstructured: the server could not find the requested resource                                                             
I0212 20:28:00.624024       1 leaderelection.go:245] successfully renewed lease openshift-authentication-operator/cluster-osin-operator-lock

Is there an actual error here?   Full pod log attached.

Version-Release number of selected component (if applicable): 4.0.0-0.nightly-2019-02-11-235234


How reproducible: always


Steps to Reproduce:
1. Deploy a Next Gen cluster on AWS using the ART payload 4.0.0-0.nightly-2019-02-11-235234
2. oc oc logs  -n openshift-authentication-operator origin-cluster-authentication-operator1-754c66ccdd-8684h

Actual results:

Logs are full of the repeated error "Failed to list *unstructured.Unstructured: the server could not find the requested resource"

Expected results: Only real errors flagged in the logs.

Comment 1 Erica von Buelow 2019-02-12 21:26:43 UTC
That operator is going away. PR to remove it is waiting on an installer fix to merge.

Jira: https://jira.coreos.com/browse/AUTH-221

PR: https://github.com/openshift/cluster-authentication-operator/pull/59

blocked by: https://jira.coreos.com/browse/AUTH-244

Comment 4 scheng 2019-02-19 07:03:53 UTC
I see the PR: https://github.com/openshift/cluster-authentication-operator/pull/59 has been merged,but setting up a cluster with origin lastest release,those changes still not take effect.

I will check it later.

Comment 8 errata-xmlrpc 2019-06-04 10:44:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.